aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-11-13 16:23:14 +0100
committerKoen Kooi <koen@openembedded.org>2008-11-13 16:23:14 +0100
commit524610263d07eb2e76988e5484a6e1024c3889b1 (patch)
treeba0f59173e15589af617486051b1b17b947c83b5 /packages
parent3afce2b55b72176984f9ab383d62a67f5bc5ac71 (diff)
downloadopenembedded-524610263d07eb2e76988e5484a6e1024c3889b1.tar.gz
linux-omap git: update DSS2 patches
Diffstat (limited to 'packages')
-rw-r--r--packages/linux/linux-omap/0003-DSS-Documentation-for-OMAP2-3-display-subsystem.patch2
-rw-r--r--packages/linux/linux-omap/0004-DSS-New-display-subsystem-driver-for-OMAP2-3.patch35
-rw-r--r--packages/linux/linux-omap/0005-DSS-OMAPFB-fb-driver-for-new-display-subsystem.patch12
-rw-r--r--packages/linux/linux-omap/0006-DSS-Add-generic-DVI-panel.patch2
-rw-r--r--packages/linux/linux-omap/0007-DSS-support-for-Beagle-Board.patch2
-rw-r--r--packages/linux/linux-omap/0008-DSS-BEAGLE-Enable-DSS-in-beagle-defconfig.patch85
-rw-r--r--packages/linux/linux-omap/0009-DSS-support-for-OMAP3-SDP-board.patch12
-rw-r--r--packages/linux/linux-omap/beagleboard/defconfig2
-rw-r--r--packages/linux/linux-omap_git.bb2
9 files changed, 84 insertions, 70 deletions
diff --git a/packages/linux/linux-omap/0003-DSS-Documentation-for-OMAP2-3-display-subsystem.patch b/packages/linux/linux-omap/0003-DSS-Documentation-for-OMAP2-3-display-subsystem.patch
index 4946bda5e7..2ee2e2acce 100644
--- a/packages/linux/linux-omap/0003-DSS-Documentation-for-OMAP2-3-display-subsystem.patch
+++ b/packages/linux/linux-omap/0003-DSS-Documentation-for-OMAP2-3-display-subsystem.patch
@@ -1,4 +1,4 @@
-From 58be9dfad433036ff46ed883c3bc77fca88079f7 Mon Sep 17 00:00:00 2001
+From b6d4f19ae3192db2d7733fb70c212494bb1e0abd Mon Sep 17 00:00:00 2001
From: Tomi Valkeinen <tomi.valkeinen@nokia.com>
Date: Tue, 4 Nov 2008 15:08:07 +0200
Subject: [PATCH] DSS: Documentation for OMAP2/3 display subsystem
diff --git a/packages/linux/linux-omap/0004-DSS-New-display-subsystem-driver-for-OMAP2-3.patch b/packages/linux/linux-omap/0004-DSS-New-display-subsystem-driver-for-OMAP2-3.patch
index 509f34697a..461890343a 100644
--- a/packages/linux/linux-omap/0004-DSS-New-display-subsystem-driver-for-OMAP2-3.patch
+++ b/packages/linux/linux-omap/0004-DSS-New-display-subsystem-driver-for-OMAP2-3.patch
@@ -1,6 +1,6 @@
-From 5a4331bf757fdec0ceb72bf40f7e46ce5c404e2d Mon Sep 17 00:00:00 2001
+From 04b4d27af34373bbb65df19c2c084f117fe54213 Mon Sep 17 00:00:00 2001
From: Tomi Valkeinen <tomi.valkeinen@nokia.com>
-Date: Tue, 11 Nov 2008 13:52:25 +0200
+Date: Thu, 13 Nov 2008 15:38:15 +0200
Subject: [PATCH] DSS: New display subsystem driver for OMAP2/3
Signed-off-by: Tomi Valkeinen <tomi.valkeinen@nokia.com>
@@ -12,14 +12,14 @@ Signed-off-by: Tomi Valkeinen <tomi.valkeinen@nokia.com>
arch/arm/plat-omap/dss/dispc.c | 1720 ++++++++++++++++
arch/arm/plat-omap/dss/display.c | 775 ++++++++
arch/arm/plat-omap/dss/dpi.c | 323 +++
- arch/arm/plat-omap/dss/dsi.c | 3022 +++++++++++++++++++++++++++++
- arch/arm/plat-omap/dss/dss.c | 547 ++++++
+ arch/arm/plat-omap/dss/dsi.c | 3020 +++++++++++++++++++++++++++++
+ arch/arm/plat-omap/dss/dss.c | 554 ++++++
arch/arm/plat-omap/dss/dss.h | 254 +++
arch/arm/plat-omap/dss/rfbi.c | 1234 ++++++++++++
arch/arm/plat-omap/dss/sdi.c | 157 ++
arch/arm/plat-omap/dss/venc.c | 515 +++++
arch/arm/plat-omap/include/mach/display.h | 458 +++++
- 14 files changed, 9081 insertions(+), 0 deletions(-)
+ 14 files changed, 9086 insertions(+), 0 deletions(-)
create mode 100644 arch/arm/plat-omap/dss/Kconfig
create mode 100644 arch/arm/plat-omap/dss/Makefile
create mode 100644 arch/arm/plat-omap/dss/dispc.c
@@ -2978,10 +2978,10 @@ index 0000000..2261288
+
diff --git a/arch/arm/plat-omap/dss/dsi.c b/arch/arm/plat-omap/dss/dsi.c
new file mode 100644
-index 0000000..980be39
+index 0000000..9f31ac3
--- /dev/null
+++ b/arch/arm/plat-omap/dss/dsi.c
-@@ -0,0 +1,3022 @@
+@@ -0,0 +1,3020 @@
+/*
+ * linux/arch/arm/plat-omap/dss/dsi.c
+ *
@@ -3722,7 +3722,8 @@ index 0000000..980be39
+ continue;
+
+ if (min_fck_per_pck &&
-+ cur.dispc_fck < req_pck * min_fck_per_pck)
++ cur.dispc_fck <
++ req_pck * min_fck_per_pck)
+ continue;
+
+ match = 1;
@@ -3735,7 +3736,8 @@ index 0000000..980be39
+ cur.lck = cur.dispc_fck / cur.lck_div;
+ cur.pck = cur.lck / cur.pck_div;
+
-+ if (abs(cur.pck - req_pck) < abs(best.pck - req_pck)) {
++ if (abs(cur.pck - req_pck) <
++ abs(best.pck - req_pck)) {
+ best = cur;
+
+ if (cur.pck == req_pck)
@@ -5681,10 +5683,6 @@ index 0000000..980be39
+ if (display->ctrl && display->ctrl->disable)
+ display->ctrl->disable(display);
+
-+ /* XXX sleep a bit to make sure all DSI buffers are sent.
-+ * We should check it from somewhere, fifo fullness I guess */
-+ msleep(200);
-+
+ dsi_complexio_uninit();
+ dsi_pll_uninit();
+
@@ -6006,10 +6004,10 @@ index 0000000..980be39
+
diff --git a/arch/arm/plat-omap/dss/dss.c b/arch/arm/plat-omap/dss/dss.c
new file mode 100644
-index 0000000..da0364b
+index 0000000..8450ddd
--- /dev/null
+++ b/arch/arm/plat-omap/dss/dss.c
-@@ -0,0 +1,547 @@
+@@ -0,0 +1,554 @@
+/*
+ * linux/arch/arm/plat-omap/dss/dss.c
+ *
@@ -6344,6 +6342,13 @@ index 0000000..da0364b
+
+ enable_dss_clocks();
+
++ /* We need to wait here a bit, otherwise we sometimes start to get
++ * synclost errors. I believe we could wait for one framedone or
++ * perhaps vsync interrupt, but, because dispc is not initialized yet,
++ * we don't have access to the irq register.
++ */
++ msleep(40);
++
+ _omap_dss_reset();
+
+ /* autoidle */
diff --git a/packages/linux/linux-omap/0005-DSS-OMAPFB-fb-driver-for-new-display-subsystem.patch b/packages/linux/linux-omap/0005-DSS-OMAPFB-fb-driver-for-new-display-subsystem.patch
index 57a12c1a79..d64fe442f9 100644
--- a/packages/linux/linux-omap/0005-DSS-OMAPFB-fb-driver-for-new-display-subsystem.patch
+++ b/packages/linux/linux-omap/0005-DSS-OMAPFB-fb-driver-for-new-display-subsystem.patch
@@ -1,4 +1,4 @@
-From 538201a6cc52913c8165644d8c5ee1dd2c2b2a95 Mon Sep 17 00:00:00 2001
+From e2aaa3251054eecf92b8936e704a3581de69bdc7 Mon Sep 17 00:00:00 2001
From: Tomi Valkeinen <tomi.valkeinen@nokia.com>
Date: Tue, 4 Nov 2008 15:12:21 +0200
Subject: [PATCH] DSS: OMAPFB: fb driver for new display subsystem
@@ -92,11 +92,11 @@ index 90d63c5..1e34304 100644
struct omapfb_update_window {
diff --git a/drivers/video/Kconfig b/drivers/video/Kconfig
-index 0f13448..4b45731 100644
+index 3f3ce13..689a3b1 100644
--- a/drivers/video/Kconfig
+++ b/drivers/video/Kconfig
-@@ -2084,6 +2084,7 @@ config FB_METRONOME
- and could also have been called by some vendors as PVI-nnnn.
+@@ -2116,6 +2116,7 @@ config FB_PRE_INIT_FB
+ the bootloader.
source "drivers/video/omap/Kconfig"
+source "drivers/video/omap2/Kconfig"
@@ -104,7 +104,7 @@ index 0f13448..4b45731 100644
source "drivers/video/backlight/Kconfig"
source "drivers/video/display/Kconfig"
diff --git a/drivers/video/Makefile b/drivers/video/Makefile
-index 248bddc..4d69355 100644
+index e39e33e..3d9d50e 100644
--- a/drivers/video/Makefile
+++ b/drivers/video/Makefile
@@ -120,6 +120,7 @@ obj-$(CONFIG_FB_SM501) += sm501fb.o
@@ -114,7 +114,7 @@ index 248bddc..4d69355 100644
+obj-$(CONFIG_OMAP2_DSS) += omap2/
obj-$(CONFIG_XEN_FBDEV_FRONTEND) += xen-fbfront.o
obj-$(CONFIG_FB_CARMINE) += carminefb.o
-
+ obj-$(CONFIG_FB_MB862XX) += mb862xx/
diff --git a/drivers/video/omap/Kconfig b/drivers/video/omap/Kconfig
index c355b59..541fab3 100644
--- a/drivers/video/omap/Kconfig
diff --git a/packages/linux/linux-omap/0006-DSS-Add-generic-DVI-panel.patch b/packages/linux/linux-omap/0006-DSS-Add-generic-DVI-panel.patch
index 790cada121..4925f2437b 100644
--- a/packages/linux/linux-omap/0006-DSS-Add-generic-DVI-panel.patch
+++ b/packages/linux/linux-omap/0006-DSS-Add-generic-DVI-panel.patch
@@ -1,4 +1,4 @@
-From 36e83ecf4db86b61cec3bc9817d658d3ef218967 Mon Sep 17 00:00:00 2001
+From ce4676f5a466d991bccfeac2c32316053e86b9a1 Mon Sep 17 00:00:00 2001
From: Tomi Valkeinen <tomi.valkeinen@nokia.com>
Date: Tue, 11 Nov 2008 13:52:56 +0200
Subject: [PATCH] DSS: Add generic DVI panel
diff --git a/packages/linux/linux-omap/0007-DSS-support-for-Beagle-Board.patch b/packages/linux/linux-omap/0007-DSS-support-for-Beagle-Board.patch
index 145695cd8a..39670557b2 100644
--- a/packages/linux/linux-omap/0007-DSS-support-for-Beagle-Board.patch
+++ b/packages/linux/linux-omap/0007-DSS-support-for-Beagle-Board.patch
@@ -1,4 +1,4 @@
-From c5e43b2e4bc191feaab30e364c462a47aa3cc0a3 Mon Sep 17 00:00:00 2001
+From eaadaa1e6192ef58079fb6149136e4f267f771b0 Mon Sep 17 00:00:00 2001
From: Tomi Valkeinen <tomi.valkeinen@nokia.com>
Date: Mon, 29 Sep 2008 17:03:36 +0300
Subject: [PATCH] DSS: support for Beagle Board
diff --git a/packages/linux/linux-omap/0008-DSS-BEAGLE-Enable-DSS-in-beagle-defconfig.patch b/packages/linux/linux-omap/0008-DSS-BEAGLE-Enable-DSS-in-beagle-defconfig.patch
index f88abaacd4..a3df3ef562 100644
--- a/packages/linux/linux-omap/0008-DSS-BEAGLE-Enable-DSS-in-beagle-defconfig.patch
+++ b/packages/linux/linux-omap/0008-DSS-BEAGLE-Enable-DSS-in-beagle-defconfig.patch
@@ -1,14 +1,14 @@
-From 54f114db20a45e99389bec9c3c630c76f3e6c043 Mon Sep 17 00:00:00 2001
+From adf1ac7680926ca94f1b36ae8c643f74c8a47253 Mon Sep 17 00:00:00 2001
From: Tomi Valkeinen <tomi.valkeinen@nokia.com>
Date: Fri, 7 Nov 2008 16:54:01 +0200
Subject: [PATCH] DSS: BEAGLE: Enable DSS in beagle defconfig
---
- arch/arm/configs/omap3_beagle_defconfig | 143 ++++++++++++++++++++++---------
- 1 files changed, 103 insertions(+), 40 deletions(-)
+ arch/arm/configs/omap3_beagle_defconfig | 149 +++++++++++++++++++++----------
+ 1 files changed, 102 insertions(+), 47 deletions(-)
diff --git a/arch/arm/configs/omap3_beagle_defconfig b/arch/arm/configs/omap3_beagle_defconfig
-index df67296..5036233 100644
+index df67296..aa3ee12 100644
--- a/arch/arm/configs/omap3_beagle_defconfig
+++ b/arch/arm/configs/omap3_beagle_defconfig
@@ -1,7 +1,7 @@
@@ -16,8 +16,8 @@ index df67296..5036233 100644
# Automatically generated make config: don't edit
-# Linux kernel version: 2.6.27-omap1
-# Fri Oct 17 14:05:39 2008
-+# Linux kernel version: 2.6.28-rc3-omap1
-+# Tue Nov 11 14:30:05 2008
++# Linux kernel version: 2.6.28-rc4-omap1
++# Thu Nov 13 15:51:03 2008
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -71,7 +71,7 @@ index df67296..5036233 100644
#
# TI OMAP Implementations
-@@ -200,17 +194,27 @@ CONFIG_OMAP_DM_TIMER=y
+@@ -200,6 +194,14 @@ CONFIG_OMAP_DM_TIMER=y
# CONFIG_OMAP_LL_DEBUG_UART1 is not set
# CONFIG_OMAP_LL_DEBUG_UART2 is not set
CONFIG_OMAP_LL_DEBUG_UART3=y
@@ -86,12 +86,7 @@ index df67296..5036233 100644
CONFIG_ARCH_OMAP34XX=y
CONFIG_ARCH_OMAP3430=y
- #
- # OMAP Board Type
- #
-+# CONFIG_MACH_NOKIA_DFL61 is not set
- # CONFIG_MACH_OMAP_LDP is not set
- # CONFIG_MACH_OMAP_3430SDP is not set
+@@ -211,6 +213,7 @@ CONFIG_ARCH_OMAP3430=y
# CONFIG_MACH_OMAP3EVM is not set
CONFIG_MACH_OMAP3_BEAGLE=y
# CONFIG_MACH_OVERO is not set
@@ -99,7 +94,7 @@ index df67296..5036233 100644
CONFIG_OMAP_TICK_GPTIMER=12
#
-@@ -263,26 +267,30 @@ CONFIG_TICK_ONESHOT=y
+@@ -263,26 +266,30 @@ CONFIG_TICK_ONESHOT=y
CONFIG_NO_HZ=y
CONFIG_HIGH_RES_TIMERS=y
CONFIG_GENERIC_CLOCKEVENTS_BUILD=y
@@ -135,7 +130,7 @@ index df67296..5036233 100644
# CONFIG_LEDS is not set
CONFIG_ALIGNMENT_TRAP=y
-@@ -296,9 +304,10 @@ CONFIG_CMDLINE="root=/dev/nfs nfsroot=192.168.0.1:/home/user/buildroot ip=192.16
+@@ -296,9 +303,10 @@ CONFIG_CMDLINE="root=/dev/nfs nfsroot=192.168.0.1:/home/user/buildroot ip=192.16
# CONFIG_KEXEC is not set
#
@@ -147,7 +142,7 @@ index df67296..5036233 100644
#
# Floating point emulation
-@@ -318,6 +327,8 @@ CONFIG_VFPv3=y
+@@ -318,6 +326,8 @@ CONFIG_VFPv3=y
# Userspace binary formats
#
CONFIG_BINFMT_ELF=y
@@ -156,7 +151,7 @@ index df67296..5036233 100644
# CONFIG_BINFMT_AOUT is not set
CONFIG_BINFMT_MISC=y
-@@ -379,6 +390,7 @@ CONFIG_DEFAULT_TCP_CONG="cubic"
+@@ -379,6 +389,7 @@ CONFIG_DEFAULT_TCP_CONG="cubic"
# CONFIG_TIPC is not set
# CONFIG_ATM is not set
# CONFIG_BRIDGE is not set
@@ -164,7 +159,7 @@ index df67296..5036233 100644
# CONFIG_VLAN_8021Q is not set
# CONFIG_DECNET is not set
# CONFIG_LLC2 is not set
-@@ -399,11 +411,10 @@ CONFIG_DEFAULT_TCP_CONG="cubic"
+@@ -399,11 +410,10 @@ CONFIG_DEFAULT_TCP_CONG="cubic"
# CONFIG_IRDA is not set
# CONFIG_BT is not set
# CONFIG_AF_RXRPC is not set
@@ -179,7 +174,7 @@ index df67296..5036233 100644
# CONFIG_WIRELESS_EXT is not set
# CONFIG_MAC80211 is not set
# CONFIG_IEEE80211 is not set
-@@ -490,6 +501,7 @@ CONFIG_MTD_NAND=y
+@@ -490,6 +500,7 @@ CONFIG_MTD_NAND=y
# CONFIG_MTD_NAND_VERIFY_WRITE is not set
# CONFIG_MTD_NAND_ECC_SMC is not set
# CONFIG_MTD_NAND_MUSEUM_IDS is not set
@@ -187,7 +182,7 @@ index df67296..5036233 100644
CONFIG_MTD_NAND_OMAP2=y
CONFIG_MTD_NAND_IDS=y
# CONFIG_MTD_NAND_DISKONCHIP is not set
-@@ -743,6 +755,8 @@ CONFIG_GPIO_TWL4030=y
+@@ -743,6 +754,8 @@ CONFIG_GPIO_TWL4030=y
# CONFIG_W1 is not set
# CONFIG_POWER_SUPPLY is not set
# CONFIG_HWMON is not set
@@ -196,7 +191,7 @@ index df67296..5036233 100644
# CONFIG_WATCHDOG is not set
#
-@@ -760,10 +774,14 @@ CONFIG_SSB_POSSIBLE=y
+@@ -760,10 +773,14 @@ CONFIG_SSB_POSSIBLE=y
# CONFIG_HTC_EGPIO is not set
# CONFIG_HTC_PASIC3 is not set
CONFIG_TWL4030_CORE=y
@@ -211,7 +206,7 @@ index df67296..5036233 100644
#
# Multimedia devices
-@@ -790,6 +808,7 @@ CONFIG_DAB=y
+@@ -790,6 +807,7 @@ CONFIG_DAB=y
CONFIG_FB=y
# CONFIG_FIRMWARE_EDID is not set
# CONFIG_FB_DDC is not set
@@ -219,7 +214,7 @@ index df67296..5036233 100644
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
-@@ -810,10 +829,22 @@ CONFIG_FB_CFB_IMAGEBLIT=y
+@@ -810,10 +828,22 @@ CONFIG_FB_CFB_IMAGEBLIT=y
#
# CONFIG_FB_S1D13XXX is not set
# CONFIG_FB_VIRTUAL is not set
@@ -228,6 +223,7 @@ index df67296..5036233 100644
-# CONFIG_FB_OMAP_BOOTLOADER_INIT is not set
-CONFIG_FB_OMAP_CONSISTENT_DMA_SIZE=4
+# CONFIG_FB_METRONOME is not set
++# CONFIG_FB_MB862XX is not set
+CONFIG_FB_OMAP_CONSISTENT_DMA_SIZE=14
+CONFIG_FB_OMAP2=y
+# CONFIG_FB_OMAP2_DEBUG is not set
@@ -242,11 +238,10 @@ index df67296..5036233 100644
+CONFIG_PANEL_DVI_HIGHRES=y
+# CONFIG_PANEL_DVI_VERYHIGHRES is not set
+# CONFIG_PANEL_SDP3430 is not set
-+# CONFIG_PANEL_NEVADA is not set
# CONFIG_BACKLIGHT_LCD_SUPPORT is not set
#
-@@ -862,6 +893,8 @@ CONFIG_USB_OTG=y
+@@ -862,6 +892,8 @@ CONFIG_USB_OTG=y
# CONFIG_USB_OTG_WHITELIST is not set
# CONFIG_USB_OTG_BLACKLIST_HUB is not set
CONFIG_USB_MON=y
@@ -255,7 +250,7 @@ index df67296..5036233 100644
#
# USB Host Controller Drivers
-@@ -873,6 +906,7 @@ CONFIG_USB_MON=y
+@@ -873,6 +905,7 @@ CONFIG_USB_MON=y
# CONFIG_USB_OHCI_HCD is not set
# CONFIG_USB_SL811_HCD is not set
# CONFIG_USB_R8A66597_HCD is not set
@@ -263,7 +258,7 @@ index df67296..5036233 100644
CONFIG_USB_MUSB_HDRC=y
CONFIG_USB_MUSB_SOC=y
-@@ -895,6 +929,7 @@ CONFIG_USB_INVENTRA_DMA=y
+@@ -895,6 +928,7 @@ CONFIG_USB_INVENTRA_DMA=y
# CONFIG_USB_ACM is not set
# CONFIG_USB_PRINTER is not set
# CONFIG_USB_WDM is not set
@@ -271,7 +266,7 @@ index df67296..5036233 100644
#
# NOTE: USB_STORAGE enables SCSI, and 'SCSI disk support'
-@@ -923,6 +958,7 @@ CONFIG_USB_INVENTRA_DMA=y
+@@ -923,6 +957,7 @@ CONFIG_USB_INVENTRA_DMA=y
# CONFIG_USB_EMI62 is not set
# CONFIG_USB_EMI26 is not set
# CONFIG_USB_ADUTUX is not set
@@ -279,7 +274,7 @@ index df67296..5036233 100644
# CONFIG_USB_RIO500 is not set
# CONFIG_USB_LEGOTOWER is not set
# CONFIG_USB_LCD is not set
-@@ -939,22 +975,25 @@ CONFIG_USB_INVENTRA_DMA=y
+@@ -939,22 +974,25 @@ CONFIG_USB_INVENTRA_DMA=y
# CONFIG_USB_IOWARRIOR is not set
# CONFIG_USB_TEST is not set
# CONFIG_USB_ISIGHTFW is not set
@@ -312,7 +307,7 @@ index df67296..5036233 100644
# CONFIG_USB_GADGET_DUMMY_HCD is not set
CONFIG_USB_GADGET_DUALSPEED=y
# CONFIG_USB_ZERO is not set
-@@ -971,7 +1010,7 @@ CONFIG_MMC=y
+@@ -971,7 +1009,7 @@ CONFIG_MMC=y
# CONFIG_MMC_UNSAFE_RESUME is not set
#
@@ -321,7 +316,7 @@ index df67296..5036233 100644
#
CONFIG_MMC_BLOCK=y
CONFIG_MMC_BLOCK_BOUNCE=y
-@@ -979,10 +1018,12 @@ CONFIG_MMC_BLOCK_BOUNCE=y
+@@ -979,10 +1017,12 @@ CONFIG_MMC_BLOCK_BOUNCE=y
# CONFIG_MMC_TEST is not set
#
@@ -335,7 +330,7 @@ index df67296..5036233 100644
# CONFIG_NEW_LEDS is not set
CONFIG_RTC_LIB=y
CONFIG_RTC_CLASS=y
-@@ -1024,12 +1065,15 @@ CONFIG_RTC_DRV_TWL4030=y
+@@ -1024,26 +1064,22 @@ CONFIG_RTC_DRV_TWL4030=y
# Platform RTC drivers
#
# CONFIG_RTC_DRV_CMOS is not set
@@ -351,7 +346,21 @@ index df67296..5036233 100644
# CONFIG_RTC_DRV_V3020 is not set
#
-@@ -1059,11 +1103,12 @@ CONFIG_EXT2_FS=y
+ # on-CPU RTC drivers
+ #
+ # CONFIG_DMADEVICES is not set
+-
+-#
+-# Voltage and Current regulators
+-#
+ # CONFIG_REGULATOR is not set
+-# CONFIG_REGULATOR_FIXED_VOLTAGE is not set
+-# CONFIG_REGULATOR_VIRTUAL_CONSUMER is not set
+-# CONFIG_REGULATOR_BQ24022 is not set
+ # CONFIG_UIO is not set
+
+ #
+@@ -1059,11 +1095,12 @@ CONFIG_EXT2_FS=y
# CONFIG_EXT2_FS_XIP is not set
CONFIG_EXT3_FS=y
# CONFIG_EXT3_FS_XATTR is not set
@@ -365,7 +374,7 @@ index df67296..5036233 100644
# CONFIG_XFS_FS is not set
# CONFIG_OCFS2_FS is not set
CONFIG_DNOTIFY=y
-@@ -1100,6 +1145,7 @@ CONFIG_FAT_DEFAULT_IOCHARSET="iso8859-1"
+@@ -1100,6 +1137,7 @@ CONFIG_FAT_DEFAULT_IOCHARSET="iso8859-1"
#
CONFIG_PROC_FS=y
CONFIG_PROC_SYSCTL=y
@@ -373,7 +382,7 @@ index df67296..5036233 100644
CONFIG_SYSFS=y
CONFIG_TMPFS=y
# CONFIG_TMPFS_POSIX_ACL is not set
-@@ -1148,6 +1194,7 @@ CONFIG_LOCKD_V4=y
+@@ -1148,6 +1186,7 @@ CONFIG_LOCKD_V4=y
CONFIG_NFS_COMMON=y
CONFIG_SUNRPC=y
CONFIG_SUNRPC_GSS=y
@@ -381,7 +390,7 @@ index df67296..5036233 100644
CONFIG_RPCSEC_GSS_KRB5=y
# CONFIG_RPCSEC_GSS_SPKM3 is not set
# CONFIG_SMB_FS is not set
-@@ -1260,15 +1307,23 @@ CONFIG_DEBUG_INFO=y
+@@ -1260,15 +1299,23 @@ CONFIG_DEBUG_INFO=y
CONFIG_FRAME_POINTER=y
# CONFIG_BOOT_PRINTK_DELAY is not set
# CONFIG_RCU_TORTURE_TEST is not set
@@ -408,7 +417,7 @@ index df67296..5036233 100644
# CONFIG_SAMPLES is not set
CONFIG_HAVE_ARCH_KGDB=y
# CONFIG_KGDB is not set
-@@ -1282,14 +1337,19 @@ CONFIG_HAVE_ARCH_KGDB=y
+@@ -1282,14 +1329,19 @@ CONFIG_HAVE_ARCH_KGDB=y
#
# CONFIG_KEYS is not set
# CONFIG_SECURITY is not set
@@ -428,7 +437,7 @@ index df67296..5036233 100644
CONFIG_CRYPTO_MANAGER=y
# CONFIG_CRYPTO_GF128MUL is not set
# CONFIG_CRYPTO_NULL is not set
-@@ -1362,14 +1422,17 @@ CONFIG_CRYPTO_DES=y
+@@ -1362,14 +1414,17 @@ CONFIG_CRYPTO_DES=y
#
# CONFIG_CRYPTO_DEFLATE is not set
# CONFIG_CRYPTO_LZO is not set
diff --git a/packages/linux/linux-omap/0009-DSS-support-for-OMAP3-SDP-board.patch b/packages/linux/linux-omap/0009-DSS-support-for-OMAP3-SDP-board.patch
index 4c22a89929..981a2021b3 100644
--- a/packages/linux/linux-omap/0009-DSS-support-for-OMAP3-SDP-board.patch
+++ b/packages/linux/linux-omap/0009-DSS-support-for-OMAP3-SDP-board.patch
@@ -1,4 +1,4 @@
-From b51518d69d562d275afc830373710417e507c613 Mon Sep 17 00:00:00 2001
+From 0938c1e91fe69da535e06d092bdec6fcc95ad650 Mon Sep 17 00:00:00 2001
From: Tomi Valkeinen <tomi.valkeinen@nokia.com>
Date: Mon, 20 Oct 2008 13:13:15 +0300
Subject: [PATCH] DSS: support for OMAP3 SDP board
@@ -13,7 +13,7 @@ Signed-off-by: Tomi Valkeinen <tomi.valkeinen@nokia.com>
create mode 100644 drivers/video/omap2/panel-sdp3430.c
diff --git a/arch/arm/mach-omap2/board-3430sdp.c b/arch/arm/mach-omap2/board-3430sdp.c
-index 7ee85e9..f226a55 100644
+index 7ee85e9..3a644b1 100644
--- a/arch/arm/mach-omap2/board-3430sdp.c
+++ b/arch/arm/mach-omap2/board-3430sdp.c
@@ -40,6 +40,8 @@
@@ -111,7 +111,7 @@ index 7ee85e9..f226a55 100644
+ return -EINVAL;
+ }
+
-+ if (system_rev > OMAP3430_REV_ES1_0) {
++ if (omap_rev() > OMAP3430_REV_ES1_0) {
+ t2_out(PM_RECEIVER, ENABLE_VPLL2_DEDICATED,
+ TWL4030_VPLL2_DEDICATED);
+ t2_out(PM_RECEIVER, ENABLE_VPLL2_DEV_GRP,
@@ -143,7 +143,7 @@ index 7ee85e9..f226a55 100644
+ gpio_direction_output(enable_gpio, 0);
+ gpio_direction_output(backlight_gpio, 0);
+
-+ if (system_rev > OMAP3430_REV_ES1_0) {
++ if (omap_rev() > OMAP3430_REV_ES1_0) {
+ t2_out(PM_RECEIVER, 0x0, TWL4030_VPLL2_DEDICATED);
+ t2_out(PM_RECEIVER, 0x0, TWL4030_VPLL2_DEV_GRP);
+ mdelay(4);
@@ -166,7 +166,7 @@ index 7ee85e9..f226a55 100644
+ return -EINVAL;
+ }
+
-+ if (system_rev > OMAP3430_REV_ES1_0) {
++ if (omap_rev() > OMAP3430_REV_ES1_0) {
+ t2_out(PM_RECEIVER, ENABLE_VPLL2_DEDICATED,
+ TWL4030_VPLL2_DEDICATED);
+ t2_out(PM_RECEIVER, ENABLE_VPLL2_DEV_GRP,
@@ -182,7 +182,7 @@ index 7ee85e9..f226a55 100644
+{
+ dvi_enabled = 0;
+
-+ if (system_rev > OMAP3430_REV_ES1_0) {
++ if (omap_rev() > OMAP3430_REV_ES1_0) {
+ t2_out(PM_RECEIVER, 0x0, TWL4030_VPLL2_DEDICATED);
+ t2_out(PM_RECEIVER, 0x0, TWL4030_VPLL2_DEV_GRP);
+ mdelay(4);
diff --git a/packages/linux/linux-omap/beagleboard/defconfig b/packages/linux/linux-omap/beagleboard/defconfig
index 22c29fb23c..ce06b21672 100644
--- a/packages/linux/linux-omap/beagleboard/defconfig
+++ b/packages/linux/linux-omap/beagleboard/defconfig
@@ -206,7 +206,7 @@ CONFIG_OMAP2_DSS_VENC=y
CONFIG_OMAP2_DSS_DSI=y
CONFIG_OMAP2_DSS_USE_DSI_PLL=y
# CONFIG_OMAP2_DSS_FAKE_VSYNC is not set
-CONFIG_OMAP2_DSS_MIN_FCK_PER_PCK=4
+CONFIG_OMAP2_DSS_MIN_FCK_PER_PCK=2
CONFIG_ARCH_OMAP34XX=y
CONFIG_ARCH_OMAP3430=y
diff --git a/packages/linux/linux-omap_git.bb b/packages/linux/linux-omap_git.bb
index 109dcdffd8..dd5016336a 100644
--- a/packages/linux/linux-omap_git.bb
+++ b/packages/linux/linux-omap_git.bb
@@ -10,7 +10,7 @@ SRCREV = "444fcab6e8f8bad4ffc50feb91516c246d91e901"
PV = "2.6.27+2.6.28-rc3+${PR}+gitr${SRCREV}"
#PV = "2.6.27+${PR}+gitr${SRCREV}"
-PR = "r2"
+PR = "r3"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
file://defconfig"