aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-12-04 21:15:56 +0100
committerRobert Schuster <thebohemian@gmx.net>2008-12-04 21:15:56 +0100
commitb700177bbb91519d6dc5e4a9a8dc1711b4ef7483 (patch)
tree6540e23c687146771d6b9fc070677bf3dbb4bebf /packages
parentea90cfd7f46fee76c8d40f20509be9c589f1b4b6 (diff)
downloadopenembedded-b700177bbb91519d6dc5e4a9a8dc1711b4ef7483.tar.gz
midpath-core 0.2+03rc2: Added patch to fix file opening.
Diffstat (limited to 'packages')
-rw-r--r--packages/midpath/files/fix-openfile.patch13
-rw-r--r--packages/midpath/midpath-core_0.2+0.3rc2.bb3
2 files changed, 15 insertions, 1 deletions
diff --git a/packages/midpath/files/fix-openfile.patch b/packages/midpath/files/fix-openfile.patch
new file mode 100644
index 0000000000..6b9b8be237
--- /dev/null
+++ b/packages/midpath/files/fix-openfile.patch
@@ -0,0 +1,13 @@
+Index: midpath-0.3rc2/components/core/src/org/thenesis/midpath/io/backend/j2se/FileHandlerImpl.java
+===================================================================
+--- midpath-0.3rc2.orig/components/core/src/org/thenesis/midpath/io/backend/j2se/FileHandlerImpl.java 2008-12-04 21:10:39.000000000 +0100
++++ midpath-0.3rc2/components/core/src/org/thenesis/midpath/io/backend/j2se/FileHandlerImpl.java 2008-12-04 21:12:11.000000000 +0100
+@@ -182,7 +182,7 @@
+ public void openForRead() throws IOException {
+ if (randomAccessFile == null) {
+ //stream = new FileRandomAccessStream(file);
+- randomAccessFile = new RandomAccessFile(file, "rws");
++ randomAccessFile = new RandomAccessFile(file, "r");
+ }
+ }
+
diff --git a/packages/midpath/midpath-core_0.2+0.3rc2.bb b/packages/midpath/midpath-core_0.2+0.3rc2.bb
index 1a6fee82cd..d4d6b6b939 100644
--- a/packages/midpath/midpath-core_0.2+0.3rc2.bb
+++ b/packages/midpath/midpath-core_0.2+0.3rc2.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "MIDPath is a Java library which provides a MIDP2 implementation"
-PR = "r0"
+PR = "r1"
SRC_URI = "${SOURCEFORGE_MIRROR}/midpath/midpath-0.3rc2.tar.gz"
@@ -9,6 +9,7 @@ S = "${WORKDIR}/midpath-0.3rc2"
require midpath-common.inc
SRC_URI += "\
+ file://fix-openfile.patch;patch=1 \
file://midpath-suitemanager \
file://midpath-launcher-j2se \
file://midpath-suitemanager.desktop \