aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-01-18 19:08:01 +0100
committerKoen Kooi <koen@openembedded.org>2009-01-18 19:08:01 +0100
commit5b484aec0a3167bc7df53094958fefbba977aac9 (patch)
tree433ea556e495cb11de57be03c4452ec2ba3ddb34 /packages
parent1b26f047125a2abd85e1c27a758c885f91a2b9b4 (diff)
downloadopenembedded-5b484aec0a3167bc7df53094958fefbba977aac9.tar.gz
openldap: make it build with a recent autofoo and ship initscript, also fix copy/paste error (it's 'openldap', not 'acpid')
Diffstat (limited to 'packages')
-rw-r--r--packages/openldap/openldap_2.3.11.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/packages/openldap/openldap_2.3.11.bb b/packages/openldap/openldap_2.3.11.bb
index 9f8b5edf74..fb980cb946 100644
--- a/packages/openldap/openldap_2.3.11.bb
+++ b/packages/openldap/openldap_2.3.11.bb
@@ -217,6 +217,11 @@ PACKAGES += "${PN}-overlay-proxycache"
EXTRA_OECONF += "${OPENLDAP_OPTIONS}"
DEPENDS += "${OPENLDAP_DEPENDS}"
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
#FIXME: this is a hack, at present an openldap build will pick up the header
# files from staging rather than the local ones (bad -I order), so remove
# the headers (from openldap-old.x) before compiling...
@@ -255,7 +260,7 @@ PACKAGES += "${PN}-slapd ${PN}-slurpd ${PN}-bin"
# Package contents - shift most standard contents to -bin
FILES_${PN} = "${libdir}/lib*.so.* ${sysconfdir}/openldap/ldap.* ${localstatedir}/openldap-data"
-FILES_${PN}-slapd = "${libexecdir}/slapd ${sbindir} ${localstatedir}/run \
+FILES_${PN}-slapd = "${sysconfdir}/init.d ${libexecdir}/slapd ${sbindir} ${localstatedir}/run \
${sysconfdir}/openldap/slapd.* ${sysconfdir}/openldap/schema \
${sysconfdir}/openldap/DB_CONFIG.example"
FILES_${PN}-slurpd = "${libexecdir}/slurpd ${localstatedir}/openldap-slurp ${localstatedir}/run"
@@ -270,16 +275,16 @@ do_install_append() {
rm -f ${D}${localstatedir}/openldap-data/DB_CONFIG.example
}
-pkg_postinst () {
+pkg_postinst_${PN}-slapd () {
if test -n "${D}"; then
D="-r $D"
fi
- update-rc.d $D acpid defaults
+ update-rc.d $D openldap defaults
}
-pkg_prerm () {
+pkg_prerm_${PN}-slapd () {
if test -n "${D}"; then
D="-r $D"
fi
- update-rc.d $D acpid remove
+ update-rc.d $D openldap remove
}