aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-12-08 15:55:04 +0100
committerKoen Kooi <koen@openembedded.org>2008-12-08 15:55:04 +0100
commitcae53ca9a21ed9b79e3d3dfdbe8870e3fe34463a (patch)
treeb6bf001e9415a9645b3613abe8571759c3b350d8 /packages
parent5b1ed09b1ab1a60a28a76e4658bc9957cd361b5d (diff)
downloadopenembedded-cae53ca9a21ed9b79e3d3dfdbe8870e3fe34463a.tar.gz
linux-omap git: add patch to fix DPLL reprogramming
Diffstat (limited to 'packages')
-rw-r--r--packages/linux/linux-omap/fix-dpll-m4.diff37
-rw-r--r--packages/linux/linux-omap_git.bb3
2 files changed, 39 insertions, 1 deletions
diff --git a/packages/linux/linux-omap/fix-dpll-m4.diff b/packages/linux/linux-omap/fix-dpll-m4.diff
new file mode 100644
index 0000000000..1fa3bfe7fe
--- /dev/null
+++ b/packages/linux/linux-omap/fix-dpll-m4.diff
@@ -0,0 +1,37 @@
+From linux-omap-owner@vger.kernel.org Mon Dec 08 14:41:05 2008
+
+This fixes commit e42218d45afbc3e654e289e021e6b80c657b16c2. The commit
+was based on old kernel tree, and with bad luck applied ok but to wrong
+position, modifying dpll4_m6_ck instead of dpll4_m4_ck.
+
+Signed-off-by: Tomi Valkeinen <tomi.valkeinen@nokia.com>
+---
+ arch/arm/mach-omap2/clock34xx.h | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/arch/arm/mach-omap2/clock34xx.h b/arch/arm/mach-omap2/clock34xx.h
+index 1c2b49f..5357507 100644
+--- a/arch/arm/mach-omap2/clock34xx.h
++++ b/arch/arm/mach-omap2/clock34xx.h
+@@ -825,6 +825,8 @@ static struct clk dpll4_m4_ck = {
+ PARENT_CONTROLS_CLOCK,
+ .clkdm = { .name = "dpll4_clkdm" },
+ .recalc = &omap2_clksel_recalc,
++ .set_rate = &omap2_clksel_set_rate,
++ .round_rate = &omap2_clksel_round_rate,
+ };
+
+ /* The PWRDN bit is apparently only available on 3430ES2 and above */
+@@ -879,8 +881,6 @@ static struct clk dpll4_m6_ck = {
+ PARENT_CONTROLS_CLOCK,
+ .clkdm = { .name = "dpll4_clkdm" },
+ .recalc = &omap2_clksel_recalc,
+- .set_rate = &omap2_clksel_set_rate,
+- .round_rate = &omap2_clksel_round_rate,
+ };
+
+ /* The PWRDN bit is apparently only available on 3430ES2 and above */
+--
+1.6.0.3
+
+
diff --git a/packages/linux/linux-omap_git.bb b/packages/linux/linux-omap_git.bb
index e229622b39..5ad4bc1544 100644
--- a/packages/linux/linux-omap_git.bb
+++ b/packages/linux/linux-omap_git.bb
@@ -10,7 +10,7 @@ SRCREV = "014ba70469e889ebb74516052c43fd06a419b17b"
PV = "2.6.27+2.6.28-rc7+${PR}+gitr${SRCREV}"
#PV = "2.6.27+${PR}+gitr${SRCREV}"
-PR = "r5"
+PR = "r6"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
file://defconfig"
@@ -40,6 +40,7 @@ SRC_URI_append = " \
http://www.bat.org/~tomba/git/0001-DSS-OMAPFB-Check-that-var-pixclock-is-not-zero.patch;patch=1 \
file://twl-asoc-fix-record.diff;patch=1 \
file://tick-schedc-suppress-needless-timer-reprogramming.patch;patch=1 \
+ file://fix-dpll-m4.diff;patch=1 \
"