aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-04 20:47:30 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-04 20:47:30 +0000
commit40f235ee23e7ed72a7e28c16dbcb2a1d2d02a6d3 (patch)
treedd55163ac604cc01acd585be0f04b9f47e9fbc28 /packages
parentec05f60b2a11d52a01a4a39c8057f608d7da1c9d (diff)
parentcfdf930c72da72af054ccb53e29f63e1174d3679 (diff)
downloadopenembedded-40f235ee23e7ed72a7e28c16dbcb2a1d2d02a6d3.tar.gz
merge of '15632785e576f4fbbf9cdccf18d8aae806bec193'
and 'dace6576f510b1f3af99d9580e3f0d3d18a773b1'
Diffstat (limited to 'packages')
-rw-r--r--packages/gtk+/files/lower-quality-scaling-in-pixbuf-engine.patch13
-rw-r--r--packages/gtk+/gtk+_2.10.14.bb7
-rw-r--r--packages/psplash/psplash_svn.bb7
-rw-r--r--packages/sysvinit/sysvinit/openmoko/.mtn2git_empty0
-rwxr-xr-xpackages/sysvinit/sysvinit/openmoko/rc176
-rwxr-xr-xpackages/sysvinit/sysvinit/openmoko/rcS56
-rw-r--r--packages/tslib/tslib_1.0.bb3
7 files changed, 23 insertions, 239 deletions
diff --git a/packages/gtk+/files/lower-quality-scaling-in-pixbuf-engine.patch b/packages/gtk+/files/lower-quality-scaling-in-pixbuf-engine.patch
new file mode 100644
index 0000000000..6cf1c14991
--- /dev/null
+++ b/packages/gtk+/files/lower-quality-scaling-in-pixbuf-engine.patch
@@ -0,0 +1,13 @@
+Index: gtk+-2.6.10/modules/engines/pixbuf/pixbuf-render.c
+===================================================================
+--- gtk+-2.6.10.orig/modules/engines/pixbuf/pixbuf-render.c 2005-08-18 14:11:00.000000000 +0000
++++ gtk+-2.6.10/modules/engines/pixbuf/pixbuf-render.c 2007-05-24 11:16:50.000000000 +0000
+@@ -407,7 +407,7 @@
+ 0, 0, rect.width, rect.height,
+ dest_x - rect.x, dest_y - rect.y,
+ x_scale, y_scale,
+- GDK_INTERP_BILINEAR);
++ GDK_INTERP_NEAREST);
+
+ g_object_unref (partial_src);
+
diff --git a/packages/gtk+/gtk+_2.10.14.bb b/packages/gtk+/gtk+_2.10.14.bb
index 3aaa0d6bec..bee625646f 100644
--- a/packages/gtk+/gtk+_2.10.14.bb
+++ b/packages/gtk+/gtk+_2.10.14.bb
@@ -1,6 +1,6 @@
require gtk-2.10.inc
-PR = "r1"
+PR = "r2"
# disable per default - untested and not all patches included.
DEFAULT_PREFERENCE = "-1"
@@ -31,3 +31,8 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.10/gtk+-${PV}.tar.bz2 \
#check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
require gtk-fpu.inc
EXTRA_OECONF += "${@get_gtk_fpu_setting(bb, d)}"
+
+# try to squeeze some more performance out of it
+SRC_URI_append_fic-gta01 = " file://lower-quality-scaling-in-pixbuf-engine.patch;patch=1"
+SRC_URI_append_fic-gta02 = " file://lower-quality-scaling-in-pixbuf-engine.patch;patch=1"
+
diff --git a/packages/psplash/psplash_svn.bb b/packages/psplash/psplash_svn.bb
index fb7627f631..6c0f2028dc 100644
--- a/packages/psplash/psplash_svn.bb
+++ b/packages/psplash/psplash_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
SECTION = "base"
LICENSE = "GPL"
PV = "0.0+svn${SRCDATE}"
-PR = "r6"
+PR = "r7"
# You can create your own pslash-hand-img.h by doing
# ./make-image-header.sh <file>.png HAND
@@ -13,11 +13,10 @@ PR = "r6"
SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
file://psplash-hand-img.h \
file://psplash-bar-img.h \
- file://psplash-init "
+ file://psplash-init"
S = "${WORKDIR}/psplash"
-# for now only GTA01, later use openmoko distro override
-SRC_URI_append_fic-gta01 = "file://configurability.patch;patch=1 "
+SRC_URI_append_openmoko = " file://configurability.patch;patch=1 "
inherit autotools pkgconfig update-rc.d
diff --git a/packages/sysvinit/sysvinit/openmoko/.mtn2git_empty b/packages/sysvinit/sysvinit/openmoko/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/sysvinit/sysvinit/openmoko/.mtn2git_empty
+++ /dev/null
diff --git a/packages/sysvinit/sysvinit/openmoko/rc b/packages/sysvinit/sysvinit/openmoko/rc
deleted file mode 100755
index 30b69ad516..0000000000
--- a/packages/sysvinit/sysvinit/openmoko/rc
+++ /dev/null
@@ -1,176 +0,0 @@
-#!/bin/sh
-#
-# rc This file is responsible for starting/stopping
-# services when the runlevel changes.
-#
-# Optimization feature:
-# A startup script is _not_ run when the service was
-# running in the previous runlevel and it wasn't stopped
-# in the runlevel transition (most Debian services don't
-# have K?? links in rc{1,2,3,4,5} )
-#
-# Author: Miquel van Smoorenburg <miquels@cistron.nl>
-# Bruce Perens <Bruce@Pixar.com>
-#
-# Version: @(#)rc 2.78 07-Nov-1999 miquels@cistron.nl
-#
-
-. /etc/default/rcS
-export VERBOSE
-
-startup_progress() {
- step=$(($step + $step_change))
- if [ "$num_steps" != "0" ]; then
- progress=$((($step * $progress_size / $num_steps) + $first_step))
- else
- progress=$progress_size
- fi
- #echo "PROGRESS is $progress $runlevel $first_step + ($step of $num_steps) $step_change $progress_size"
- if type psplash-write >/dev/null 2>&1; then
- TMPDIR=/mnt/.psplash psplash-write "PROGRESS $progress" || true
- fi
-}
-
-
-#
-# Start script or program.
-#
-startup() {
- # Handle verbosity
- [ "$VERBOSE" = very ] && echo "INIT: Running $@..."
-
- case "$1" in
- *.sh)
- # Source shell script for speed.
- (
- trap - INT QUIT TSTP
- scriptname=$1
- shift
- . $scriptname
- )
- ;;
- *)
- "$@"
- ;;
- esac
- startup_progress
-}
-
- # Ignore CTRL-C only in this shell, so we can interrupt subprocesses.
- trap ":" INT QUIT TSTP
-
- # Set onlcr to avoid staircase effect.
- stty onlcr 0>&1
-
- # Now find out what the current and what the previous runlevel are.
-
- runlevel=$RUNLEVEL
- # Get first argument. Set new runlevel to this argument.
- [ "$1" != "" ] && runlevel=$1
- if [ "$runlevel" = "" ]
- then
- echo "Usage: $0 <runlevel>" >&2
- exit 1
- fi
- previous=$PREVLEVEL
- [ "$previous" = "" ] && previous=N
-
- export runlevel previous
-
- # Is there an rc directory for this new runlevel?
- if [ -d /etc/rc$runlevel.d ]
- then
- # Find out where in the progress bar the initramfs got to.
- PROGRESS_STATE=0
- #if [ -f /dev/.initramfs/progress_state ]; then
- # . /dev/.initramfs/progress_state
- #fi
-
- # Split the remaining portion of the progress bar into thirds
- progress_size=$(((100 - $PROGRESS_STATE) / 3))
-
- case "$runlevel" in
- 0|6)
- # Count down from -100 to 0 and use the entire bar
- first_step=-100
- progress_size=100
- step_change=1
- ;;
- S)
- # Begin where the initramfs left off and use 2/3
- # of the remaining space
- first_step=$PROGRESS_STATE
- progress_size=$(($progress_size * 2))
- step_change=1
- ;;
- *)
- # Begin where rcS left off and use the final 1/3 of
- # the space (by leaving progress_size unchanged)
- first_step=$(($progress_size * 2 + $PROGRESS_STATE))
- step_change=1
- ;;
- esac
-
- num_steps=0
- for s in /etc/rc$runlevel.d/[SK]*; do
- case "${s##/etc/rc$runlevel.d/S??}" in
- gdm|xdm|kdm|reboot|halt)
- break
- ;;
- esac
- num_steps=$(($num_steps + 1))
- done
- step=0
-
- # First, run the KILL scripts.
- if [ $previous != N ]
- then
- for i in /etc/rc$runlevel.d/K[0-9][0-9]*
- do
- # Check if the script is there.
- [ ! -f $i ] && continue
-
- # Stop the service.
- startup $i stop
- done
- fi
-
- # Now run the START scripts for this runlevel.
- for i in /etc/rc$runlevel.d/S*
- do
- [ ! -f $i ] && continue
-
- if [ $previous != N ] && [ $previous != S ]
- then
- #
- # Find start script in previous runlevel and
- # stop script in this runlevel.
- #
- suffix=${i#/etc/rc$runlevel.d/S[0-9][0-9]}
- stop=/etc/rc$runlevel.d/K[0-9][0-9]$suffix
- previous_start=/etc/rc$previous.d/S[0-9][0-9]$suffix
- #
- # If there is a start script in the previous level
- # and _no_ stop script in this level, we don't
- # have to re-start the service.
- #
- [ -f $previous_start ] && [ ! -f $stop ] && continue
- fi
- case "$runlevel" in
- 0|6)
- startup $i stop
- ;;
- *)
- startup $i start
- ;;
- esac
- done
- fi
-
-#Uncomment to cause psplash to exit manually, otherwise it exits when it sees a VC switch
-#if [ "x$runlevel" != "xS" ]; then
-# if type psplash-write >/dev/null 2>&1; then
-# TMPDIR=/mnt/.psplash psplash-write "QUIT" || true
-# umount /mnt/.psplash
-# fi
-#fi
diff --git a/packages/sysvinit/sysvinit/openmoko/rcS b/packages/sysvinit/sysvinit/openmoko/rcS
deleted file mode 100755
index 90af4149e4..0000000000
--- a/packages/sysvinit/sysvinit/openmoko/rcS
+++ /dev/null
@@ -1,56 +0,0 @@
-#!/bin/sh
-#
-# rcS Call all S??* scripts in /etc/rcS.d in
-# numerical/alphabetical order.
-#
-# Version: @(#)/etc/init.d/rcS 2.76 19-Apr-1999 miquels@cistron.nl
-#
-
-PATH=/sbin:/bin:/usr/sbin:/usr/bin
-runlevel=S
-prevlevel=N
-umask 022
-export PATH runlevel prevlevel
-
-# Make sure proc is mounted
-#
-[ -d "/proc/1" ] || mount /proc
-
-#
-# See if system needs to be setup. This is ONLY meant to
-# be used for the initial setup after a fresh installation!
-#
-if [ -x /sbin/unconfigured.sh ]
-then
- /sbin/unconfigured.sh
-fi
-
-#
-# Source defaults.
-#
-. /etc/default/rcS
-
-#
-# Trap CTRL-C &c only in this shell so we can interrupt subprocesses.
-#
-trap ":" INT QUIT TSTP
-
-#
-# Call all parts in order.
-#
-exec /etc/init.d/rc S
-
-#
-# For compatibility, run the files in /etc/rc.boot too.
-#
-[ -d /etc/rc.boot ] && run-parts /etc/rc.boot
-
-#
-# Finish setup if needed. The comment above about
-# /sbin/unconfigured.sh applies here as well!
-#
-if [ -x /sbin/setup.sh ]
-then
- /sbin/setup.sh
-fi
-
diff --git a/packages/tslib/tslib_1.0.bb b/packages/tslib/tslib_1.0.bb
index 4c5cb6ddb6..51bd1f6a7b 100644
--- a/packages/tslib/tslib_1.0.bb
+++ b/packages/tslib/tslib_1.0.bb
@@ -4,7 +4,7 @@ AUTHOR = "Russell King w/ plugins by Chris Larson et. al."
SECTION = "base"
LICENSE = "LGPL"
-PR = "r15"
+PR = "r16"
SRC_URI = "http://download.berlios.de/tslib/tslib-1.0.tar.bz2 \
file://tslib-input_raw-grab_events.patch;patch=1 \
@@ -75,7 +75,6 @@ DEBIAN_NOAUTONAME_tslib-calibrate = "1"
RDEPENDS_${PN} = "tslib-conf"
# Ship calibration data if it exists
RRECOMMENDS_angstrom = " pointercal "
-RRECOMMENDS_openmoko = " pointercal "
FILES_${PN}-dbg += "${libdir}/ts/.debug*"
FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"