aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-07-07 09:41:47 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-07 09:41:47 +0000
commit2df9f2514bd102fa98b2579a6d1f38ef7e9c0aba (patch)
tree68adefebe24fb58155cf00c4c624c4cedf3b4b9d /packages
parent9e7357192f5b635576a412aba335a2677ea5964c (diff)
downloadopenembedded-2df9f2514bd102fa98b2579a6d1f38ef7e9c0aba.tar.gz
glib-2.0_2.12.0.bb, gtk+_2.10.0.bb : rediff and add the patches to fix
the hardcoded libtool path in both these packages configure.in as they are essential. Both are running on my c7x0 now so they have at least been tested.
Diffstat (limited to 'packages')
-rw-r--r--packages/glib-2.0/glib-2.0-2.12.0/.mtn2git_empty0
-rw-r--r--packages/glib-2.0/glib-2.0-2.12.0/configure-libtool.patch20
-rw-r--r--packages/glib-2.0/glib-2.0_2.12.0.bb5
-rw-r--r--packages/gtk+/gtk+-2.10.0/hardcoded_libtool.patch20
-rw-r--r--packages/gtk+/gtk+_2.10.0.bb6
5 files changed, 36 insertions, 15 deletions
diff --git a/packages/glib-2.0/glib-2.0-2.12.0/.mtn2git_empty b/packages/glib-2.0/glib-2.0-2.12.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/glib-2.0/glib-2.0-2.12.0/.mtn2git_empty
diff --git a/packages/glib-2.0/glib-2.0-2.12.0/configure-libtool.patch b/packages/glib-2.0/glib-2.0-2.12.0/configure-libtool.patch
new file mode 100644
index 0000000000..478ef132af
--- /dev/null
+++ b/packages/glib-2.0/glib-2.0-2.12.0/configure-libtool.patch
@@ -0,0 +1,20 @@
+--- glib-2.12.0/configure.in.orig 2006-07-07 09:21:56.000000000 +0100
++++ glib-2.12.0/configure.in 2006-07-07 09:25:44.000000000 +0100
+@@ -1169,7 +1169,7 @@
+ dnl No use for this on Win32
+ G_MODULE_LDFLAGS=
+ else
+- G_MODULE_LDFLAGS=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
++ G_MODULE_LDFLAGS=`(./$host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
+ fi
+ dnl G_MODULE_IMPL= don't reset, so cmd-line can override
+ G_MODULE_NEED_USCORE=0
+@@ -1234,7 +1234,7 @@
+ LDFLAGS="$LDFLAGS $G_MODULE_LDFLAGS"
+ dnl *** check for OSF1/5.0 RTLD_GLOBAL brokenness
+ echo "void glib_plugin_test(void) { }" > plugin.c
+- ${SHELL} ./libtool --mode=compile ${CC} -shared \
++ ${SHELL} ./$host_alias-libtool --mode=compile ${CC} -shared \
+ -export-dynamic -o plugin.o plugin.c 2>&1 >/dev/null
+ AC_CACHE_CHECK([for RTLD_GLOBAL brokenness],
+ glib_cv_rtldglobal_broken,[
diff --git a/packages/glib-2.0/glib-2.0_2.12.0.bb b/packages/glib-2.0/glib-2.0_2.12.0.bb
index 355a9802ff..2082e4ca6b 100644
--- a/packages/glib-2.0/glib-2.0_2.12.0.bb
+++ b/packages/glib-2.0/glib-2.0_2.12.0.bb
@@ -10,7 +10,7 @@ MAINTAINER = "Philip Blundell <pb@handhelds.org>"
DEPENDS += "glib-2.0-native gtk-doc"
DEPENDS += "virtual/libiconv virtual/libintl"
PACKAGES =+ "glib-2.0-utils "
-PR = "r0"
+PR = "r1"
LEAD_SONAME = "libglib-2.0.*"
FILES_glib-2.0-utils = "${bindir}/*"
@@ -18,7 +18,8 @@ FILES_glib-2.0-utils = "${bindir}/*"
EXTRA_OECONF = "--disable-debug"
SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.12/glib-${PV}.tar.bz2 \
- file://glibconfig-sysdefs.h"
+ file://glibconfig-sysdefs.h \
+ file://configure-libtool.patch;patch=1"
S = "${WORKDIR}/glib-${PV}"
diff --git a/packages/gtk+/gtk+-2.10.0/hardcoded_libtool.patch b/packages/gtk+/gtk+-2.10.0/hardcoded_libtool.patch
index b2afddcc61..bdbdb32f97 100644
--- a/packages/gtk+/gtk+-2.10.0/hardcoded_libtool.patch
+++ b/packages/gtk+/gtk+-2.10.0/hardcoded_libtool.patch
@@ -1,29 +1,29 @@
---- gtk+-2.6.0/configure.in.old 2005-01-01 16:23:45.000000000 +0000
-+++ gtk+-2.6.0/configure.in 2005-01-01 16:24:03.000000000 +0000
-@@ -360,7 +360,7 @@
+--- gtk+-2.10.0/configure.in.orig 2006-07-07 09:31:34.000000000 +0100
++++ gtk+-2.10.0/configure.in 2006-07-07 09:32:49.000000000 +0100
+@@ -370,7 +370,7 @@
AC_MSG_CHECKING([Whether to write dependencies into .pc files])
case $enable_explicit_deps in
auto)
-- deplib_check_method=`(./libtool --config; echo eval echo \\$deplib_check_method) | sh`
-+ deplib_check_method=`($host_alias-libtool --config; echo eval echo \\$deplib_check_method) | sh`
- if test "X$deplib_check_method" = Xnone || test "x$enable_static" = xyes ; then
+- deplibs_check_method=`(./libtool --config; echo eval echo \\$deplibs_check_method) | sh`
++ deplibs_check_method=`(./$host_alias-libtool --config; echo eval echo \\$deplibs_check_method) | sh`
+ if test "x$deplibs_check_method" '!=' xpass_all || test "x$enable_static" = xyes ; then
enable_explicit_deps=yes
else
-@@ -688,7 +688,7 @@
+@@ -768,7 +768,7 @@
dnl Now we check to see if our libtool supports shared lib deps
dnl (in a rather ugly way even)
if $dynworks; then
- pixbuf_libtool_config="${CONFIG_SHELL-/bin/sh} ./libtool --config"
-+ pixbuf_libtool_config="${CONFIG_SHELL-/bin/sh} $host_alias-libtool --config"
++ pixbuf_libtool_config="${CONFIG_SHELL-/bin/sh} ./$host_alias-libtool --config"
pixbuf_deplibs_check=`$pixbuf_libtool_config | \
grep '^[[a-z_]]*check[[a-z_]]*_method=[['\''"]]' | \
sed 's/.*[['\''"]]\(.*\)[['\''"]]$/\1/'`
-@@ -1512,7 +1512,7 @@
+@@ -1600,7 +1600,7 @@
#
# We are using gmodule-no-export now, but I'm leaving the stripping
# code in place for now, since pango and atk still require gmodule.
-export_dynamic=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
-+export_dynamic=`($host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
++export_dynamic=`(./$host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
if test -n "$export_dynamic"; then
GDK_PIXBUF_DEP_LIBS=`echo $GDK_PIXBUF_DEP_LIBS | sed -e "s/$export_dynamic//"`
GDK_PIXBUF_XLIB_DEP_LIBS=`echo $GDK_PIXBUF_XLIB_DEP_LIBS | sed -e "s/$export_dynamic//"`
diff --git a/packages/gtk+/gtk+_2.10.0.bb b/packages/gtk+/gtk+_2.10.0.bb
index 8d325502e1..195140ea92 100644
--- a/packages/gtk+/gtk+_2.10.0.bb
+++ b/packages/gtk+/gtk+_2.10.0.bb
@@ -6,7 +6,7 @@ SECTION = "libs"
PRIORITY = "optional"
MAINTAINER = "Philip Blundell <pb@handhelds.org>"
DEPENDS = "glib-2.0 pango atk jpeg libpng xext libxcursor gtk-doc libgcrypt cairo cups"
-PR = "r0"
+PR = "r1"
# disable per default - untested and not all patches included.
DEFAULT_PREFERENCE = "-1"
@@ -22,12 +22,12 @@ SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.10/gtk+-${PV}.tar.bz2 \
file://small-gtkfilesel.patch;patch=1 \
file://migration.patch;patch=1;pnum=0 \
file://run-iconcache.patch;patch=1 \
- file://disable-print.patch;patch=1"
+ file://disable-print.patch;patch=1 \
+ file://hardcoded_libtool.patch;patch=1"
# file://no-demos.patch;patch=1
# file://gtk+-handhelds.patch;patch=1
# file://single-click.patch;patch=1
# file://spinbutton.patch;patch=1 \
-# file://hardcoded_libtool.patch;patch=1 \
inherit autotools pkgconfig