aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorLukas Gorris <lukas.gorris@gmail.com>2009-03-08 16:18:11 +0100
committerLukas Gorris <lukas.gorris@gmail.com>2009-03-08 16:18:11 +0100
commit101860728efdad5e79c0c92b9e9cabde1280cc18 (patch)
tree7313d93346e7411128e65b4485545fa76a914f07 /packages
parentff5c09e220ffbe4c433670c232e9a4ba854e7b26 (diff)
parent0b2d8d7c37d681a249a2752a2df821bfce1f2742 (diff)
downloadopenembedded-101860728efdad5e79c0c92b9e9cabde1280cc18.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'packages')
-rw-r--r--packages/cdrkit/files/xconfig.patch15
-rw-r--r--packages/xfsprogs/libattr_2.4.43.bb27
2 files changed, 42 insertions, 0 deletions
diff --git a/packages/cdrkit/files/xconfig.patch b/packages/cdrkit/files/xconfig.patch
new file mode 100644
index 0000000000..5af1a373b9
--- /dev/null
+++ b/packages/cdrkit/files/xconfig.patch
@@ -0,0 +1,15 @@
+--- cdrkit-1.1.9/include/xconfig.h.in.orig 2006-12-02 12:10:05.000000000 +0100
++++ cdrkit-1.1.9/include/xconfig.h.in 2009-03-08 13:29:05.000000000 +0100
+@@ -233,7 +233,11 @@
+ /* If using network byte order */
+ #cmakedefine WORDS_BIGENDIAN
+ /* If high bits come first in structures */
+-#cmakedefine BITFIELDS_HTOL
++#ifdef WORDS_BIGENDIAN
++#define BITFIELDS_HTOL
++#else
++#define BITFIELDS_LTOH
++#endif
+ #define HAVE_C_BIGENDIAN /* Flag that WORDS_BIGENDIAN test was done */
+ #define HAVE_C_BITFIELDS /* Flag that BITFIELDS_HTOL test was done */
+
diff --git a/packages/xfsprogs/libattr_2.4.43.bb b/packages/xfsprogs/libattr_2.4.43.bb
new file mode 100644
index 0000000000..99890313f5
--- /dev/null
+++ b/packages/xfsprogs/libattr_2.4.43.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "library functions to get attribute bits"
+HOMEPAGE = "http://oss.sgi.com/projects/xfs"
+LICENSE = "GPL"
+SECTION = "base"
+PR = "r0"
+DEPENDS = "gettext"
+
+SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/attr_${PV}-1.tar.gz"
+S = "${WORKDIR}/attr-${PV}"
+
+PARALLEL_MAKE = ""
+inherit autotools
+EXTRA_OECONF = "--enable-gettext=no --enable-shared=yes"
+
+do_configure () {
+ export LIBTOOL="${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"
+ export DEBUG="-DNDEBUG"
+ oe_runconf
+}
+
+do_install () {
+ export DIST_ROOT=${D}
+ oe_runmake install
+ oe_libinstall -a libattr ${D}${libdir}
+ oe_libinstall -a libattr ${STAGING_LIBDIR}
+}
+