aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2006-09-12 16:06:00 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2006-09-12 16:06:00 +0000
commit03051884eea4af47b099f3b1e09325a064d70cd1 (patch)
treec4e165516899b45e444a79ee20fad5e8095664ab /packages
parent7232b828c1a32ba503545838ec29366e13bf68db (diff)
parent6d54a192a79f5bbfe008b790e5a8f088ba496a91 (diff)
downloadopenembedded-03051884eea4af47b099f3b1e09325a064d70cd1.tar.gz
merge of '3e2ce2d7251972891d2ea2ce5c8e998bbd9d3edb'
and '97610ee42c7e0053a732da81b17cfc1599f73882'
Diffstat (limited to 'packages')
-rw-r--r--packages/e17/e-utils_20060501.bb2
-rw-r--r--packages/gnupg/gnupg-1.4.2.2/30_nm_always_check.patch21
-rw-r--r--packages/gnupg/gnupg.inc4
-rw-r--r--packages/gnupg/gnupg_1.4.2.2.bb5
-rw-r--r--packages/libgpg-error/libgpg-error_1.3.bb4
5 files changed, 31 insertions, 5 deletions
diff --git a/packages/e17/e-utils_20060501.bb b/packages/e17/e-utils_20060501.bb
index 3f1af895ae..fc94cd106f 100644
--- a/packages/e17/e-utils_20060501.bb
+++ b/packages/e17/e-utils_20060501.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Enlightenment Window Manager Utilities"
-DEPENDS = "virtual/ecore virtual/evas virtual/esmart edje eet ewl engrave virtual/imlib2 e epsilon"
+DEPENDS = "virtual/ecore virtual/evas virtual/esmart edje eet ewl engrave virtual/imlib2 epsilon"
LICENSE = "MIT"
PR = "r1"
diff --git a/packages/gnupg/gnupg-1.4.2.2/30_nm_always_check.patch b/packages/gnupg/gnupg-1.4.2.2/30_nm_always_check.patch
new file mode 100644
index 0000000000..914f1475b7
--- /dev/null
+++ b/packages/gnupg/gnupg-1.4.2.2/30_nm_always_check.patch
@@ -0,0 +1,21 @@
+Originally the test for _'s on symbols was not done when cross-compiling and
+it was assumed that the _'s were appended. The test does in fact work since
+it simply compiles a file and then run's nm on it. So patch this to enable.
+Without this x86 targets fail during linking since the assembler code has
+the _'s appended when it shouldn't.
+
+--- gnupg-1.4.2.2/acinclude.m4 2006/09/11 22:11:23 1.1
++++ gnupg-1.4.2.2/acinclude.m4 2006/09/11 22:17:25
+@@ -673,11 +673,7 @@
+ ac_cv_sys_symbol_underscore=yes
+ ;;
+ *)
+- if test "$cross_compiling" = yes; then
+- ac_cv_sys_symbol_underscore=yes
+- else
+- tmp_do_check="yes"
+- fi
++ tmp_do_check="yes"
+ ;;
+ esac
+
diff --git a/packages/gnupg/gnupg.inc b/packages/gnupg/gnupg.inc
index b4eb9bba65..2d8e37605f 100644
--- a/packages/gnupg/gnupg.inc
+++ b/packages/gnupg/gnupg.inc
@@ -70,3 +70,7 @@ do_install () {
mv ${D}${datadir}/${PN}/* ${D}/${docdir}/${PN}/ || :
mv ${D}${prefix}/doc/* ${D}/${docdir}/${PN}/ || :
}
+
+# Exclude debug files from the main packages
+FILES_${PN} = "${bindir}/* ${datadir}/${PN} ${libexecdir}/${PN}/*"
+FILES_${PN}-dbg += "${libexecdir}/${PN}/.debug"
diff --git a/packages/gnupg/gnupg_1.4.2.2.bb b/packages/gnupg/gnupg_1.4.2.2.bb
index 97c301cf97..b21eb88b91 100644
--- a/packages/gnupg/gnupg_1.4.2.2.bb
+++ b/packages/gnupg/gnupg_1.4.2.2.bb
@@ -6,8 +6,9 @@ EXTRA_OECONF += "--with-readline=${STAGING_LIBDIR}/.."
SRC_URI += "file://15_free_caps.patch;patch=1 \
file://16_min_privileges.patch;patch=1 \
- file://22_zero_length_mpi_fix.patch;patch=1 "
+ file://22_zero_length_mpi_fix.patch;patch=1 \
+ file://30_nm_always_check.patch;patch=1"
S = "${WORKDIR}/gnupg-${PV}"
-PR = "r1"
+PR = "r2"
diff --git a/packages/libgpg-error/libgpg-error_1.3.bb b/packages/libgpg-error/libgpg-error_1.3.bb
index c29053832b..a2a19b254c 100644
--- a/packages/libgpg-error/libgpg-error_1.3.bb
+++ b/packages/libgpg-error/libgpg-error_1.3.bb
@@ -1,4 +1,4 @@
-PR = "r0"
+PR = "r1"
DESCRIPTION = "GPG-Error library"
SECTION = "libs"
PRIORITY = "optional"
@@ -9,7 +9,7 @@ SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${PV}.tar.gz \
# move libgpg-error-config into -dev package
FILES_${PN} = "${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${bindir}"
+FILES_${PN}-dev += "${bindir}/*"
inherit autotools binconfig pkgconfig