aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-08-23 08:16:51 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-08-23 08:16:51 +0000
commitb6d6e400005ee9a12a5c859609e3cb609c0d8dea (patch)
tree0e4b614f33cd020bb7f9e317e6f96be756c74d80 /packages
parent2cb53be5d39a4a4817e1464f853d5b0cd038e571 (diff)
parent1d90efcdbf94571236a9d770af3d1adfb8ced770 (diff)
downloadopenembedded-b6d6e400005ee9a12a5c859609e3cb609c0d8dea.tar.gz
merge of '19b3553f698a014d63c349b2723f835295c7b5da'
and '38e2cd40a04ac88008e433a43002415c562145e4'
Diffstat (limited to 'packages')
-rw-r--r--packages/python/python-dbus/python-path.patch21
-rw-r--r--packages/python/python-dbus_0.81.1.bb8
-rw-r--r--packages/python/python-pygobject-native_2.12.2.bb3
-rw-r--r--packages/python/python-pygobject_2.12.2.bb23
4 files changed, 27 insertions, 28 deletions
diff --git a/packages/python/python-dbus/python-path.patch b/packages/python/python-dbus/python-path.patch
new file mode 100644
index 0000000000..6bdbd19d03
--- /dev/null
+++ b/packages/python/python-dbus/python-path.patch
@@ -0,0 +1,21 @@
+--- dbus-python-0.81.1/m4.orig/am-check-python-headers.m4
++++ dbus-python-0.81.1/m4/am-check-python-headers.m4
+@@ -7214,12 +7214,18 @@
+ [AC_REQUIRE([AM_PATH_PYTHON])
+ AC_MSG_CHECKING(for headers required to compile python extensions)
+ dnl deduce PYTHON_INCLUDES
++AC_ARG_WITH(python-includes,
++ [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
++if test x$py_exec_prefix != x; then
++PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
++else
+ py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
+ py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
+ PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
+ if test "$py_prefix" != "$py_exec_prefix"; then
+ PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
+ fi
++fi
+ AC_SUBST(PYTHON_INCLUDES)
+ dnl check if the headers exist:
+ save_CPPFLAGS="$CPPFLAGS"
diff --git a/packages/python/python-dbus_0.81.1.bb b/packages/python/python-dbus_0.81.1.bb
index 82b9c390ca..ad3b1c177b 100644
--- a/packages/python/python-dbus_0.81.1.bb
+++ b/packages/python/python-dbus_0.81.1.bb
@@ -4,11 +4,15 @@ HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
LICENSE = "GPL"
DEPENDS = "expat glib-2.0 virtual/libintl python-pyrex-native python"
RDEPENDS = "dbus python-threading python-io python-stringold python-logging"
-PR = "ml0"
+PR = "ml1"
SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
- file://allow-older-autotools.patch;patch=1"
+ file://allow-older-autotools.patch;patch=1 \
+ file://python-path.patch;patch=1"
+
S = "${WORKDIR}/dbus-python-${PV}"
inherit distutils-base autotools
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
diff --git a/packages/python/python-pygobject-native_2.12.2.bb b/packages/python/python-pygobject-native_2.12.2.bb
deleted file mode 100644
index c93950b31b..0000000000
--- a/packages/python/python-pygobject-native_2.12.2.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require python-pygobject_${PV}.bb
-
-DEPENDS = "python-native"
diff --git a/packages/python/python-pygobject_2.12.2.bb b/packages/python/python-pygobject_2.12.2.bb
deleted file mode 100644
index 1604b54715..0000000000
--- a/packages/python/python-pygobject_2.12.2.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-DESCRIPTION = "Python GObject bindings"
-SECTION = "devel/python"
-LICENSE = "LGPL"
-DEPENDS = "python-pygobject-native"
-PR = "ml2"
-
-SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/2.12/pygobject-${PV}.tar.bz2"
-S = "${WORKDIR}/pygobject-${PV}"
-
-inherit autotools distutils-base pkgconfig
-
-# otherwise the main package keeps snatching the .pc file away
-# and therefore depends on glib-2.0-dev (which only the -dev
-# package should).
-PACKAGES =+ "${PN}-dev"
-
-do_stage() {
- autotools_stage_all
- install -d ${STAGING_LIBDIR}/../share/pygobject/
- cp -dpfR docs/* ${STAGING_LIBDIR}/../share/pygobject/
- install -d ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
- cp docs/style.css ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
-}