aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-11-27 12:07:29 +0100
committerKoen Kooi <koen@openembedded.org>2008-11-27 12:07:29 +0100
commit9c46ce7b5a5fa267296296026145f58cb143d2b2 (patch)
tree5510a19c3e9d774502fe695c4f26bb0de83104b7 /packages
parentab9e5fb6dc0ed835e4cca5d40957da991ffa20ea (diff)
downloadopenembedded-9c46ce7b5a5fa267296296026145f58cb143d2b2.tar.gz
linux-omap git: bump SRCREV
Diffstat (limited to 'packages')
-rw-r--r--packages/linux/linux-omap/musb-fix-ISO-in-unlink.diff69
-rw-r--r--packages/linux/linux-omap/musb-fix-dbrownell.patch71
-rw-r--r--packages/linux/linux-omap/musb-mru-otgfix.diff43
-rw-r--r--packages/linux/linux-omap_git.bb4
4 files changed, 2 insertions, 185 deletions
diff --git a/packages/linux/linux-omap/musb-fix-ISO-in-unlink.diff b/packages/linux/linux-omap/musb-fix-ISO-in-unlink.diff
deleted file mode 100644
index c93a5b06c8..0000000000
--- a/packages/linux/linux-omap/musb-fix-ISO-in-unlink.diff
+++ /dev/null
@@ -1,69 +0,0 @@
-From: Ajay Kumar Gupta <ajay.gupta@ti.com>
-To: linux-omap@vger.kernel.org
-Cc: linux-usb@vger.kernel.org, felipe.balbi@nokia.com,
- stern@rowland.harvard.edu, Ajay Kumar Gupta <ajay.gupta@ti.com>
-Subject: [PATCH v3] OMAP:MUSB: Corrects urb unlink function path
-Date: Mon, 25 Aug 2008 10:52:16 +0530
-
-Fixes kernel panic while ISO IN transfer is aborted.Replaced
-usb_hcd_unlink_urb_from_ep() from musb_giveback() to __musb_giveback()
-to make sure urb is unlinked before giveback when __musb_giveback() is
-called from musb_urb_dequeue().
-
-Acquired musb->lock() before usb_hcd_unlink_urb_from_ep() within in
-enqueue path.
-
-Signed-off-by: Ajay Kumar Gupta <ajay.gupta@ti.com>
----
- drivers/usb/musb/musb_host.c | 7 +++++--
- 1 files changed, 5 insertions(+), 2 deletions(-)
-
-diff --git a/drivers/usb/musb/musb_host.c b/drivers/usb/musb/musb_host.c
-index 08e421f..4279311 100644
---- a/drivers/usb/musb/musb_host.c
-+++ b/drivers/usb/musb/musb_host.c
-@@ -291,6 +291,7 @@ __acquires(musb->lock)
- urb->actual_length, urb->transfer_buffer_length
- );
-
-+ usb_hcd_unlink_urb_from_ep(musb_to_hcd(musb), urb);
- spin_unlock(&musb->lock);
- usb_hcd_giveback_urb(musb_to_hcd(musb), urb, status);
- spin_lock(&musb->lock);
-@@ -353,8 +354,6 @@ musb_giveback(struct musb_qh *qh, struct urb *urb, int status)
- break;
- }
-
-- usb_hcd_unlink_urb_from_ep(musb_to_hcd(musb), urb);
--
- qh->is_ready = 0;
- __musb_giveback(musb, urb, status);
- qh->is_ready = ready;
-@@ -1787,7 +1786,9 @@ static int musb_urb_enqueue(
- */
- qh = kzalloc(sizeof *qh, mem_flags);
- if (!qh) {
-+ spin_lock_irqsave(&musb->lock, flags);
- usb_hcd_unlink_urb_from_ep(hcd, urb);
-+ spin_unlock_irqrestore(&musb->lock, flags);
- return -ENOMEM;
- }
-
-@@ -1899,7 +1900,9 @@ static int musb_urb_enqueue(
-
- done:
- if (ret != 0) {
-+ spin_lock_irqsave(&musb->lock, flags);
- usb_hcd_unlink_urb_from_ep(hcd, urb);
-+ spin_unlock_irqrestore(&musb->lock, flags);
- kfree(qh);
- }
- return ret;
---
-1.5.6
-
---
-To unsubscribe from this list: send the line "unsubscribe linux-omap" in
-the body of a message to majordomo@vger.kernel.org
-More majordomo info at http://vger.kernel.org/majordomo-info.html
-
diff --git a/packages/linux/linux-omap/musb-fix-dbrownell.patch b/packages/linux/linux-omap/musb-fix-dbrownell.patch
deleted file mode 100644
index 3526cd3ca6..0000000000
--- a/packages/linux/linux-omap/musb-fix-dbrownell.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From: David Brownell <dbrownell@users.sourceforge.net>
-
-Minor cleanups to omap 2430/34xx/35x musb_hdrc init:
-
- - num_eps is 16; here, each one is bidirectional
- - use DMA_32BIT_MASK to prevent confusion/errors
- - initialize root port power to reflect 100 mA limit
-
-This still hard-wires some board-specific data, since there
-are no hooks through which different boards can provide the
-right data to the init code.
-
-Signed-off-by: David Brownell <dbrownell@users.sourceforge.net>
-
---- a/arch/arm/mach-omap2/usb-musb.c
-+++ b/arch/arm/mach-omap2/usb-musb.c
-@@ -21,12 +21,15 @@
- #include <linux/delay.h>
- #include <linux/platform_device.h>
- #include <linux/clk.h>
-+#include <linux/dma-mapping.h>
-+
- #include <asm/io.h>
--#include <mach/mux.h>
-+
- #include <linux/usb/musb.h>
-
- #include <mach/hardware.h>
- #include <mach/pm.h>
-+#include <mach/mux.h>
- #include <mach/usb.h>
-
- #ifdef CONFIG_USB_MUSB_SOC
-@@ -109,7 +112,7 @@ static struct musb_hdrc_config musb_config = {
- .dyn_fifo = 1,
- .soft_con = 1,
- .dma = 1,
-- .num_eps = 32,
-+ .num_eps = 16,
- .dma_channels = 7,
- .dma_req_chan = (1 << 0) | (1 << 1) | (1 << 2) | (1 << 3),
- .ram_bits = 12,
-@@ -129,16 +132,22 @@ static struct musb_hdrc_platform_data musb_plat = {
- : "usbhs_ick",
- .set_clock = musb_set_clock,
- .config = &musb_config,
-+
-+ /* REVISIT charge pump on TWL4030 can supply up to
-+ * 100 mA ... but this value is board-specific, like
-+ * "mode", and should be passed to usb_musb_init().
-+ */
-+ .power = 50, /* up to 100 mA */
- };
-
--static u64 musb_dmamask = ~(u32)0;
-+static u64 musb_dmamask = DMA_32BIT_MASK;
-
- static struct platform_device musb_device = {
- .name = "musb_hdrc",
- .id = -1,
- .dev = {
- .dma_mask = &musb_dmamask,
-- .coherent_dma_mask = 0xffffffff,
-+ .coherent_dma_mask = DMA_32BIT_MASK,
- .platform_data = &musb_plat,
- },
- .num_resources = ARRAY_SIZE(musb_resources),
---
-To unsubscribe from this list: send the line "unsubscribe linux-omap" in
-the body of a message to majordomo@vger.kernel.org
-More majordomo info at http://vger.kernel.org/majordomo-info.html
diff --git a/packages/linux/linux-omap/musb-mru-otgfix.diff b/packages/linux/linux-omap/musb-mru-otgfix.diff
deleted file mode 100644
index 767858b8b1..0000000000
--- a/packages/linux/linux-omap/musb-mru-otgfix.diff
+++ /dev/null
@@ -1,43 +0,0 @@
-From: Mans Rullgard <mans@mansr.com>
-Date: Sat, 6 Sep 2008 15:11:00 +0000 (+0100)
-Subject: usb: musb: fix something
-X-Git-Url: http://git.mansr.com/?p=linux-omap;a=commitdiff_plain;h=1e5bc41773bb981b3a89bd762becf98c72be5e4c
-
-usb: musb: fix something
-
-This makes USB work on the Beagleboard. I don't know why.
----
-
-diff --git a/drivers/usb/musb/musb_core.c b/drivers/usb/musb/musb_core.c
-index e07cad8..4d6ff26 100644
---- a/drivers/usb/musb/musb_core.c
-+++ b/drivers/usb/musb/musb_core.c
-@@ -1819,6 +1819,9 @@ allocate_instance(struct device *dev, void __iomem *mbase)
- ep->epnum = epnum;
- }
-
-+#ifdef CONFIG_USB_MUSB_OTG
-+ otg_set_transceiver(&musb->xceiv);
-+#endif
- musb->controller = dev;
- return musb;
- }
-diff --git a/drivers/usb/musb/omap2430.c b/drivers/usb/musb/omap2430.c
-index 9d2dcb1..51af80b 100644
---- a/drivers/usb/musb/omap2430.c
-+++ b/drivers/usb/musb/omap2430.c
-@@ -215,12 +215,14 @@ void musb_platform_set_mode(struct musb *musb, u8 musb_mode)
-
- int __init musb_platform_init(struct musb *musb)
- {
-+ struct otg_transceiver *xceiv = otg_get_transceiver();
- u32 l;
-
- #if defined(CONFIG_ARCH_OMAP2430)
- omap_cfg_reg(AE5_2430_USB0HS_STP);
- #endif
-
-+ musb->xceiv = *xceiv;
- musb_platform_resume(musb);
-
- l = omap_readl(OTG_SYSCONFIG);
diff --git a/packages/linux/linux-omap_git.bb b/packages/linux/linux-omap_git.bb
index 76bf666449..bea6f8ecae 100644
--- a/packages/linux/linux-omap_git.bb
+++ b/packages/linux/linux-omap_git.bb
@@ -6,11 +6,11 @@ KERNEL_IMAGETYPE = "uImage"
COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm"
-SRCREV = "3b7de4be879f1f4f55ae59882a5cbd80f6dcf0f0"
+SRCREV = "5019ed843f3208482c64043e4052e89b3d5462a0"
PV = "2.6.27+2.6.28-rc6+${PR}+gitr${SRCREV}"
#PV = "2.6.27+${PR}+gitr${SRCREV}"
-PR = "r1"
+PR = "r2"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
file://defconfig"