aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-10-10 14:06:04 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-10-10 14:06:04 +0000
commit3b35fbcf6081cc769e4cb00d909806b8381f45d1 (patch)
tree610dc6f944db15c44b0ab5b4a1e955c53b65b81c /packages
parent5deda18914a97c792e468d8aeceec94867dd60c2 (diff)
parent845e6f9090e6b5c35f4888340715621ca138e32a (diff)
downloadopenembedded-3b35fbcf6081cc769e4cb00d909806b8381f45d1.tar.gz
merge of '2a367b175831bc65ea08b04593fd5775fd3b35b8'
and '3d6ef85ae2e8f4ef0940c85f75b4ba86dcb0266c'
Diffstat (limited to 'packages')
-rw-r--r--packages/classpath/classpath-native_0.97.2.bb3
-rw-r--r--packages/classpath/files/miscompilation.patch13
-rw-r--r--packages/libsdl/libsdl-image.inc18
-rw-r--r--packages/libsdl/libsdl-image_1.2.3.bb11
-rw-r--r--packages/libsdl/libsdl-image_1.2.6.bb8
5 files changed, 44 insertions, 9 deletions
diff --git a/packages/classpath/classpath-native_0.97.2.bb b/packages/classpath/classpath-native_0.97.2.bb
index 81ffad3b14..0024136b97 100644
--- a/packages/classpath/classpath-native_0.97.2.bb
+++ b/packages/classpath/classpath-native_0.97.2.bb
@@ -1,6 +1,6 @@
require classpath-native.inc
-PR = "r3"
+PR = "r4"
# The code affected by the javanet-local patch
# is usually not compiled. However if someone changes
@@ -14,6 +14,7 @@ SRC_URI += "\
file://autotools.patch;patch=1 \
file://decimalformat.patch;patch=1 \
file://cp-byte-loophelper.patch;patch=1;pnum=0 \
+ file://miscompilation.patch;patch=1 \
"
do_unpackpost() {
diff --git a/packages/classpath/files/miscompilation.patch b/packages/classpath/files/miscompilation.patch
new file mode 100644
index 0000000000..c61b214f44
--- /dev/null
+++ b/packages/classpath/files/miscompilation.patch
@@ -0,0 +1,13 @@
+Index: classpath-0.97.2/native/jni/java-io/java_io_VMFile.c
+===================================================================
+--- classpath-0.97.2.orig/native/jni/java-io/java_io_VMFile.c 2008-10-10 15:24:54.000000000 +0200
++++ classpath-0.97.2/native/jni/java-io/java_io_VMFile.c 2008-10-10 15:25:36.000000000 +0200
+@@ -439,7 +439,7 @@
+ {
+ #ifndef WITHOUT_FILESYSTEM
+ const char *filename;
+- int result;
++ volatile int result;
+
+ /* Don't use the JCL convert function because it throws an exception
+ on failure */
diff --git a/packages/libsdl/libsdl-image.inc b/packages/libsdl/libsdl-image.inc
new file mode 100644
index 0000000000..1212e9cfa6
--- /dev/null
+++ b/packages/libsdl/libsdl-image.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "Simple DirectMedia Layer image library."
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "zlib libpng jpeg virtual/libsdl"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_image/release/SDL_image-${PV}.tar.gz"
+
+S = "${WORKDIR}/SDL_image-${PV}"
+
+inherit autotools
+
+do_stage() {
+ oe_libinstall -so libSDL_image ${STAGING_LIBDIR}
+ ln -sf libSDL_image.so ${STAGING_LIBDIR}/libSDL_image-1.2.so
+ install -m 0644 SDL_image.h ${STAGING_INCDIR}/SDL/SDL_image.h
+}
+
diff --git a/packages/libsdl/libsdl-image_1.2.3.bb b/packages/libsdl/libsdl-image_1.2.3.bb
index 7bf24412d2..0c83158c03 100644
--- a/packages/libsdl/libsdl-image_1.2.3.bb
+++ b/packages/libsdl/libsdl-image_1.2.3.bb
@@ -1,15 +1,10 @@
-DESCRIPTION = "Simple DirectMedia Layer image library."
-SECTION = "libs"
-PRIORITY = "optional"
-DEPENDS = "zlib libpng jpeg virtual/libsdl"
-LICENSE = "LGPL"
+require libsdl-image.inc
+
PR = "r2"
-SRC_URI = "\
- http://www.libsdl.org/projects/SDL_image/release/SDL_image-${PV}.tar.gz \
+SRC_URI += "\
file://autotools.patch;patch=1 \
"
-S = "${WORKDIR}/SDL_image-${PV}"
export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
diff --git a/packages/libsdl/libsdl-image_1.2.6.bb b/packages/libsdl/libsdl-image_1.2.6.bb
new file mode 100644
index 0000000000..27b5aa7d1a
--- /dev/null
+++ b/packages/libsdl/libsdl-image_1.2.6.bb
@@ -0,0 +1,8 @@
+require libsdl-image.inc
+
+do_unpackpost() {
+ # Removing this file fixes a libtool version mismatch.
+ rm acinclude/libtool.m4
+}
+
+addtask unpackpost after do_unpack before do_patch