aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2008-10-06 20:18:43 +0000
committerPhilip Balister <philip@balister.org>2008-10-06 20:18:43 +0000
commite707c438cc8e36bb255fc80fbe2ba811a35d02ff (patch)
tree6eadfee162474f29de73c40f1b1a6face04813cc /packages
parent568af3b5b1ef8d5c3b0a140acc5730cfe785d34a (diff)
downloadopenembedded-e707c438cc8e36bb255fc80fbe2ba811a35d02ff.tar.gz
gnuradio_svn.bb : Commit basic support for GNU Radio trunk
* You will need to enable boost-1.36.0 * This does not build USRP code, yet.
Diffstat (limited to 'packages')
-rw-r--r--packages/gnuradio/gnuradio.inc5
-rw-r--r--packages/gnuradio/gnuradio/no-usrp2.patch12
-rw-r--r--packages/gnuradio/gnuradio_svn.bb22
3 files changed, 33 insertions, 6 deletions
diff --git a/packages/gnuradio/gnuradio.inc b/packages/gnuradio/gnuradio.inc
index 9cb936a105..a084b1cae0 100644
--- a/packages/gnuradio/gnuradio.inc
+++ b/packages/gnuradio/gnuradio.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "GNU Radio"
SECTION = "apps"
PRIORITY = "optional"
LICENSE = "GPL"
-DEPENDS = " guile-native fftwf python libusb-compat virtual/libsdl alsa-lib jack boost cppunit sdcc-native swig-native"
+DEPENDS = " guile-native fftwf python libusb virtual/libsdl alsa-lib jack boost cppunit sdcc-native swig-native"
RDEPENDS_${PN} = "python-core python-audio python-threading python-codecs python-lang python-textutils"
RDEPENDS_gnuradio-usrp = "python-core"
@@ -22,6 +22,7 @@ EXTRA_OECONF = " \
--enable-gr-audio-oss \
--enable-mblock \
--disable-html-docs \
+ PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/python2.5 \
"
do_configure_append() {
@@ -55,7 +56,7 @@ FILES_${PN}-dbg += "${libdir}/python*/site-packages/gnuradio/.debug \
"
FILES_gnuradio-usrp = "${libdir}/python*/site-packages/usrpm/* \
- ${datadir}/usrp"
+ ${datadir}/usrp/*/*"
FILES_gnuradio-usrp-dbg = "${libdir}/python*/site-packages/usrpm/.debug"
diff --git a/packages/gnuradio/gnuradio/no-usrp2.patch b/packages/gnuradio/gnuradio/no-usrp2.patch
new file mode 100644
index 0000000000..fc9e2a736f
--- /dev/null
+++ b/packages/gnuradio/gnuradio/no-usrp2.patch
@@ -0,0 +1,12 @@
+--- gnuradio-trunk-work/configure.ac.orig 2008-10-06 13:38:45.000000000 -0400
++++ gnuradio-trunk-work/configure.ac 2008-10-06 13:39:02.000000000 -0400
+@@ -272,9 +272,7 @@
+ GRC_PMT
+ GRC_MBLOCK dnl this must come after GRC_PMT
+ GRC_USRP
+-GRC_USRP2
+ GRC_GR_USRP dnl this must come after GRC_USRP
+-GRC_GR_USRP2
+ GRC_GR_GCELL dnl this must come after GRC_GCELL and GRC_GNURADIO_CORE
+ GRC_GR_MSDD6000
+ GRC_GR_AUDIO_ALSA
diff --git a/packages/gnuradio/gnuradio_svn.bb b/packages/gnuradio/gnuradio_svn.bb
index f72cf2fb9a..2a83800c3b 100644
--- a/packages/gnuradio/gnuradio_svn.bb
+++ b/packages/gnuradio/gnuradio_svn.bb
@@ -1,14 +1,28 @@
require gnuradio.inc
-DEFAULT_PREFERENCE = "-1"
+#DEFAULT_PREFERENCE = "-1"
-PV = "3.0.4+svnr${SRCREV}"
+PV = "3.1.3+svnr${SRCREV}"
PR = "r4"
-SRC_URI = "svn://gnuradio.org/svn/gnuradio;module=trunk;proto=http \
- file://no-trellis-doc.patch;patch=1 \
+EXTRA_OECONF += "--with-boost=${STAGING_DIR_TARGET}/usr CXXFLAGS=-DBOOST_SP_USE_PTHREADS --disable-usrp1 --disable--usrp2"
+
+SRC_URI = "svn://gnuradio.org/svn/gnuradio/;module=trunk;proto=http \
+ file://no-usrp2.patch;patch=1 \
+# file://no-trellis-doc.patch;patch=1 \
+# file://gnuradio-neon.patch;patch=1;pnum=0 \
"
S="${WORKDIR}/trunk"
+#do_configure() {
+# ./bootstrap
+# oe_runconf
+#}
+
+do_compile_append() {
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ gnuradio-core/gnuradio-core.pc
+}