aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-10-07 23:50:20 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-10-07 23:50:20 +0000
commit10bb92e04748af06ffc43c0cf9773de8a5e8914c (patch)
treeac8765673bd0d4332e6b3b65505a8d622a84bf78 /packages
parent570c4b81062fc43f021950e6449c1b0dd6d6c602 (diff)
parenta8e1f7d7523ab5cd6154bc585cd90c1fd24f89dd (diff)
downloadopenembedded-10bb92e04748af06ffc43c0cf9773de8a5e8914c.tar.gz
merge of '2a9c44cdb5873b8f43feb32a28672dc98ff82666'
and 'dc0102fc89237b4da908e11a15fd36bef0dd2677'
Diffstat (limited to 'packages')
-rw-r--r--packages/splashutils/.mtn2git_empty0
-rw-r--r--packages/splashutils/splashutils_1.5.4.2.bb42
2 files changed, 42 insertions, 0 deletions
diff --git a/packages/splashutils/.mtn2git_empty b/packages/splashutils/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/splashutils/.mtn2git_empty
diff --git a/packages/splashutils/splashutils_1.5.4.2.bb b/packages/splashutils/splashutils_1.5.4.2.bb
new file mode 100644
index 0000000000..36c11ab2de
--- /dev/null
+++ b/packages/splashutils/splashutils_1.5.4.2.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Framebuffer splash utilities."
+SECTION = "media-gfx"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://dev.gentoo.org/~spock/projects/gensplash/archive/splashutils-${PV}.tar.bz2"
+
+DEPENDS = "jpeg klibc"
+
+inherit autotools
+
+PARALLEL_MAKE = ""
+
+# klcc doesn't work with -isystem
+export TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}/${layout_includedir}"
+export BUILD_CPPFLAGS = "-I${STAGING_DIR_NATIVE}${layout_includedir}"
+
+do_configure_prepend() {
+ if [ -f "${S}"/src/Makefile.am ] ; then
+ sed -i "s#^INCLUDES = \(.*\)#INCLUDES = \1 $CPPFLAGS#" "${S}"/src/Makefile.am
+ fi
+}
+
+EXTRA_OECONF = "--without-gpm --without-png --without-mng --without-ttf --without-ttf-kernel"
+
+# fbcondecor_helper is also useful outside of the main package.
+RDEPENDS_${PN} = "${PN}-helper"
+
+PACKAGES =+ "${PN}-helper"
+FILES_${PN}-helper = "${base_sbindir}/fbcondecor_helper ${base_sbindir}/splash_helper"
+FILES_${PN} += "/lib"
+
+do_install_append () {
+ if [ -f "${S}"/debian/splashutils.dirs ] ; then
+ for dir in $(cat debian/splashutils.dirs) ; do
+ mkdir -p ${D}/$dir
+ done
+ fi
+
+ ln -s fbcondecor_helper ${D}${base_sbindir}/splash_helper
+
+}