summaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorErin Yueh <erin_yueh@openmoko.com>2008-12-02 13:57:18 +0800
committerJohn Lee <john_lee@openmoko.org>2009-01-05 17:07:03 +0800
commita8832b766416fe15aeeff2e939bf50ecf98b1a3b (patch)
treec8447dd22fd2d13efee45bcad9ba1fe386161ba8 /packages
parentfa4f0bb849682240ad44cfe2e825aa8d4ba96adb (diff)
downloadopenembedded-a8832b766416fe15aeeff2e939bf50ecf98b1a3b.tar.gz
obexpush_1.0.0.bb: add opd_args file to append arguments for starting
opd
Diffstat (limited to 'packages')
-rw-r--r--packages/obexpush/files/opd_args1
-rw-r--r--packages/obexpush/obexpush_1.0.0.bb7
2 files changed, 6 insertions, 2 deletions
diff --git a/packages/obexpush/files/opd_args b/packages/obexpush/files/opd_args
new file mode 100644
index 0000000000..26afc0e249
--- /dev/null
+++ b/packages/obexpush/files/opd_args
@@ -0,0 +1 @@
+OPD_ARGS="--mode OBEX --path /var/obexpush --channel 10 --sdp --metadata"
diff --git a/packages/obexpush/obexpush_1.0.0.bb b/packages/obexpush/obexpush_1.0.0.bb
index 4ec591d262..cfc09df2b6 100644
--- a/packages/obexpush/obexpush_1.0.0.bb
+++ b/packages/obexpush/obexpush_1.0.0.bb
@@ -3,11 +3,12 @@ HOMEPAGE = "http://www.caside.lancs.ac.uk/java_bt.php"
SECTION = "console/network"
LICENSE = "GPL"
DEPENDS = "glib-2.0 openobex bluez-libs"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://www.caside.lancs.ac.uk/bt/obexpush.tar.gz \
file://add-obextool.patch;patch=1 \
- file://init"
+ file://init \
+ file://opd_args"
S = "${WORKDIR}/obexpush"
inherit update-rc.d
@@ -41,6 +42,8 @@ do_install() {
install -m 0755 opd/opd ${D}${sbindir}
install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/default
install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/opd
+ install -m 0755 ${WORKDIR}/opd_args ${D}${sysconfdir}/default/opd_args
}