aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xqt2
diff options
context:
space:
mode:
authorBernhard Guillon <Bernhard.Guillon@opensimpad.org>2008-11-25 18:43:12 +0100
committerThomas Kunze <thommycheck@gmx.de>2008-11-25 18:43:12 +0100
commitc7c1df6ce89916259a0803d2a9a22e588cfa7de9 (patch)
treebb096a8d033206d5604b15f2add09b562b9aaa45 /packages/xqt2
parent03219a272280eceb2b761e32a011700d1bdde72c (diff)
downloadopenembedded-c7c1df6ce89916259a0803d2a9a22e588cfa7de9.tar.gz
xqt2: hack to fix screen rotation
Diffstat (limited to 'packages/xqt2')
-rw-r--r--packages/xqt2/files/fix_qtscreen_HACK.patch55
-rw-r--r--packages/xqt2/xqt2_20060509.bb15
2 files changed, 63 insertions, 7 deletions
diff --git a/packages/xqt2/files/fix_qtscreen_HACK.patch b/packages/xqt2/files/fix_qtscreen_HACK.patch
new file mode 100644
index 0000000000..7e4b2c658a
--- /dev/null
+++ b/packages/xqt2/files/fix_qtscreen_HACK.patch
@@ -0,0 +1,55 @@
+diff -Nur xc/../xqt2.vanilla/xfree86/xqt-driver/qtscreen.cc xc/../xqt2/xfree86/xqt-driver/qtscreen.cc
+--- xc/../xqt2.vanilla/xfree86/xqt-driver/qtscreen.cc 2008-09-25 14:18:44.000000000 +0200
++++ xc/../xqt2/xfree86/xqt-driver/qtscreen.cc 2008-09-25 14:28:30.000000000 +0200
+@@ -109,6 +109,7 @@
+ desktopSize = newSize;
+ fullScrSize = desktopSize;
+ normalScrSize = fullScrSize;
++ /* FIXME: get taskbar size from opie
+ if (normalScrSize.height() >= 400) {
+ normalScrSize.setHeight( normalScrSize.height() - 38);
+ } else {
+@@ -117,7 +118,7 @@
+
+ if (!g_fFullScreen) {
+ fullScrSize = normalScrSize;
+- }
++ }*/
+
+ #ifdef DEBUG_SCR
+ normalScrSize.setHeight(640);
+@@ -128,6 +129,7 @@
+ setDisplaySize();
+
+ #ifdef QWS
++ /* FIXME: fix this more general
+ // zaurus hack
+ if (desktopSize.width() > desktopSize.height()) {
+ shadow.setScrRandr(270);
+@@ -136,6 +138,10 @@
+ shadow.setScrRandr(0);
+ qtRandRRotate(0);
+ }
++ */
++ // until that
++ shadow.setScrRandr(0);
++ qtRandRRotate(0);
+ #endif
+ }
+
+@@ -148,6 +154,7 @@
+ *h = fullScrSize.height();
+
+ #ifdef QWS
++ /* FIXME: dix this more general
+ // zaurus hack
+ if (*w > *h) {
+ // rotate!
+@@ -155,6 +162,7 @@
+ *w = *h;
+ *h = sw;
+ }
++ */
+
+ *depth = 16; // 16bpp ¸ÇÄê
+ *bits = NULL;
diff --git a/packages/xqt2/xqt2_20060509.bb b/packages/xqt2/xqt2_20060509.bb
index 12e210d036..731385adb4 100644
--- a/packages/xqt2/xqt2_20060509.bb
+++ b/packages/xqt2/xqt2_20060509.bb
@@ -5,23 +5,24 @@ LICENSE = "GPL"
SECTION = "opie/applications"
APPTYPE = "binary"
APPNAME = "Xqt"
-PR = "r2"
+PR = "r3"
inherit palmtop
SRC_URI = "cvs://anonymous@cvs.sourceforge.jp/cvsroot/xqt;module=xqt2;method=pserver;date=${PV} \
- http://ring.asahi-net.or.jp/archives/XFree86/4.3.0/source/X430src-1.tgz \
- http://ring.asahi-net.or.jp/archives/XFree86/4.3.0/source/X430src-2.tgz \
- http://ring.asahi-net.or.jp/archives/XFree86/4.3.0/source/X430src-3.tgz \
- http://ring.asahi-net.or.jp/archives/XFree86/4.3.0/source/X430src-4.tgz \
- http://ring.asahi-net.or.jp/archives/XFree86/4.3.0/source/X430src-5.tgz \
+ ftp://ftp.xfree86.org/pub/XFree86/4.3.0/source/X430src-1.tgz \
+ ftp://ftp.xfree86.org/pub/XFree86/4.3.0/source/X430src-2.tgz \
+ ftp://ftp.xfree86.org/pub/XFree86/4.3.0/source/X430src-3.tgz \
+ ftp://ftp.xfree86.org/pub/XFree86/4.3.0/source/X430src-4.tgz \
+ ftp://ftp.xfree86.org/pub/XFree86/4.3.0/source/X430src-5.tgz \
file://KeyMap.patch;patch=1 \
file://moc_call.patch;patch=1 \
file://imake-staging.patch;patch=1 \
file://cross.patch;patch=1 \
file://fephack.patch;patch=1 \
file://xchar2b.patch;patch=1 \
- file://xqt-make.patch;patch=1 "
+ file://xqt-make.patch;patch=1 \
+ file://fix_qtscreen_HACK.patch;patch=1 "
S = "${WORKDIR}/xc"
QT_LIBRARY = '${@base_conditional("PALMTOP_USE_MULTITHREADED_QT", "yes", "qte-mt", "qte",d)}'