aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xfce/xfce4-panel_4.4.2.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2008-06-13 19:54:43 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2008-10-17 14:08:04 -0300
commit56c7e1bcbed8aeaa4a8ea02ac1e905ab0892a0c2 (patch)
tree67533bb0eac105725510f01024d99d7d44a86c7a /packages/xfce/xfce4-panel_4.4.2.bb
parente2a3183722ab491f97b955240107520b54507d93 (diff)
downloadopenembedded-56c7e1bcbed8aeaa4a8ea02ac1e905ab0892a0c2.tar.gz
xfce4-panel: update to 4.4.2
Diffstat (limited to 'packages/xfce/xfce4-panel_4.4.2.bb')
-rw-r--r--packages/xfce/xfce4-panel_4.4.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/xfce/xfce4-panel_4.4.2.bb b/packages/xfce/xfce4-panel_4.4.2.bb
new file mode 100644
index 0000000000..dadc413cae
--- /dev/null
+++ b/packages/xfce/xfce4-panel_4.4.2.bb
@@ -0,0 +1,26 @@
+# xfce4-panel OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see COPYING.MIT)
+
+DESCRIPTION = "XFCE4 Panel"
+SECTION = "x11"
+DEPENDS = "startup-notification virtual/libx11 libxfcegui4 libxfce4mcs xfce-mcs-manager libxml2"
+
+inherit pkgconfig xfce
+
+EXTRA_OECONF += " --enable-startup-notification"
+
+
+do_stage() {
+autotools_stage_all
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}
+
+PACKAGES += "${PN}-plugins ${PN}-mcs-plugins"
+FILES_${PN}-plugins += "${libdir}/xfce4/panel-plugins/*.so* \
+ ${datadir}/xfce4/panel-plugins/*.desktop"
+FILES_${PN}-mcs-plugins += "${libdir}/xfce4/mcs-plugins/"
+FILES_${PN}-dbg += "${libdir}/xfce4/mcs-plugins/.debug"