aboutsummaryrefslogtreecommitdiffstats
path: root/packages/webkit
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-10-25 22:45:56 +0000
committerHolger Freyther <zecke@selfish.org>2007-10-25 22:45:56 +0000
commit279d19cb2b497fd1168adfc5fa5008e11e10a538 (patch)
treeb89ac19fd48860849226f97e1c73a6604e7e07f0 /packages/webkit
parenta5c64e02cdd62a588fdb3ef9fbeab9dfb7e1a742 (diff)
downloadopenembedded-279d19cb2b497fd1168adfc5fa5008e11e10a538.tar.gz
packages/webkit: Build and package naming fixes (when using debian renaming)
We do not want the package to be named libwebkitgtk-launcher but want to keep the webkit-gtklauncher names. The same applies to Qt and Qtopia. Use my Gtk+ API defines for the WebKit/Qt port as well.
Diffstat (limited to 'packages/webkit')
-rw-r--r--packages/webkit/files/qt-api-changes.diff27
-rw-r--r--packages/webkit/webkit-gtk_svn.bb4
-rw-r--r--packages/webkit/webkit-qt.inc12
-rw-r--r--packages/webkit/webkit-qt_svn.bb2
-rw-r--r--packages/webkit/webkit-qtopia_svn.bb4
-rw-r--r--packages/webkit/webkit.inc11
6 files changed, 55 insertions, 5 deletions
diff --git a/packages/webkit/files/qt-api-changes.diff b/packages/webkit/files/qt-api-changes.diff
new file mode 100644
index 0000000000..16f448b017
--- /dev/null
+++ b/packages/webkit/files/qt-api-changes.diff
@@ -0,0 +1,27 @@
+Index: WebKit/qt/Api/qwebkitglobal.h
+===================================================================
+--- WebKit/qt/Api/qwebkitglobal.h (revision 26079)
++++ WebKit/qt/Api/qwebkitglobal.h (working copy)
+@@ -25,15 +25,13 @@
+ #include <qglobal.h>
+
+ #if defined(Q_OS_WIN)
+-# if defined(BUILD_WEBKIT)
+-# define QWEBKIT_EXPORT Q_DECL_EXPORT
+-# else
+-# define QWEBKIT_EXPORT Q_DECL_IMPORT
+-# endif
++ #ifdef BUILD_WEBKIT
++ #define QWEBKIT_EXPORT __declspec(dllexport)
++ #else
++ #define QWEBKIT_EXPORT __declspec(dllimport)
++ #endif
++#else
++ #define QWEBKIT_EXPORT __attribute__((visibility("default")))
+ #endif
+
+-#if !defined(QWEBKIT_EXPORT)
+-#define QWEBKIT_EXPORT Q_DECL_EXPORT
+-#endif
+-
+ #endif // QWEBKITGLOBAL_H
diff --git a/packages/webkit/webkit-gtk_svn.bb b/packages/webkit/webkit-gtk_svn.bb
index 4722999949..262c6820db 100644
--- a/packages/webkit/webkit-gtk_svn.bb
+++ b/packages/webkit/webkit-gtk_svn.bb
@@ -1,14 +1,16 @@
DEPENDS = "curl icu libxml2 cairo libxslt libidn gnutls gtk+"
+
WEBKIT_PORT = "gtk-port"
WEBKIT_EXTRA_OPTIONS = "CONFIG-=qt"
-PACKAGES =+ "webkit-gtklauncher-dbg webkit-gtklauncher"
FILES_webkit-gtklauncher = "${bindir}/GtkLauncher"
FILES_webkit-gtklauncher-dbg = "${bindir}/.debug/GtkLauncher"
require webkit.inc
+PR = "r3"
+
do_install() {
install -d ${D}${bindir}
install -d ${D}${libdir}
diff --git a/packages/webkit/webkit-qt.inc b/packages/webkit/webkit-qt.inc
index cb9c1f7943..626b691e50 100644
--- a/packages/webkit/webkit-qt.inc
+++ b/packages/webkit/webkit-qt.inc
@@ -1,12 +1,15 @@
WEBKIT_PORT = "qt"
WEBKIT_EXTRA_OPTIONS = ""
-PACKAGES =+ "${PN}launcher-dbg ${PN}launcher"
FILES_${PN}launcher = "${bindir}/QtLauncher"
FILES_${PN}launcher-dbg = "${bindir}/.debug/*"
+RDEPENDS += "openssl"
+
require webkit.inc
+SRC_URI += " file://qt-api-changes.diff;patch=0;pnum=0 "
+
do_install() {
install -d ${D}${bindir}
install -d ${D}${libdir}
@@ -16,5 +19,12 @@ do_install() {
cd ${S}/WebKitBuilds/Debug
PWD=`pwd` ${WEBKIT_QMAKE} WEBKIT_INC_DIR=${D}${prefix}/include WEBKIT_LIB_DIR=${D}${libdir} $PWD/../../WebKit.pro
oe_runmake install
+
+ oe_libinstall -C ${S}/WebKitBuilds/Debug/lib libQtWebKit ${D}${libdir}
}
+# disabled as Qt and Qtopia will not like each other...
+#do_stage_prepend() {
+# oe_libinstall -C ${S}/WebKitBuilds/Debug/lib libQtWebKit ${D}${libdir}
+#}
+
diff --git a/packages/webkit/webkit-qt_svn.bb b/packages/webkit/webkit-qt_svn.bb
index e681e7a41b..fb525cbd35 100644
--- a/packages/webkit/webkit-qt_svn.bb
+++ b/packages/webkit/webkit-qt_svn.bb
@@ -1,4 +1,4 @@
require webkit-qt.inc
inherit qt4x11
-PR = "r1"
+PR = "r5"
diff --git a/packages/webkit/webkit-qtopia_svn.bb b/packages/webkit/webkit-qtopia_svn.bb
index 706f0f1cd1..6ea22b72ca 100644
--- a/packages/webkit/webkit-qtopia_svn.bb
+++ b/packages/webkit/webkit-qtopia_svn.bb
@@ -1,4 +1,6 @@
require webkit-qt.inc
inherit qtopia4core
-PR = "r1"
+WEBKIT_EXTRA_OPTIONS += "QT+=xml QT+=network"
+
+PR = "r5"
diff --git a/packages/webkit/webkit.inc b/packages/webkit/webkit.inc
index a80813f072..a04b565973 100644
--- a/packages/webkit/webkit.inc
+++ b/packages/webkit/webkit.inc
@@ -1,9 +1,10 @@
DEPENDS += "flex-native gperf-native perl-native sqlite3"
SRCREV_FORMAT = "webcore-rwebkit"
+PACKAGES =+ "${PN}launcher-dbg ${PN}launcher"
+
# Yes, this is wrong...
PV = "0.1+svnr${SRCREV}"
-PR = "r1"
inherit qmake2 pkgconfig
@@ -46,3 +47,11 @@ do_stage() {
oe_runmake install
}
+python populate_packages_prepend() {
+ print "foooo"
+ print bb.data.getVar("DEBIAN_NAMES", d, True)
+ if bb.data.getVar("DEBIAN_NAMES", d, True):
+ base = bb.data.expand("${PN}launcher", d, True)
+ bb.data.setVar("PKG_%s" % base, base, d)
+ bb.data.setVar("PKG_%s-dbg" % base, "%s-dbg" % base, d)
+}