aboutsummaryrefslogtreecommitdiffstats
path: root/packages/webkit
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-07-08 17:34:14 +0000
committerKoen Kooi <koen@openembedded.org>2008-07-08 17:34:14 +0000
commit1537b02b0ee6c7220a4b51b605e07caf513a3e2f (patch)
tree50fbc50024091d715070ebe6a9d99df9e0d44b52 /packages/webkit
parent62a49a5d718a7939d144bc10e4fd970b5f913c1d (diff)
downloadopenembedded-1537b02b0ee6c7220a4b51b605e07caf513a3e2f.tar.gz
webkit-gtk: bump SRCREV
Diffstat (limited to 'packages/webkit')
-rw-r--r--packages/webkit/webkit-gtk/GNUmakefile.am125
-rw-r--r--packages/webkit/webkit-gtk/Makefile4
-rw-r--r--packages/webkit/webkit-gtk/configure.ac163
-rw-r--r--packages/webkit/webkit-gtk/update-webkit.sh (renamed from packages/webkit/files/update-webkit.sh)0
-rw-r--r--packages/webkit/webkit-gtk_svn.bb2
5 files changed, 198 insertions, 96 deletions
diff --git a/packages/webkit/webkit-gtk/GNUmakefile.am b/packages/webkit/webkit-gtk/GNUmakefile.am
index 725c79d3c6..a6ae299039 100644
--- a/packages/webkit/webkit-gtk/GNUmakefile.am
+++ b/packages/webkit/webkit-gtk/GNUmakefile.am
@@ -14,8 +14,9 @@
#
# Sources, headers, flags, etc... should be added to the respective variables
# with the above suffix, e.g, webcore-specific sources should go to
-# webcore_sources, gtk port-specific flags should go to webkitgtk_cppflags,
-# etc... The only exceptions are the global variables. See Global Variables below.
+# webcore_sources, gtk port API and WebCoreSupport parts to webkitgtk_sources,
+# etc... The only exceptions are the global variables. See Global Variables
+# below.
#
# Global Variables
#
@@ -37,6 +38,8 @@ GENPROGRAMS := $(top_builddir)/Programs
CREATE_HASH_TABLE = $(srcdir)/JavaScriptCore/kjs/create_hash_table
# Libraries and support components
+bin_PROGRAMS :=
+
noinst_PROGRAMS :=
lib_LIBRARIES :=
@@ -71,6 +74,12 @@ global_cxxflags += \
-fno-rtti
endif
+# -no-undefined required for building DLLs on Windows
+# It breaks the build on other platforms, so we use it conditionally
+if OS_WIN32
+no_undefined = -no-undefined
+endif
+
# Shared libraries
lib_LTLIBRARIES = \
libwebkit-1.0.la
@@ -115,17 +124,19 @@ libJavaScriptCore_la_LIBADD = \
-lpthread
libJavaScriptCore_la_CXXFLAGS = \
+ -fstrict-aliasing \
+ -O3 \
$(global_cxxflags) \
$(global_cflags) \
$(GLOBALDEPS_CFLAGS) \
- $(UNICODE_CFLAGS) \
- -fno-strict-aliasing
+ $(UNICODE_CFLAGS)
libJavaScriptCore_la_CFLAGS = \
+ -fstrict-aliasing \
+ -O3 \
$(global_cflags) \
$(GLOBALDEPS_CFLAGS) \
- $(UNICODE_CFLAGS) \
- -fno-strict-aliasing
+ $(UNICODE_CFLAGS)
libJavaScriptCore_la_CPPFLAGS = \
$(global_cppflags) \
@@ -139,16 +150,22 @@ webcore_headers :=
webcore_libadd :=
webcore_built_sources :=
webcore_built_nosources :=
+webcoregtk_cppflags :=
+webcoregtk_sources :=
+webcoregtk_headers :=
nodist_libWebCore_la_SOURCES = \
$(webcore_built_sources)
libWebCore_la_SOURCES = \
$(webcore_headers) \
- $(webcore_sources)
+ $(webcore_sources) \
+ $(webcoregtk_headers) \
+ $(webcoregtk_sources)
libWebCore_la_CXXFLAGS = \
-fno-strict-aliasing \
+ -O2 \
$(global_cxxflags) \
$(global_cflags) \
$(GLOBALDEPS_CFLAGS) \
@@ -156,6 +173,7 @@ libWebCore_la_CXXFLAGS = \
$(WEBKITDEPS_CFLAGS) \
$(LIBCURL_CFLAGS) \
$(LIBSOUP_CFLAGS) \
+ $(FREETYPE_CFLAGS) \
$(SQLITE3_CFLAGS) \
$(GSTREAMER_CFLAGS) \
$(LIBXSLT_CFLAGS) \
@@ -164,12 +182,14 @@ libWebCore_la_CXXFLAGS = \
libWebCore_la_CFLAGS = \
-fno-strict-aliasing \
+ -O2 \
$(global_cflags) \
$(GLOBALDEPS_CFLAGS) \
$(UNICODE_CFLAGS) \
$(WEBKITDEPS_CFLAGS) \
$(LIBCURL_CFLAGS) \
$(LIBSOUP_CFLAGS) \
+ $(FREETYPE_CFLAGS) \
$(SQLITE3_CFLAGS) \
$(GSTREAMER_CFLAGS) \
$(LIBXSLT_CFLAGS) \
@@ -180,7 +200,7 @@ libWebCore_la_CPPFLAGS = \
$(global_cppflags) \
$(webcore_cppflags) \
$(javascriptcore_cppflags) \
- $(webkitgtk_cppflags) \
+ $(webcoregtk_cppflags) \
$(HILDON_CPPFLAGS)
libWebCore_la_LIBADD = \
@@ -190,6 +210,7 @@ libWebCore_la_LIBADD = \
$(WEBKITDEPS_LIBS) \
$(LIBCURL_LIBS) \
$(LIBSOUP_LIBS) \
+ $(FREETYPE_LIBS) \
$(UNICODE_LIBS) \
$(SQLITE3_LIBS) \
$(GSTREAMER_LIBS) \
@@ -211,7 +232,9 @@ nodist_libwebkit_1_0_la_SOURCES = \
$(webkitgtk_built_sources)
libwebkit_1_0_ladir = $(prefix)/include/webkit-1.0/webkit
-libwebkit_1_0_la_HEADERS = $(webkitgtk_h_api)
+libwebkit_1_0_la_HEADERS = \
+ $(webkitgtk_h_api) \
+ WebKit/gtk/webkit/webkitenumtypes.h
libwebkit_1_0_la_SOURCES = \
$(webkitgtk_headers) \
@@ -224,11 +247,13 @@ libwebkit_1_0_la_CFLAGS = \
$(libWebCore_la_CFLAGS)
libwebkit_1_0_la_CPPFLAGS = \
- $(libWebCore_la_CPPFLAGS)
+ $(libWebCore_la_CPPFLAGS) \
+ $(webkitgtk_cppflags)
libwebkit_1_0_la_LDFLAGS = \
$(COVERAGE_LDFLAGS) \
- -version-info @LIBWEBKITGTK_VERSION@
+ -version-info @LIBWEBKITGTK_VERSION@ \
+ $(no_undefined)
libwebkit_1_0_la_LIBADD = \
libWebCore.la
@@ -236,6 +261,7 @@ libwebkit_1_0_la_LIBADD = \
#
# Extra checks and flags
global_cppflags += \
+ -DBUILDING_CAIRO__=1 \
-DBUILDING_GTK__=1 \
-DWTF_CHANGES
@@ -252,7 +278,7 @@ endif
if !ENABLE_DEBUG
global_cppflags += -DNDEBUG
else
-webkitgtk_cppflags += \
+webcoregtk_cppflags += \
-DG_DISABLE_DEPRECATED \
-DGDK_PIXBUF_DISABLE_DEPRECATED \
-DGDK_DISABLE_DEPRECATED \
@@ -282,15 +308,11 @@ if ENABLE_VIDEO
webcore_libadd += -lgstinterfaces-0.10 -lgstvideo-0.10
endif
-webkitgtk_cppflags += \
--I$(top_builddir)/WebKit/gtk/webkit \
--DBUILDING_CAIRO__=1 \
--DBUILD_WEBKIT
-
webkitgtk_h_api += \
WebKit/gtk/webkit/webkit.h \
WebKit/gtk/webkit/webkitdefines.h \
WebKit/gtk/webkit/webkitnetworkrequest.h \
+ WebKit/gtk/webkit/webkitversion.h \
WebKit/gtk/webkit/webkitwebbackforwardlist.h \
WebKit/gtk/webkit/webkitwebframe.h \
WebKit/gtk/webkit/webkitwebhistoryitem.h \
@@ -299,7 +321,9 @@ webkitgtk_h_api += \
webkitgtk_built_sources += \
DerivedSources/webkit-marshal.h \
- DerivedSources/webkit-marshal.cpp
+ DerivedSources/webkit-marshal.cpp \
+ DerivedSources/webkitenumtypes.cpp \
+ WebKit/gtk/webkit/webkitenumtypes.h
webkitgtk_headers += \
WebKit/gtk/webkit/webkitprivate.h \
@@ -314,6 +338,7 @@ webkitgtk_headers += \
webkitgtk_sources += \
WebKit/gtk/webkit/webkitnetworkrequest.cpp \
WebKit/gtk/webkit/webkitprivate.cpp \
+ WebKit/gtk/webkit/webkitversion.cpp \
WebKit/gtk/webkit/webkitwebbackforwardlist.cpp \
WebKit/gtk/webkit/webkitwebframe.cpp \
WebKit/gtk/webkit/webkitwebhistoryitem.cpp \
@@ -327,6 +352,13 @@ webkitgtk_sources += \
WebKit/gtk/WebCoreSupport/InspectorClientGtk.cpp \
WebKit/gtk/WebCoreSupport/PasteboardHelperGtk.cpp
+webkitgtk_cppflags += \
+ -DBUILDING_WEBKIT \
+ -I$(srcdir)/WebKit/gtk \
+ -I$(srcdir)/WebKit/gtk/WebCoreSupport \
+ -I$(srcdir)/WebKit/gtk/webkit \
+ -I$(top_builddir)/WebKit/gtk/webkit
+
webkitgtk_cleanfiles += \
$(top_builddir)/Programs/GtkLauncher \
$(top_builddir)/WebKit/gtk/webkit-1.0.pc
@@ -334,12 +366,14 @@ webkitgtk_cleanfiles += \
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = WebKit/gtk/webkit-1.0.pc
-WEBKIT_MARSHAL = $(GENSOURCES)/webkit-marshal
-WEBKIT_MARSHAL_LIST = $(srcdir)/WebKit/gtk/webkit/webkit-marshal.list
-
stamp_files := \
stamp-webkit-marshal.cpp \
- stamp-webkit-marshal.h
+ stamp-webkit-marshal.h \
+ stamp-webkitenumtypes.cpp \
+ stamp-webkitenumtypes.h
+
+WEBKIT_MARSHAL = $(GENSOURCES)/webkit-marshal
+WEBKIT_MARSHAL_LIST = $(srcdir)/WebKit/gtk/webkit/webkit-marshal.list
DerivedSources/webkit-marshal.cpp: stamp-webkit-marshal.cpp
@true
@@ -356,6 +390,53 @@ stamp-webkit-marshal.h: $(WEBKIT_MARSHAL_LIST)
$(GLIB_GENMARSHAL) --prefix=webkit_marshal $(WEBKIT_MARSHAL_LIST) --header > $(WEBKIT_MARSHAL).h && \
echo timestamp > $(@F)
+WebKit/gtk/webkit/webkitenumtypes.h: stamp-webkitenumtypes.h
+ @true
+stamp-webkitenumtypes.h: $(webkitgtk_h_api) Makefile
+ (cd $(srcdir) \
+ && glib-mkenums \
+ --fhead "#ifndef WEBKIT_ENUM_TYPES_H\n" \
+ --fhead "#define WEBKIT_ENUM_TYPES_H\n\n" \
+ --fhead "#include <glib-object.h>\n\n" \
+ --fhead "#include <webkit/webkitdefines.h>\n\n" \
+ --fhead "G_BEGIN_DECLS\n\n" \
+ --ftail "G_END_DECLS\n\n" \
+ --ftail "#endif\n" \
+ --fprod "#include <@filename@>\n\n" \
+ --eprod "#define WEBKIT_TYPE_@ENUMSHORT@ @enum_name@_get_type()\n\n" \
+ --eprod "WEBKIT_API GType\n@enum_name@_get_type(void);\n\n" \
+ $(webkitgtk_h_api) | \
+ sed 's,WebKit/gtk/,,' | \
+ sed 's,web_kit,webkit,' | \
+ sed 's,WEBKIT_TYPE_KIT,WEBKIT_TYPE,' \
+ ) > xgen-gth \
+ && (cmp -s xgen-gth WebKit/gtk/webkit/webkitenumtypes.h || cp xgen-gth WebKit/gtk/webkit/webkitenumtypes.h) \
+ && rm -f xgen-gth \
+ && echo timestamp > $(@F)
+
+DerivedSources/webkitenumtypes.cpp: $(webkitgtk_h_api) Makefile
+ (cd $(srcdir) \
+ && glib-mkenums \
+ --fhead "#include <config.h>\n" \
+ --fhead "#include <glib-object.h>\n" \
+ --fhead "#include \"$(top_builddir)/WebKit/gtk/webkit/webkitenumtypes.h\"\n\n" \
+ --fhead "extern \"C\" {\n\n" \
+ --fprod "\n/* enumerations from \"@filename@\" */" \
+ --vhead "static const G@Type@Value _@enum_name@_values[] = {" \
+ --vprod " { @VALUENAME@, \"@VALUENAME@\", \"@valuenick@\" }," \
+ --vtail " { 0, NULL, NULL }\n};\n\n" \
+ --vtail "GType @enum_name@_get_type(void)\n{\n" \
+ --vtail " static GType type = 0;\n\n" \
+ --vtail " if (!type)\n" \
+ --vtail " type = g_@type@_register_static(\"@EnumName@\", _@enum_name@_values);\n\n" \
+ --vtail " return type;\n}\n\n" \
+ --ftail "}\n" \
+ $(webkitgtk_h_api) | \
+ sed 's,web_kit,webkit,' \
+ ) > xgen-gtc \
+ && cp xgen-gtc $@ \
+ && rm -f xgen-gtc
+
# END WEBKIT GTK+
# Files that will be cleaned
diff --git a/packages/webkit/webkit-gtk/Makefile b/packages/webkit/webkit-gtk/Makefile
index fa7ea02426..217a035483 100644
--- a/packages/webkit/webkit-gtk/Makefile
+++ b/packages/webkit/webkit-gtk/Makefile
@@ -16,6 +16,10 @@ universal u:
@for dir in $(MODULES); do ${MAKE} $@ -C $$dir; exit_status=$$?; \
if [ $$exit_status -ne 0 ]; then exit $$exit_status; fi; done
+x86_64:
+ @for dir in $(MODULES); do ${MAKE} $@ -C $$dir; exit_status=$$?; \
+ if [ $$exit_status -ne 0 ]; then exit $$exit_status; fi; done
+
64:
@for dir in $(MODULES); do ${MAKE} $@ -C $$dir; exit_status=$$?; \
if [ $$exit_status -ne 0 ]; then exit $$exit_status; fi; done
diff --git a/packages/webkit/webkit-gtk/configure.ac b/packages/webkit/webkit-gtk/configure.ac
index 24488ef6c4..d0aa7c84d1 100644
--- a/packages/webkit/webkit-gtk/configure.ac
+++ b/packages/webkit/webkit-gtk/configure.ac
@@ -1,11 +1,24 @@
-AC_INIT([WebKit],[0.1],[http://bugs.webkit.org/])
-
AC_PREREQ(2.59)
+m4_define([webkit_major_version], [1])
+m4_define([webkit_minor_version], [0])
+m4_define([webkit_micro_version], [2])
+
+AC_INIT([WebKit],[webkit_major_version.webkit_minor_version.webkit_micro_version],[http://bugs.webkit.org/])
+
AC_CONFIG_HEADERS([aconfig.h])
+
+WEBKIT_MAJOR_VERSION=webkit_major_version
+WEBKIT_MINOR_VERSION=webkit_minor_version
+WEBKIT_MICRO_VERSION=webkit_micro_version
+AC_SUBST(WEBKIT_MAJOR_VERSION)
+AC_SUBST(WEBKIT_MINOR_VERSION)
+AC_SUBST(WEBKIT_MICRO_VERSION)
+
AC_CONFIG_SRCDIR([WebCore/config.h])
-# see http://www.gnu.org/software/libtool/manual.html#Versioning
+dnl # Libtool library version, not to confuse with API version
+dnl # see http://www.gnu.org/software/libtool/manual.html#Versioning
LIBWEBKITGTK_VERSION=1:0:0
AC_SUBST([LIBWEBKITGTK_VERSION])
@@ -38,23 +51,24 @@ case "$host" in
;;
esac
-# If CXXFLAGS and CFLAGS are unset, default to -O2
+# If CXXFLAGS and CFLAGS are unset, default to empty.
# This is to tell automake not to include '-g' if CXXFLAGS is not set
# For more info - http://www.gnu.org/software/automake/manual/autoconf.html#C_002b_002b-Compiler
if test -z "$CXXFLAGS"; then
- CXXFLAGS="-O2"
+ CXXFLAGS=""
fi
if test -z "$CFLAGS"; then
- CFLAGS="-O2"
+ CFLAGS=""
fi
-# programs
-AC_DISABLE_STATIC
-AM_PROG_LIBTOOL
-AC_PROG_INSTALL
AM_PROG_CC_STDC
-AC_PROG_CXX
AM_PROG_CC_C_O
+AC_PROG_CXX
+AC_PROG_INSTALL
+AC_DISABLE_STATIC
+AC_LIBTOOL_WIN32_DLL
+AC_PROG_LIBTOOL
+DOLT
# check for -fvisibility=hidden compiler support (GCC >= 4)
saved_CFLAGS="$CFLAGS"
@@ -147,10 +161,12 @@ esac
AC_MSG_RESULT([$unicode_backend])
if test "$unicode_backend" = "icu"; then
- # check for icu-config
if test "$os_darwin" = "yes"; then
UNICODE_CFLAGS="-I\$(srcdir)/JavaScriptCore/icu -I\$(srcdir)/WebCore/icu"
UNICODE_LIBS="-licucore"
+ elif test "$os_win32" = "yes"; then
+ UNICODE_CFLAGS=""
+ UNICODE_LIBS="-licuin -licuuc"
else
AC_PATH_PROG(icu_config, icu-config, no)
if test "$icu_config" = "no"; then
@@ -243,9 +259,6 @@ PKG_CHECK_MODULES([WEBKITDEPS],
[gtk+-2.0 >= $GTK_REQUIRED_VERSION
pango >= $PANGO_REQUIRED_VERSION
cairo >= $CAIRO_REQUIRED_VERSION
- cairo-ft,
- fontconfig >= $FONTCONFIG_REQUIRED_VERSION
- freetype2 >= $FREETYPE2_REQUIRED_VERSION
libxml-2.0 >= $LIBXML_REQUIRED_VERSION])
AC_SUBST([WEBKITDEPS_CFLAGS])
AC_SUBST([WEBKITDEPS_LIBS])
@@ -266,14 +279,6 @@ AC_ARG_ENABLE(dashboard_support,
[],[enable_dashboard_support="yes"])
AC_MSG_RESULT([$enable_dashboard_support])
-# check whether to build with cross-document messaging support
-AC_MSG_CHECKING([whether to enable HTML5 cross-document messaging support])
-AC_ARG_ENABLE(cross_document_messaging,
- AC_HELP_STRING([--enable-cross-document-messaging],
- [enable HTML5 cross-document messaging support [default=yes]]),
- [],[enable_cross_document_messaging="yes"])
-AC_MSG_RESULT([$enable_cross_document_messaging])
-
# check whether to enable HTML5 Offline Web Applications support
AC_MSG_CHECKING([whether to enable HTML5 offline web applications support])
AC_ARG_ENABLE(offline_web_applications,
@@ -286,8 +291,8 @@ AC_MSG_RESULT([$enable_offline_web_applications])
AC_MSG_CHECKING([whether to enable HTML5 client-side session and persistent storage support])
AC_ARG_ENABLE(dom_storage,
AC_HELP_STRING([--enable-dom-storage],
- [enable HTML5 client-side session and persistent storage support [default=no]]),
- [],[enable_dom_storage="no"])
+ [enable HTML5 client-side session and persistent storage support [default=yes]]),
+ [],[enable_dom_storage="yes"])
AC_MSG_RESULT([$enable_dom_storage])
# check whether to build with database support
@@ -302,8 +307,8 @@ AC_MSG_RESULT([$enable_database])
AC_MSG_CHECKING([whether to enable icon database support])
AC_ARG_ENABLE(icon_database,
AC_HELP_STRING([--enable-icon-database],
- [enable icon database [default=no]]),
- [],[enable_icon_database="no"])
+ [enable icon database [default=yes]]),
+ [],[enable_icon_database="yes"])
AC_MSG_RESULT([$enable_icon_database])
# check whether to enable HTML5 audio/video support
@@ -330,39 +335,30 @@ AC_ARG_ENABLE(xslt,
[],[enable_xslt="yes"])
AC_MSG_RESULT([$enable_xslt])
-# check whether to enable SVG experimental features
-# Enable all SVG if it is
-AC_MSG_CHECKING([whether to enable SVG experimental features])
-AC_ARG_ENABLE(svg_experimental,
- AC_HELP_STRING([--enable-svg-experimental],
- [enable support for SVG experimental features [default=no]]),
- [],[enable_svg_experimental="no"])
-AC_MSG_RESULT([$enable_svg_experimental])
-
-if test "$enable_svg_experimental" = "yes"; then
- enable_svg=yes
- enable_svg_animation=yes
-# enable_svg_filters=yes
- enable_svg_fonts=yes
- enable_svg_foreign_object=yes
- enable_svg_as_image=yes
- enable_svg_use_element=yes
-fi
-
# check whether to enable SVG support
AC_MSG_CHECKING([whether to enable SVG support])
AC_ARG_ENABLE(svg,
AC_HELP_STRING([--enable-svg],
- [enable support for SVG [default=no]]),
- [],[enable_svg="no"])
+ [enable support for SVG [default=yes]]),
+ [],[enable_svg="yes"])
AC_MSG_RESULT([$enable_svg])
+# turn off svg features if --disable-svg is requested
+if test "$enable_svg" = "no"; then
+ enable_svg_animation=no
+ enable_svg_filters=no
+ enable_svg_fonts=no
+ enable_svg_foreign_object=no
+ enable_svg_as_image=no
+ enable_svg_use_element=no
+fi
+
# check whether to enable support for SVG animation
AC_MSG_CHECKING([whether to enable support for SVG animation])
AC_ARG_ENABLE(svg_animation,
AC_HELP_STRING([--enable-svg-animation],
- [enable support for SVG animation (experimental) [default=no]]),
- [],[enable_svg_animation="no"])
+ [enable support for SVG animation (experimental) [default=yes]]),
+ [],[enable_svg_animation="yes"])
AC_MSG_RESULT([$enable_svg_animation])
# check whether to enable support for SVG filters
@@ -377,34 +373,48 @@ AC_MSG_RESULT([$enable_svg_filters])
AC_MSG_CHECKING([whether to enable support for SVG fonts])
AC_ARG_ENABLE(svg_fonts,
AC_HELP_STRING([--enable-svg-fonts],
- [enable support for SVG fonts (experimental) [default=no]]),
- [],[enable_svg_fonts="no"])
+ [enable support for SVG fonts (experimental) [default=yes]]),
+ [],[enable_svg_fonts="yes"])
AC_MSG_RESULT([$enable_svg_fonts])
# check whether to enable foreign objects support for SVG
AC_MSG_CHECKING([whether to enable support for SVG foreign objects])
AC_ARG_ENABLE(svg_foreign_object,
AC_HELP_STRING([--enable-svg-foreign-object],
- [enable support for SVG foreign objects (experimental) [default=no]]),
- [],[enable_svg_foreign_object="no"])
+ [enable support for SVG foreign objects (experimental) [default=yes]]),
+ [],[enable_svg_foreign_object="yes"])
AC_MSG_RESULT([$enable_svg_foreign_object])
# check whether to enable SVG As Image support
AC_MSG_CHECKING([whether to enable SVG as Image support])
AC_ARG_ENABLE(svg_as_image,
AC_HELP_STRING([--enable-svg-as-image],
- [enable SVG as Image support (experimental) [default=no]]),
- [],[enable_svg_as_image="no"])
+ [enable SVG as Image support (experimental) [default=yes]]),
+ [],[enable_svg_as_image="yes"])
AC_MSG_RESULT([$enable_svg_as_image])
# check whether to enable SVG USE element support
AC_MSG_CHECKING([whether to enable support for SVG use element])
AC_ARG_ENABLE(svg_use_element,
AC_HELP_STRING([--enable-svg-use-element],
- [enable SVG use element support (experimental) [default=no]]),
- [],[enable_svg_use_element="no"])
+ [enable SVG use element support (experimental) [default=yes]]),
+ [],[enable_svg_use_element="yes"])
AC_MSG_RESULT([$enable_svg_use_element])
+# check for SVG features, enabling SVG if necessary
+if test "$enable_svg_animation" = "yes" || \
+ test "$enable_svg_filters" = "yes" || \
+ test "$enable_svg_fonts" = "yes" || \
+ test "$enable_svg_foreign_object" = "yes" || \
+ test "$enable_svg_as_image" = "yes" || \
+ test "$enable_svg_use_element" = "yes"; then
+ svg_flags=yes
+ if test "$enable_svg" = "no"; then
+ AC_MSG_WARN([SVG feature(s) requested but SVG is disabled.. Enabling SVG support])
+ enable_svg=yes
+ fi
+fi
+
# check whether to enable code coverage
AC_MSG_CHECKING([whether to enable code coverage support])
AC_ARG_ENABLE(coverage,
@@ -444,6 +454,9 @@ fi
if test "$with_http_backend" = "curl"; then
PKG_CHECK_MODULES([LIBCURL],
[libcurl >= $LIBCURL_REQUIRED_VERSION])
+ if test "$os_win32" = "yes"; then
+ LIBCURL_LIBS="$LIBCURL_LIBS -lWs2_32"
+ fi
AC_SUBST([LIBCURL_CFLAGS])
AC_SUBST([LIBCURL_LIBS])
fi
@@ -455,8 +468,21 @@ if test "$with_http_backend" = "soup"; then
AC_SUBST([LIBSOUP_LIBS])
fi
+# check if FreeType/FontConfig are available
+if test "$with_font_backend" = "freetype"; then
+ PKG_CHECK_MODULES([FREETYPE],
+ [cairo-ft
+ fontconfig >= $FONTCONFIG_REQUIRED_VERSION
+ freetype2 >= $FREETYPE2_REQUIRED_VERSION])
+ AC_SUBST([FREETYPE_CFLAGS])
+ AC_SUBST([FREETYPE_LIBS])
+fi
+
# check if sqlite 3 is available
-if test "$enable_icon_database" = "yes" || test "$enable_database" = "yes"; then
+if test "$enable_icon_database" = "yes" || \
+ test "$enable_database" = "yes" || \
+ test "$enable_offline_web_applications" = "yes" || \
+ test "$enable_dom_storage" = "yes"; then
PKG_CHECK_MODULES([SQLITE3], [sqlite3 >= $SQLITE_REQUIRED_VERSION])
AC_SUBST([SQLITE3_CFLAGS])
AC_SUBST([SQLITE3_LIBS])
@@ -488,18 +514,9 @@ if test "$enable_coverage" = "yes"; then
AC_SUBST([COVERAGE_LDFLAGS])
fi
-# check for SVG features, enabling SVG if necessary
-if test "$enable_svg_animation" = "yes" || \
- test "$enable_svg_filters" = "yes" || \
- test "$enable_svg_fonts" = "yes" || \
- test "$enable_svg_foreign_object" = "yes" || \
- test "$enable_svg_as_image" = "yes" || \
- test "$enable_svg_use_element" = "yes"; then
- svg_flags=yes
- if test "$enable_svg" = "no"; then
- AC_MSG_WARN([SVG feature(s) requested but SVG is disabled.. Enabling SVG support])
- enable_svg=yes
- fi
+# check for HTML features
+if test "$enable_video" = "yes"; then
+ html_flags=yes
fi
# OS conditionals
@@ -525,7 +542,6 @@ AM_CONDITIONAL([USE_PANGO], [test "$with_font_backend" = "pango"])
# WebKit feature conditionals
AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug" = "yes"])
AM_CONDITIONAL([ENABLE_DASHBOARD_SUPPORT],[test "$enable_dashboard_support" = "yes"])
-AM_CONDITIONAL([ENABLE_CROSS_DOCUMENT_MESSAGING],[test "$enable_cross_document_messaging" = "yes"])
AM_CONDITIONAL([ENABLE_OFFLINE_WEB_APPLICATIONS],[test "$enable_offline_web_applications" = "yes"])
AM_CONDITIONAL([ENABLE_DOM_STORAGE],[test "$enable_dom_storage" = "yes"])
AM_CONDITIONAL([ENABLE_DATABASE],[test "$enable_database" = "yes"])
@@ -543,10 +559,12 @@ AM_CONDITIONAL([ENABLE_SVG_USE],[test "$enable_svg_use_element" = "yes"])
AM_CONDITIONAL([ENABLE_COVERAGE],[test "$enable_coverage" = "yes"])
AM_CONDITIONAL([ENABLE_FAST_MALLOC],[test "$enable_fast_malloc" = "yes"])
AM_CONDITIONAL([SVG_FLAGS],[test "$svg_flags" = "yes"])
+AM_CONDITIONAL([HTML_FLAGS],[test "$html_flags" = "yes"])
AC_CONFIG_FILES([
GNUmakefile
WebKit/gtk/webkit-1.0.pc:WebKit/gtk/webkit.pc.in
+WebKit/gtk/webkit/webkitversion.h
]
)
@@ -564,7 +582,6 @@ Build configuration:
Optimized memory allocator : $enable_fast_malloc
Features:
Dashboard support : $enable_dashboard_support
- HTML5 cross-document messaging : $enable_cross_document_messaging
HTML5 offline web applications support : $enable_offline_web_applications
HTML5 client-side session and persistent storage support : $enable_dom_storage
HTML5 client-side database storage support : $enable_database
diff --git a/packages/webkit/files/update-webkit.sh b/packages/webkit/webkit-gtk/update-webkit.sh
index e4cc3ebefa..e4cc3ebefa 100644
--- a/packages/webkit/files/update-webkit.sh
+++ b/packages/webkit/webkit-gtk/update-webkit.sh
diff --git a/packages/webkit/webkit-gtk_svn.bb b/packages/webkit/webkit-gtk_svn.bb
index 11e08ac6ac..06f869ef48 100644
--- a/packages/webkit/webkit-gtk_svn.bb
+++ b/packages/webkit/webkit-gtk_svn.bb
@@ -24,7 +24,7 @@ SRC_URI = "\
S = "${WORKDIR}/"
-inherit autotools pkgconfig
+inherit autotools pkgconfig lib_package
EXTRA_OECONF = "\
--enable-debug=no \