aboutsummaryrefslogtreecommitdiffstats
path: root/packages/vnc/tightvnc_1.3.9.bb
diff options
context:
space:
mode:
authorJunqian Gordon Xu <xjqian@gmail.com>2008-09-21 15:47:00 +0000
committerJunqian Gordon Xu <xjqian@gmail.com>2008-09-21 15:47:00 +0000
commit549fcd819a9e713e2ed2debb56e60afbdde0531c (patch)
tree709f58a215cf1b19a8d8d6577d7658bc9fb8f8c5 /packages/vnc/tightvnc_1.3.9.bb
parent6c2adc3fe62322636b3099ec6ff945d5c8534d55 (diff)
downloadopenembedded-549fcd819a9e713e2ed2debb56e60afbdde0531c.tar.gz
tightvnc: bump to 1.3.9
* fix hard coded path and package name * note: only tightvnc-viewer is built and shipped
Diffstat (limited to 'packages/vnc/tightvnc_1.3.9.bb')
-rw-r--r--packages/vnc/tightvnc_1.3.9.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/vnc/tightvnc_1.3.9.bb b/packages/vnc/tightvnc_1.3.9.bb
new file mode 100644
index 0000000000..ec6a7057d9
--- /dev/null
+++ b/packages/vnc/tightvnc_1.3.9.bb
@@ -0,0 +1,25 @@
+DESCRIPTION-${PN}-viewer = "A lightweight VNC viewer"
+HOMEPAGE = "http://www.tightvnc.com/"
+DEPENDS = "virtual/libx11 zlib libxmu libxaw"
+LICENSE = "GPL"
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/vnc-tight/${PN}-${PV}_unixsrc.tar.gz \
+ file://Makefile"
+
+S = "${WORKDIR}/vnc_unixsrc/vncviewer/"
+
+PACKAGES = "${PN}-viewer-dbg ${PN}-viewer"
+FILES_${PN}-viewer-dbg = "${bindir}/.debug"
+FILES_${PN}-viewer = "${bindir}/${PN}viewer"
+
+do_compile () {
+ install ${WORKDIR}/Makefile ${S}
+ oe_runmake
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install ${PN}viewer ${D}${bindir}
+}