aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ushare
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2008-02-07 11:17:47 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2008-02-07 11:17:47 +0000
commitb793d8f421a84ea0769c6f6ecf521253ced0636d (patch)
tree596ae673c99a9f9576e549e79902af24022ff0cb /packages/ushare
parent9e0a4ee6bc1aa2345cfd5448c39c198d3c9d5e31 (diff)
downloadopenembedded-b793d8f421a84ea0769c6f6ecf521253ced0636d.tar.gz
ushare_1.1a.bb: package ushare version 1.1a
Diffstat (limited to 'packages/ushare')
-rw-r--r--packages/ushare/ushare_1.1a.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/ushare/ushare_1.1a.bb b/packages/ushare/ushare_1.1a.bb
new file mode 100644
index 0000000000..b198d89c95
--- /dev/null
+++ b/packages/ushare/ushare_1.1a.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "ushare is a UPnP media server"
+LICENSE = "GPL"
+HOMEPAGE = "http://ushare.geexbox.org/"
+DEPENDS = "libupnp virtual/libiconv virtual/libintl"
+SRC_URI = "http://ushare.geexbox.org/releases/ushare-${PV}.tar.bz2"
+S = "${WORKDIR}/ushare-${PV}"
+
+inherit autotools gettext
+
+# the configure script is hand-crafted, it rejects some of the usual
+# configure arguments
+do_configure () {
+ ${S}/configure \
+ --prefix=${prefix} \
+ --bindir=${bindir} \
+ --localedir=${datadir}/locale \
+ --sysconfdir=${sysconfdir} \
+ --cross-compile
+}
+