aboutsummaryrefslogtreecommitdiffstats
path: root/packages/u-boot/u-boot_git.bb
diff options
context:
space:
mode:
authorant <ant@unknown.openembedded.org>2008-08-22 16:56:50 +0000
committerPhil Blundell <philb@gnu.org>2008-08-22 16:56:50 +0000
commita67cb0ff5cf6670a151b7583ac078b72b7ccb836 (patch)
tree8f83600feda144c1fefa5f99d01969f63150e169 /packages/u-boot/u-boot_git.bb
parentf56aab883db4a1fde7bd23318ef64a0d6139b6af (diff)
downloadopenembedded-a67cb0ff5cf6670a151b7583ac078b72b7ccb836.tar.gz
apply latest u-boot-on-zaurus patch from bug #3738
Diffstat (limited to 'packages/u-boot/u-boot_git.bb')
-rw-r--r--packages/u-boot/u-boot_git.bb28
1 files changed, 27 insertions, 1 deletions
diff --git a/packages/u-boot/u-boot_git.bb b/packages/u-boot/u-boot_git.bb
index 04eb7eb2e8..a5f6cca220 100644
--- a/packages/u-boot/u-boot_git.bb
+++ b/packages/u-boot/u-boot_git.bb
@@ -1,10 +1,13 @@
require u-boot.inc
-PR="r16"
+PR="r17"
SRCREV_davinci-sffsdr = "4b50cd12a3b3c644153c4cf393f4a4c12289e5aa"
SRCREV_davinci-dvevm = "4b50cd12a3b3c644153c4cf393f4a4c12289e5aa"
SRCREV_beagleboard = "9c1c36409b2cb4e81aab0bd9d0a69c68f4475aae"
SRCREV_neuros-osd2 = "bc66414cd99154a40949db1bd2f45a62b8febca9"
+SRCREV_akita = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
+SRCREV_spitz = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
+SRCREV_c7x0 = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git "
SRC_URI_sequoia = "git://www.denx.de/git/u-boot.git;protocol=git;tag=cf3b41e0c1111dbb865b6e34e9f3c3d3145a6093 "
@@ -15,7 +18,30 @@ SRC_URI_beagleboard = "git://www.sakoman.net/git/u-boot-omap3.git;branch=test;pr
"
SRC_URI_neuros-osd2 += "file://Makefile-fix.patch;patch=1"
+SRC_URI_append_akita = "file://pdaXrom-u-boot.patch;patch=1 \
+ file://uboot-eabi-fix-HACK2.patch;patch=1 \
+ file://akita-standard-partitioning.patch;patch=1 \
+SRC_URI_append_spitz = "file://pdaXrom-u-boot.patch;patch=1 \
+ file://uboot-eabi-fix-HACK2.patch;patch=1 \
+ file://spitz-standard-partitioning.patch;patch=1 \
+ "
+SRC_URI_append_c7x0 = "file://pdaXrom-u-boot.patch;patch=1 \
+ file://uboot-eabi-fix-HACK2.patch;patch=1 \
+ file://corgi-standard-partitioning.patch;patch=1 \
+ "
S = "${WORKDIR}/git"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_configure_prepend_akita() {
+ sed -i s:ROOT_FLASH_SIZE:${ROOT_FLASH_SIZE}:g ${S}/include/configs/akita.h
+}
+
+do_configure_prepend_spitz() {
+ sed -i s:ROOT_FLASH_SIZE:${ROOT_FLASH_SIZE}:g ${S}/include/configs/akita.h
+}
+
+do_configure_prepend_c7x0() {
+ sed -i s:ROOT_FLASH_SIZE:${ROOT_FLASH_SIZE}:g ${S}/include/configs/corgi.h
+}