aboutsummaryrefslogtreecommitdiffstats
path: root/packages/tslib
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-05-25 13:28:26 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-25 13:28:26 +0000
commit2778f69aff1605a888311176059c5ddfd85796df (patch)
treefc103d022c4bbd4da45282c2fc43caa1733e08a3 /packages/tslib
parent37fbb9165458b5912a0e676eb39d321e85f1cc79 (diff)
downloadopenembedded-2778f69aff1605a888311176059c5ddfd85796df.tar.gz
tslib cvs: add support for the Motorola E680 and A780
Diffstat (limited to 'packages/tslib')
-rw-r--r--packages/tslib/tslib/a780/.mtn2git_empty0
-rw-r--r--packages/tslib/tslib/a780/tslib.sh6
-rw-r--r--packages/tslib/tslib/e680/.mtn2git_empty0
-rw-r--r--packages/tslib/tslib/e680/tslib.sh6
-rw-r--r--packages/tslib/tslib_cvs.bb41
5 files changed, 36 insertions, 17 deletions
diff --git a/packages/tslib/tslib/a780/.mtn2git_empty b/packages/tslib/tslib/a780/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/tslib/tslib/a780/.mtn2git_empty
diff --git a/packages/tslib/tslib/a780/tslib.sh b/packages/tslib/tslib/a780/tslib.sh
new file mode 100644
index 0000000000..2244648861
--- /dev/null
+++ b/packages/tslib/tslib/a780/tslib.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+TSLIB_TSDEVICE=/dev/input/event1
+TSLIB_CONFFILE=/usr/share/tslib/ts-2.6.conf
+
+export TSLIB_TSDEVICE TSLIB_CONFFILE
diff --git a/packages/tslib/tslib/e680/.mtn2git_empty b/packages/tslib/tslib/e680/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/tslib/tslib/e680/.mtn2git_empty
diff --git a/packages/tslib/tslib/e680/tslib.sh b/packages/tslib/tslib/e680/tslib.sh
new file mode 100644
index 0000000000..2244648861
--- /dev/null
+++ b/packages/tslib/tslib/e680/tslib.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+TSLIB_TSDEVICE=/dev/input/event1
+TSLIB_CONFFILE=/usr/share/tslib/ts-2.6.conf
+
+export TSLIB_TSDEVICE TSLIB_CONFFILE
diff --git a/packages/tslib/tslib_cvs.bb b/packages/tslib/tslib_cvs.bb
index bac18153fa..57eede769d 100644
--- a/packages/tslib/tslib_cvs.bb
+++ b/packages/tslib/tslib_cvs.bb
@@ -1,36 +1,35 @@
+DESCRIPTION = "tslib is a plugin-based flexible touchscreen access library."
+HOMEPAGE = "http://cvs.arm.linux.org.uk/"
+AUTHOR = "Russel King. Plugins by Chris Larson et. al."
SECTION = "base"
-DESCRIPTION = "tslib is a touchscreen access library."
-PV = "0.0+cvs${SRCDATE}"
-PR = "r34"
+LICENSE = "LGPL"
-SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
-PACKAGE_ARCH_tslib-conf = "${MACHINE_ARCH}"
-PACKAGE_ARCH_mnci = "${MACHINE_ARCH}"
+PV = "0.0+cvs${SRCDATE}"
+PR = "r35"
SRC_URI = "cvs://cvs:@pubcvs.arm.linux.org.uk/mnt/src/cvsroot;module=tslib \
file://usec_fix.patch;patch=1 \
- file://ts.conf file://ts-2.6.conf \
- file://ts.conf-h3600-2.4 file://ts.conf-simpad-2.4 \
- file://ts.conf-corgi-2.4 file://ts.conf-collie-2.4 \
+ file://ts.conf \
+ file://ts-2.6.conf \
+ file://ts.conf-h3600-2.4 \
+ file://ts.conf-simpad-2.4 \
+ file://ts.conf-corgi-2.4 \
+ file://ts.conf-collie-2.4 \
file://tslib.sh"
SRC_URI_append_mnci += " file://devfs.patch;patch=1"
SRC_URI_append_mnci += " file://event1.patch;patch=1"
S = "${WORKDIR}/tslib"
-LICENSE = "LGPL"
-CONFFILES_${PN} = "${sysconfdir}/ts.conf"
inherit autotools pkgconfig
-PACKAGES = "tslib-conf libts libts-dev tslib-tests tslib-calibrate"
EXTRA_OECONF = "--enable-shared"
EXTRA_OECONF_mnci = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00 "
-EXTRA_OECONF_beagle = "--enable-shared --enable-h3600 --disable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00 "
-do_stage () {
-autotools_stage_all
+do_stage() {
+ autotools_stage_all
}
-do_install_prepend () {
+do_install_prepend() {
install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
}
@@ -38,7 +37,7 @@ do_install_append() {
install -d ${D}${sysconfdir}/profile.d/
install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
case ${MACHINE} in
- h3600 | h3900 | h1940 | h6300 | h2200 | ipaq-pxa270 | blueangel)
+ a780 | e680 | h3600 | h3900 | h1940 | h6300 | h2200 | ipaq-pxa270 | blueangel)
install -d ${D}${datadir}/tslib
for f in ts-2.6.conf ts.conf-h3600-2.4; do
install -m 0644 ${WORKDIR}/$f ${D}${datadir}/tslib/
@@ -72,6 +71,14 @@ do_install_append() {
esac
}
+SRC_URI_OVERRIDES_PACKAGE_ARCH = "0"
+CONFFILES_${PN} = "${sysconfdir}/ts.conf"
+
+PACKAGE_ARCH_tslib-conf = "${MACHINE_ARCH}"
+PACKAGE_ARCH_mnci = "${MACHINE_ARCH}"
+
+PACKAGES = "tslib-conf libts libts-dev tslib-tests tslib-calibrate"
+
RDEPENDS_libts = "tslib-conf"
FILES_tslib-conf = "${sysconfdir}/ts.conf ${sysconfdir}/profile.d/tslib.sh ${datadir}/tslib"