aboutsummaryrefslogtreecommitdiffstats
path: root/packages/totem
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-08-10 15:47:43 +0000
committerKoen Kooi <koen@openembedded.org>2008-08-10 15:47:43 +0000
commit70185fab5a60f21c0888baa34d621450b7205716 (patch)
treeae1c86e00db1724d3183ad98abe66a629fa1626a /packages/totem
parent60ead6c3df9298dbbbf284ddd6d1415ca604f5bb (diff)
downloadopenembedded-70185fab5a60f21c0888baa34d621450b7205716.tar.gz
totem: add 2.23.4
Diffstat (limited to 'packages/totem')
-rw-r--r--packages/totem/totem/.mtn2git_empty0
-rw-r--r--packages/totem/totem/gst-detect.diff37
-rw-r--r--packages/totem/totem_2.23.4.bb35
3 files changed, 72 insertions, 0 deletions
diff --git a/packages/totem/totem/.mtn2git_empty b/packages/totem/totem/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/totem/totem/.mtn2git_empty
diff --git a/packages/totem/totem/gst-detect.diff b/packages/totem/totem/gst-detect.diff
new file mode 100644
index 0000000000..5fc0788654
--- /dev/null
+++ b/packages/totem/totem/gst-detect.diff
@@ -0,0 +1,37 @@
+--- /tmp/configure.in 2008-08-10 15:27:06.000000000 +0200
++++ totem-2.23.4/configure.in 2008-08-10 17:35:46.593198000 +0200
+@@ -142,11 +142,7 @@
+ if $gst010_inspect $base_element >/dev/null 2>/dev/null; then
+ AC_MSG_RESULT([yes])
+ else
+- AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 plugin '$base_element'.
+- It should be part of gst-plugins-base. Please install it.
+- ])
++ AC_MSG_RESULT([yes, we assume OE has already built them])
+ fi
+ done
+
+@@ -157,11 +153,7 @@
+ if $gst010_inspect $good_element >/dev/null 2>/dev/null; then
+ AC_MSG_RESULT([yes])
+ else
+- AC_MSG_RESULT([no])
+- AC_MSG_ERROR([
+- Cannot find required GStreamer-0.10 plugin '$good_element'.
+- It should be part of gst-plugins-good. Please install it.
+- ])
++ AC_MSG_RESULT([yes, we assume OE has already built them])
+ fi
+ done
+
+@@ -565,7 +557,7 @@
+ fi
+ ;;
+ mythtv)
+- PKG_CHECK_MODULES(GMYTH, gmyth >= 0.7 gmyth-upnp >= 0.7.1,
++ PKG_CHECK_MODULES(GMYTH, gmyth >= 0.7.0,
+ [HAVE_GMYTH=yes], [HAVE_GMYTH=no])
+ if test "${HAVE_GMYTH}" != "yes"; then
+ plugin_error_or_ignore "you need GMyth >= 0.7 installed for the MythTV plugin"
diff --git a/packages/totem/totem_2.23.4.bb b/packages/totem/totem_2.23.4.bb
new file mode 100644
index 0000000000..7bd5c6945b
--- /dev/null
+++ b/packages/totem/totem_2.23.4.bb
@@ -0,0 +1,35 @@
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "A GTK2 based media player"
+HOMEPAGE = "http://www.gnome.org/projects/totem/"
+LICENSE = "GPL"
+
+DEPENDS = " totem-pl-parser gtk+ dbus bluez-libs libglade gconf libxml2 gst-ffmpeg gst-plugins-bad gst-plugins-base"
+RDEPENDS = "iso-codes"
+RRECOMMENDS = "gst-plugin-playbin gst-ffmpeg gst-plugin-audioresample gst-plugin-ximagesink gst-plugin-xvimagesink gst-plugin-alsa"
+
+inherit gnome
+
+SRC_URI += "file://gst-detect.diff;patch=1"
+
+EXTRA_OECONF=" --disable-schemas-install \
+ --enable-gtk \
+ --disable-iso-codes \
+ --disable-debug \
+ --enable-gstreamer \
+ --enable-browser-plugins \
+ --disable-run-in-source-tree \
+ --with-dbus \
+ "
+
+do_configure_prepend() {
+ sed -i -e s:help::g ${S}/Makefile.am
+}
+
+PACKAGES =+ "totem-browser-plugin-dbg totem-browser-plugin"
+FILES_${PN} += "${datadir}/icons"
+FILES_${PN}-dbg += "${libdir}/totem/plugins/*/.debug"
+FILES_totem-browser-plugin-dbg += "${libdir}/mozilla/plugins/.debug"
+FILES_totem-browser-plugin += "${libdir}/mozilla/plugins/"