aboutsummaryrefslogtreecommitdiffstats
path: root/packages/tasks/task-slugos.bb
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-03-10 15:27:06 +0000
committerRod Whitby <rod@whitby.id.au>2007-03-10 15:27:06 +0000
commited3a584c445dc6b68db8ce1ff246d64c16ea6fdb (patch)
treebffb55d021d0e5c96c4f960df5b071e419752240 /packages/tasks/task-slugos.bb
parent3ee81f28552ce7acdd2206d3700b9fa3664a201c (diff)
downloadopenembedded-ed3a584c445dc6b68db8ce1ff246d64c16ea6fdb.tar.gz
task-slugos: Changed a lot of packages in the rootfs from RDEPENDS to RRECOMMENDS
Diffstat (limited to 'packages/tasks/task-slugos.bb')
-rw-r--r--packages/tasks/task-slugos.bb36
1 files changed, 17 insertions, 19 deletions
diff --git a/packages/tasks/task-slugos.bb b/packages/tasks/task-slugos.bb
index 2fd4ad0473..92820e069c 100644
--- a/packages/tasks/task-slugos.bb
+++ b/packages/tasks/task-slugos.bb
@@ -6,7 +6,7 @@
DESCRIPTION = "Task packages for the SlugOS distribution"
HOMEPAGE = "http://www.nslu2-linux.org"
LICENSE = "MIT"
-PR = "r4"
+PR = "r5"
PACKAGE_ARCH = "${MACHINE_ARCH}"
ALLOW_EMPTY = "1"
@@ -18,6 +18,7 @@ ALLOW_EMPTY = "1"
# The standard firmware contents and additional packages built as requirements
# of the firmware are defined here in SLUGOS_STANDARD_RDEPENDS.
SLUGOS_STANDARD_RDEPENDS = ""
+SLUGOS_STANDARD_RRECOMMENDS = ""
# diff, cpio and find are required for reflash and turnup ram.
# Removing these probably leaves the system bootable, but standard
@@ -27,17 +28,17 @@ SLUGOS_STANDARD_RDEPENDS = ""
# udev is the default way of handling devices, there is no guarantee
# that the static device table is completely correct (it is just
# known to be sufficient for boot.)
-SLUGOS_STANDARD_RDEPENDS += "diffutils cpio findutils udev"
+SLUGOS_STANDARD_RRECOMMENDS += "diffutils cpio findutils udev"
# These lines add support for formatting ext2 and ext3 file systems
# on a hard disk attached to the NSLU2. ext3 is the standard Linux
# file system.
-SLUGOS_STANDARD_RDEPENDS += "e2fsprogs-mke2fs e2fsprogs-fsck e2fsprogs-e2fsck e2fsprogs-badblocks"
+SLUGOS_STANDARD_RRECOMMENDS += "e2fsprogs-mke2fs e2fsprogs-fsck e2fsprogs-e2fsck e2fsprogs-badblocks"
# These lines add support for an X/Y/ZModem package called lrzsz
# (this is of use for people with modified NSLU2 hardware which
# supports a serial port.)
-SLUGOS_STANDARD_RDEPENDS += "lrzsz"
+SLUGOS_STANDARD_RRECOMMENDS += "lrzsz"
# Filesystem selection. Adding entries here adds the module to the
# image. The module must be built as part of nslu2-kernel (i.e. it
@@ -55,7 +56,7 @@ SLUGOS_STANDARD_RDEPENDS += "lrzsz"
# NOTE: removing kernel-module-nfs from this list will prevent NFS
# boot (however you can do a simple flash file system boot - no
# attached disk - and install the nfs modules from ssh.)
-SLUGOS_STANDARD_RDEPENDS += "\
+SLUGOS_STANDARD_RRECOMMENDS += "\
kernel-module-ext2 \
kernel-module-jbd \
kernel-module-ext3 \
@@ -67,31 +68,25 @@ kernel-module-nls-cp437 \
kernel-module-nls-utf8 \
"
-# Until it becomes clear which of the ntfs drivers is the better
-# solution, the Linux ntfs driver is commented out.
-#SLUGOS_STANDARD_RDEPENDS += "\
-#kernel-module-ntfs \
-#"
-
# Add daemon required for HW RNG support
-SLUGOS_STANDARD_RDEPENDS += "\
+SLUGOS_STANDARD_RRECOMMENDS += "\
rng-tools \
"
# Add modules required for usb support
-SLUGOS_STANDARD_RDEPENDS += "\
+SLUGOS_STANDARD_RRECOMMENDS += "\
kernel-module-ohci-hcd \
kernel-module-uhci-hcd \
"
# Add modules required for IDE support
-SLUGOS_STANDARD_RDEPENDS += "\
+SLUGOS_STANDARD_RRECOMMENDS += "\
kernel-module-libata \
kernel-module-pata-artop \
"
# Add modules required for Network support
-SLUGOS_STANDARD_RDEPENDS += "\
+SLUGOS_STANDARD_RRECOMMENDS += "\
kernel-module-via-velocity \
"
@@ -99,20 +94,20 @@ kernel-module-via-velocity \
# NOTE: This module is desirable for systems lacking a physical
# console, but is usually only enabled if specific needs or issues
# arise. If space in the flash is at a premium, it can be omitted.
-SLUGOS_STANDARD_RDEPENDS += "\
+SLUGOS_STANDARD_RRECOMMENDS += "\
kernel-module-netconsole \
"
DEPENDS += "${DISTRO_EXTRA_DEPENDS}"
-RDEPENDS += "kernel ixp4xx-npe \
+RDEPENDS += "\
+ kernel ixp4xx-npe \
base-files base-passwd netbase \
busybox initscripts-slugos slugos-init \
update-modules sysvinit tinylogin \
module-init-tools modutils-initscripts \
ipkg-collateral ipkg ipkg-link \
portmap \
- dropbear \
beep \
e2fsprogs-blkid \
util-linux-mount \
@@ -122,4 +117,7 @@ RDEPENDS += "kernel ixp4xx-npe \
${SLUGOS_STANDARD_RDEPENDS} \
${DISTRO_EXTRA_RDEPENDS}"
-RRECOMMENDS = "${DISTRO_EXTRA_RRECOMMENDS}"
+RRECOMMENDS += "\
+ dropbear \
+ ${SLUGOS_STANDARD_RRECOMMENDS} \
+ ${DISTRO_EXTRA_RRECOMMENDS}"