aboutsummaryrefslogtreecommitdiffstats
path: root/packages/tasks/task-slugos.bb
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-02-08 23:06:09 +0000
committerRod Whitby <rod@whitby.id.au>2007-02-08 23:06:09 +0000
commitcb389ca847d894e4239be229e67779948f1487eb (patch)
tree15448b2d19be72884c9bee6ea968ada15e411d14 /packages/tasks/task-slugos.bb
parentae35d5932fa824472ce62b7ef829b479852c6269 (diff)
downloadopenembedded-cb389ca847d894e4239be229e67779948f1487eb.tar.gz
slugos: Added task-slugos to separate out rootfs contents from image creation.
Diffstat (limited to 'packages/tasks/task-slugos.bb')
-rw-r--r--packages/tasks/task-slugos.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/packages/tasks/task-slugos.bb b/packages/tasks/task-slugos.bb
new file mode 100644
index 0000000000..b953befb40
--- /dev/null
+++ b/packages/tasks/task-slugos.bb
@@ -0,0 +1,49 @@
+# This describes a generic SlugOS image, even though the bb file is
+# called 'slugos-image.bb' the distro specific configuration is
+# done in conf/distro/${DISTRO}.conf (which should always include
+# conf/distro/slugos.conf to get the standard settings).
+#
+DESCRIPTION = "Task packages for the SlugOS distribution"
+HOMEPAGE = "http://www.nslu2-linux.org"
+LICENSE = "MIT"
+PR = "r1"
+
+# CONFIG:
+# SLUGOS_EXTRA_RDEPENDS: set in conf, things to add to the image
+# SLUGOS_SUPPORT: set here, see below, added to the image.
+# SLUGOS_KERNEL: set here, kernel modules added to the image
+#
+# Do not override the last two unless you really know what you
+# are doing - there is more information below.
+
+# diff, cpio and find are required for reflash and turnup ram.
+# Removing these probably leaves the system bootable, but standard
+# openslug and ucslugc stuff won't work, so only take these out in
+# very non-standard turnkey slugos builds.
+#
+# udev is the default way of handling devices, there is no guarantee
+# that the static device table is completely correct (it is just
+# known to be sufficient for boot.)
+SLUGOS_SUPPORT ?= "diffutils cpio findutils udev"
+
+SLUGOS_KERNEL ?= ""
+
+SLUGOS_EXTRA_RDEPENDS ?= ""
+
+RDEPENDS = "kernel ixp4xx-npe \
+ base-files base-passwd netbase \
+ busybox initscripts-slugos slugos-init \
+ update-modules sysvinit tinylogin \
+ module-init-tools modutils-initscripts \
+ ipkg-collateral ipkg ipkg-link \
+ portmap \
+ dropbear \
+ beep \
+ e2fsprogs-blkid \
+ util-linux-mount \
+ util-linux-umount \
+ util-linux-swaponoff \
+ util-linux-losetup \
+ ${SLUGOS_SUPPORT} \
+ ${SLUGOS_KERNEL} \
+ ${SLUGOS_EXTRA_RDEPENDS}"