aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sysfsutils
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/sysfsutils
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/sysfsutils')
-rw-r--r--packages/sysfsutils/sysfsutils-1.2.0/libsysfs-write-attribute.patch29
-rw-r--r--packages/sysfsutils/sysfsutils-2.1.0/get_mnt_path_check.patch56
-rw-r--r--packages/sysfsutils/sysfsutils_1.3.0.bb22
-rw-r--r--packages/sysfsutils/sysfsutils_2.0.0.bb24
-rw-r--r--packages/sysfsutils/sysfsutils_2.1.0.bb22
5 files changed, 0 insertions, 153 deletions
diff --git a/packages/sysfsutils/sysfsutils-1.2.0/libsysfs-write-attribute.patch b/packages/sysfsutils/sysfsutils-1.2.0/libsysfs-write-attribute.patch
deleted file mode 100644
index 447d90f588..0000000000
--- a/packages/sysfsutils/sysfsutils-1.2.0/libsysfs-write-attribute.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Hi,
-
-int sysfs_write_attribute(struct sysfs_attribute *sysattr,
- const char *new_value, size_t len)
-
-has a problematic "feature": if the file is empty but readable, nothing gets
-written into it. The attached patch (untested) should fix it.
-
- Dominik
-
-
-The check which tests whether the value to be written into a sysfs attribute
-is already there should only trigger if the length of both strings is the
-same.
-
-Signed-off-by: Dominik Brodowski <linux@dominikbrodowski.net>
-
---- sysfsutils-1.2.0/lib/sysfs_dir.c.original 2005-02-21 08:10:33.000000000 +0100
-+++ sysfsutils-1.2.0/lib/sysfs_dir.c 2005-02-21 08:14:01.000000000 +0100
-@@ -194,7 +194,8 @@
- dprintf("Error reading attribute\n");
- return -1;
- }
-- if ((strncmp(sysattr->value, new_value, sysattr->len)) == 0) {
-+ if (((strncmp(sysattr->value, new_value, sysattr->len)) == 0)&&
-+ (len == sysattr->len)) {
- dprintf("Attr %s already has the requested value %s\n",
- sysattr->name, new_value);
- return 0;
diff --git a/packages/sysfsutils/sysfsutils-2.1.0/get_mnt_path_check.patch b/packages/sysfsutils/sysfsutils-2.1.0/get_mnt_path_check.patch
deleted file mode 100644
index 47f6cafb05..0000000000
--- a/packages/sysfsutils/sysfsutils-2.1.0/get_mnt_path_check.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-diff -ruN sysfsutils-2.0.0-old/lib/sysfs_utils.c sysfsutils-2.0.0/lib/sysfs_utils.c
---- sysfsutils-2.0.0-old/lib/sysfs_utils.c 2005-12-07 12:28:18.000000000 +0100
-+++ sysfsutils-2.0.0/lib/sysfs_utils.c 2006-03-06 19:06:11.000000000 +0100
-@@ -22,6 +22,7 @@
- */
- #include "libsysfs.h"
- #include "sysfs.h"
-+#include <mntent.h>
-
- /**
- * sysfs_remove_trailing_slash: Removes any trailing '/' in the given path
-@@ -53,6 +54,9 @@
- {
- static char sysfs_path[SYSFS_PATH_MAX] = "";
- const char *sysfs_path_env;
-+ FILE *mnt;
-+ struct mntent *mntent;
-+ int ret;
-
- if (len == 0 || mnt_path == NULL)
- return -1;
-@@ -64,12 +68,31 @@
- if (sysfs_path_env != NULL) {
- safestrcpymax(mnt_path, sysfs_path_env, len);
- sysfs_remove_trailing_slash(mnt_path);
-- return 0;
-+ } else {
-+ safestrcpymax(mnt_path, SYSFS_MNT_PATH, len);
- }
-- safestrcpymax(mnt_path, SYSFS_MNT_PATH, len);
- }
-
-- return 0;
-+ /* check that mount point is indeed mounted */
-+ ret = -1;
-+ if ((mnt = setmntent(SYSFS_PROC_MNTS, "r")) == NULL) {
-+ dprintf("Error getting mount information\n");
-+ return -1;
-+ }
-+ while ((mntent = getmntent(mnt)) != NULL) {
-+ if (strcmp(mntent->mnt_type, SYSFS_FSTYPE_NAME) == 0 &&
-+ strcmp(mntent->mnt_dir, mnt_path) == 0) {
-+ ret = 0;
-+ break;
-+ }
-+ }
-+
-+ endmntent(mnt);
-+
-+ if (ret < 0)
-+ errno = ENOENT;
-+
-+ return ret;
- }
-
- /**
diff --git a/packages/sysfsutils/sysfsutils_1.3.0.bb b/packages/sysfsutils/sysfsutils_1.3.0.bb
deleted file mode 100644
index 11e4ca7e9a..0000000000
--- a/packages/sysfsutils/sysfsutils_1.3.0.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-PR = "r2"
-SECTION = "base"
-DESCRIPTION = "System Utilities Based on Sysfs"
-HOMEPAGE = "http://linux-diag.sourceforge.net/Sysfsutils.html"
-LICENSE = "GPLv2"
-SRC_URI = "${SOURCEFORGE_MIRROR}/linux-diag/sysfsutils-${PV}.tar.gz"
-
-S = "${WORKDIR}/sysfsutils-${PV}"
-
-inherit autotools
-
-includedir += "/sysfs"
-
-PACKAGES_prepend = "libsysfs "
-FILES_libsysfs = "${libdir}/*.so.1.0.3"
-
-do_stage () {
- oe_libinstall -a -so -C lib libsysfs ${STAGING_LIBDIR}
- install -d ${STAGING_INCDIR}/sysfs
- install -m 0644 ${S}/include/dlist.h ${STAGING_INCDIR}/sysfs
- install -m 0644 ${S}/include/libsysfs.h ${STAGING_INCDIR}/sysfs
-}
diff --git a/packages/sysfsutils/sysfsutils_2.0.0.bb b/packages/sysfsutils/sysfsutils_2.0.0.bb
deleted file mode 100644
index f59dfa0feb..0000000000
--- a/packages/sysfsutils/sysfsutils_2.0.0.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "System Utilities Based on Sysfs"
-HOMEPAGE = "http://linux-diag.sourceforge.net/Sysfsutils.html"
-LICENSE = "GPLv2"
-PR = "r2"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/linux-diag/sysfsutils-${PV}.tar.gz"
-S = "${WORKDIR}/sysfsutils-${PV}"
-
-inherit autotools
-
-includedir += "/sysfs"
-
-do_stage () {
- oe_libinstall -a -so -C lib libsysfs ${STAGING_LIBDIR}
- install -d ${STAGING_INCDIR}/sysfs
- install -m 0644 ${S}/include/dlist.h ${STAGING_INCDIR}/sysfs
- install -m 0644 ${S}/include/libsysfs.h ${STAGING_INCDIR}/sysfs
-}
-
-PACKAGES_prepend = "libsysfs libsysfs-dbg libsysfs-dev "
-FILES_libsysfs = "${libdir}/*.so.*"
-FILES_libsysfs-dev = "${libdir}/* ${includedir}"
-FILES_libsysfs-dbg += "${libdir}/.debug"
-FILES_${PN}-dbg += "${bindir}/.debug"
diff --git a/packages/sysfsutils/sysfsutils_2.1.0.bb b/packages/sysfsutils/sysfsutils_2.1.0.bb
deleted file mode 100644
index 4f540d5181..0000000000
--- a/packages/sysfsutils/sysfsutils_2.1.0.bb
+++ /dev/null
@@ -1,22 +0,0 @@
-DESCRIPTION = "System Utilities Based on Sysfs"
-HOMEPAGE = "http://linux-diag.sourceforge.net/Sysfsutils.html"
-LICENSE = "GPLv2"
-PR = "r1"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/linux-diag/sysfsutils-${PV}.tar.gz \
- file://get_mnt_path_check.patch;patch=1"
-
-inherit autotools
-
-do_stage () {
- autotools_stage_all
-}
-
-PACKAGES = "libsysfs libsysfs-dbg libsysfs-dev \
- ${PN} ${PN}-dbg ${PN}-doc ${PN}-locale"
-
-FILES_libsysfs = "${libdir}/*.so.*"
-FILES_libsysfs-dev = "${includedir} ${libdir}/lib*.so ${libdir}/*.la \
- ${libdir}/*.a"
-FILES_libsysfs-dbg += "${libdir}/.debug"
-FILES_${PN}-dbg += "${bindir}/.debug"