aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sidplayer
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/sidplayer
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/sidplayer')
-rw-r--r--packages/sidplayer/sidplayer-1.5.0/gcc3.patch69
-rw-r--r--packages/sidplayer/sidplayer-1.5.0/gcc34.patch40
-rw-r--r--packages/sidplayer/sidplayer-1.5.0/use-external-libsidplay.patch20
-rw-r--r--packages/sidplayer/sidplayer_1.5.0.bb24
4 files changed, 0 insertions, 153 deletions
diff --git a/packages/sidplayer/sidplayer-1.5.0/gcc3.patch b/packages/sidplayer/sidplayer-1.5.0/gcc3.patch
deleted file mode 100644
index b94e26a18a..0000000000
--- a/packages/sidplayer/sidplayer-1.5.0/gcc3.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- sidplayer/sidplayer.cpp~gcc3 2003-09-26 20:28:51.000000000 +0200
-+++ sidplayer/sidplayer.cpp 2004-02-12 19:24:33.000000000 +0100
-@@ -83,8 +83,8 @@
- //============================================================================================
-
- Sidplayer::Sidplayer( int argc, char **argv, QPEApplication *app,
-- QWidget *parent, const char *name, WFlags f )
-- : TabbedDialog( parent, name, f ),
-+ QWidget *parent, const char *name, WFlags flags )
-+ : TabbedDialog( parent, name, flags ),
- application( app ),
- selectedSong( 1 ),
- totalSongs( 1 ),
-@@ -710,7 +710,7 @@
-
- //--------------------------------------------------------------------------------------------
-
--void Sidplayer::updateListeningMileageLabel( bool forceUpdate = false )
-+void Sidplayer::updateListeningMileageLabel( bool forceUpdate )
- {
- static int oldSecondsTotal = 0;
- int secondsTotal = myEmuEngine.getSecondsTotal();
---- sidplayer/sidplayer_file.cpp~gcc3 2003-09-25 21:56:57.000000000 +0200
-+++ sidplayer/sidplayer_file.cpp 2004-02-12 19:24:33.000000000 +0100
-@@ -249,7 +249,7 @@
- }
- }
-
--void Sidplayer::populateFileView( const QString &directory, const QString &selectThis = "" )
-+void Sidplayer::populateFileView( const QString &directory, const QString &selectThis )
- {
- QDir dir( directory );
-
---- sidplayer/sidplayer_list.cpp~gcc3 2003-07-09 21:49:28.000000000 +0200
-+++ sidplayer/sidplayer_list.cpp 2004-02-12 19:24:33.000000000 +0100
-@@ -172,7 +172,7 @@
- setAllPlaylistViewItemsOddFlag();
- }
-
--void Sidplayer::insertDir_( QString dirpath = "" )
-+void Sidplayer::insertDir_( QString dirpath )
- {
- if ( dirpath == "" )
- dirpath = currentDir;
-@@ -225,7 +225,7 @@
- setAllPlaylistViewItemsOddFlag();
- }
-
--void Sidplayer::insertDirRecursive_( QString dirpath = "" )
-+void Sidplayer::insertDirRecursive_( QString dirpath )
- {
- if ( dirpath == "" )
- dirpath = currentDir;
---- sidplayer/volumebarwidget.cpp~gcc3 2003-07-09 22:35:48.000000000 +0200
-+++ sidplayer/volumebarwidget.cpp 2004-02-12 19:28:54.000000000 +0100
-@@ -18,7 +18,7 @@
-
- #include <iostream>
-
--VolumeBarWidget::VolumeBarWidget( QWidget *parent = 0, const char *name = 0, WFlags f = 0 )
-+VolumeBarWidget::VolumeBarWidget( QWidget *parent, const char *name, WFlags f )
- : QWidget( parent, name, f )
- {
- getVolume();
diff --git a/packages/sidplayer/sidplayer-1.5.0/gcc34.patch b/packages/sidplayer/sidplayer-1.5.0/gcc34.patch
deleted file mode 100644
index 00598a103c..0000000000
--- a/packages/sidplayer/sidplayer-1.5.0/gcc34.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- sidplayer/sidplayer.h~gcc34.patch 2004-05-16 20:54:24.000000000 +0200
-+++ sidplayer/sidplayer.h 2004-05-16 20:54:24.000000000 +0200
-@@ -36,7 +36,7 @@
-
- #define SHUTDOWN_TIMER_TIMEOUT 10 // 2 would probably be also long enough
-
--
-+static bool evenFlag = 0;
- extern bool sidEmuFastForwardReplay( int );
-
-
---- sidplayer/sidplayer_list.cpp~gcc34.patch 2004-05-16 20:54:24.000000000 +0200
-+++ sidplayer/sidplayer_list.cpp 2004-05-16 20:55:40.000000000 +0200
-@@ -23,9 +23,6 @@
- #include <qpe/config.h>
-
-
--static bool evenFlag; // This global flag is used to toggle between even and odd list entries
-- // when generating list items (i.e. when populating a list).
--
- PlaylistItem::PlaylistItem( QListView *parent, QListViewItem *after, const QFileInfo &fi,
- const QString &name,
- const QString &author,
---- sidplayer/sidplayer_file.cpp~gcc34.patch 2004-05-16 20:54:24.000000000 +0200
-+++ sidplayer/sidplayer_file.cpp 2004-05-16 20:56:01.000000000 +0200
-@@ -24,9 +24,6 @@
- #endif
-
-
--static bool evenFlag; // This global flag is used to toggle between even and odd list entries
-- // when generating list items (i.e. when populating a list).
--
- FileItem::FileItem( QListView *parent, const QFileInfo &fi, int type )
- : ItemBase( parent ),
- fileInfo( fi )
diff --git a/packages/sidplayer/sidplayer-1.5.0/use-external-libsidplay.patch b/packages/sidplayer/sidplayer-1.5.0/use-external-libsidplay.patch
deleted file mode 100644
index 7c00079299..0000000000
--- a/packages/sidplayer/sidplayer-1.5.0/use-external-libsidplay.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- sidplayer/sidplayer.h~use-external-libsidplay 2003-09-26 00:28:31.000000000 +0200
-+++ sidplayer/sidplayer.h 2004-02-12 18:16:19.000000000 +0100
-@@ -13,9 +13,9 @@
-
- #include "tabbeddialog.h"
-
--#include "libsidplay/src/player.h"
--#include "libsidplay/src/fformat.h"
--#include "libsidplay/src/myendian.h"
-+#include <player.h>
-+#include <fformat.h>
-+#include <myendian.h>
- #include "audiodrv.h"
-
- #include <qpe/qpeapplication.h>
diff --git a/packages/sidplayer/sidplayer_1.5.0.bb b/packages/sidplayer/sidplayer_1.5.0.bb
deleted file mode 100644
index 9929aa8c9f..0000000000
--- a/packages/sidplayer/sidplayer_1.5.0.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-DESCRIPTION = "A SID Player for the Qt/Embedded based Palmtop Environments"
-SECTION = "opie/multimedia"
-PRIORITY = "optional"
-LICENSE = "GPL"
-HOMEPAGE = "http://sidplayer.sourceforge.net/"
-DEPENDS = "libsidplay"
-PR = "r1"
-
-SRC_URI = "http://sidplayer.sourceforge.net/sidplayer.tar.gz \
- file://use-external-libsidplay.patch;patch=1 \
- file://gcc3.patch;patch=1 \
- file://gcc34.patch;patch=1"
-S = "${WORKDIR}/sidplayer"
-
-EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${STAGING_INCDIR}/sidplay"
-
-inherit palmtop
-
-do_install() {
- install -d ${D}${palmtopdir}/bin \
- ${D}${palmtopdir}/apps/Applications \
- ${D}${palmtopdir}/pics
- cp -pPR ../apps ../bin ../pics ${D}${palmtopdir}/
-}