aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qt4/qtopia-core_4.3.3.bb
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-12-24 01:17:45 +0000
committerHolger Freyther <zecke@selfish.org>2007-12-24 01:17:45 +0000
commitf53bfcb679b66b329fe13418d492d9c289472e6e (patch)
tree7ff349eb9e528d8fff8f20292302dfe1e9359492 /packages/qt4/qtopia-core_4.3.3.bb
parent39dbfbe23ad2f6dc14244d27c08fd4979918bea4 (diff)
downloadopenembedded-f53bfcb679b66b329fe13418d492d9c289472e6e.tar.gz
package/qt4/qt4-x11-free,qtopia-core: Start sharing packaging
The font and translations are a bit hairy and need further work. The idea is that at one point in time we can install Qt/X11 and Qt/Embedded side by side again. Headers and tools still need some time.
Diffstat (limited to 'packages/qt4/qtopia-core_4.3.3.bb')
-rw-r--r--packages/qt4/qtopia-core_4.3.3.bb77
1 files changed, 5 insertions, 72 deletions
diff --git a/packages/qt4/qtopia-core_4.3.3.bb b/packages/qt4/qtopia-core_4.3.3.bb
index 0e94145df0..3e66d9f1b0 100644
--- a/packages/qt4/qtopia-core_4.3.3.bb
+++ b/packages/qt4/qtopia-core_4.3.3.bb
@@ -128,78 +128,6 @@ do_install() {
touch ${D}/${libdir}/fonts/fontdir
}
-# We might want to package all the libraries separately, so you can really
-# fine-tune what to install. This is e.g. done in qt4-x11-free_4.1.2.bb.
-# What should these packages be called? I'm tempted to call them the same
-# as in qt4 version, as the API is supposed to be compatible, e.g.
-# libqtcore4 and libqtgui4. This will however conflict if you have QT and
-# Qtopia, but this is something you don't want anyway, I guess.
-# Another solution is making virtual/libqtfoo4, and DEPENDing on that one
-# and let both the PACKAGES in QT and Qtopia PROVIDE these. The packages
-# themselves could then be called libqtopiafoo4.
-# I'll postpone this discussion by not making separate Qtopia packages.
-
-# Also, I don't package the plugins and translations atm, I don't use them
-# and I don't feel like thinking about a sensible separation.
-
-PACKAGES =+ " libqtcore libqtcore-dev libqtcore-dbg \
- libqtxml libqtxml-dev libqtxml-dbg \
- libqtgui libqtgui-dev libqtgui-dbg \
- libqtsql libqtsql-dev libqtsql-dbg \
- libqtnetwork libqtnetwork-dev libqtnetwork-dbg \
- libqtsvg libqtsvg-dev libqtsvg-dbg \
- libqt3support libqt3support-dev libqt3support-dbg \
- qtopia-core-plugins qtopia-core-plugins-dbg \
- libqtscript libqtscript-dev libqtscript-dbg \
- "
-
-PACKAGES += " ${PN}-fonts "
-
-# The default included fonts are around 75MB and consist of a number of
-# FreeType-renderable fonts as well as QPF (Qtopia Prerendered Fonts).
-# As FreeType is generally slow on embedded platforms, and 75MB is
-# quite huge, we downsize the fonts dir in the do_install. I've decided
-# to include only the QPF (Helvetica and Fixed), amounting to 500KB. This
-# also results in tremendously faster application startup time.
-FILES_libqtcore += " ${libdir}/fonts/helvetic* ${libdir}/fonts/fixed* ${D}/${libdir}/fonts/fontdir"
-FILES_${PN}-fonts = "${libdir}/fonts"
-
-FILES_qtopia-core-plugins += "${datadir}/qtopia/plugins/*/*.so"
-FILES_qtopia-core-plugins-dbg += "${datadir}/qtopia/plugins/*/.debug/*.so"
-
-FILES_libqtcore += "${libdir}/libQtCore.so.*"
-FILES_libqtxml += "${libdir}/libQtXml.so.*"
-FILES_libqtgui += "${libdir}/libQtGui.so.*"
-FILES_libqtsql += "${libdir}/libQtSql.so.*"
-FILES_libqtnetwork += "${libdir}/libQtNetwork.so.*"
-FILES_libqtsvg += "${libdir}/libQtSvg.so.*"
-FILES_libqt3support += "${libdir}/libQt3Support.so.*"
-FILES_libqtscript += "${libdir}/libQtScript.so.*"
-
-FILES_libqtcore-dev += "${libdir}/*QtCore.*"
-FILES_libqtxml-dev += "${libdir}/*QtXml.*"
-FILES_libqtgui-dev += "${libdir}/*QtGui.*"
-FILES_libqtsql-dev += "${libdir}/*QtSql.*"
-FILES_libqtnetwork-dev += "${libdir}/*QtNetwork.*"
-FILES_libqtsvg-dev += "${libdir}/*QtSvg.*"
-FILES_libqt3support-dev += "${libdir}/*Qt3Support.*"
-FILES_libqtscript-dev += "${libdir}/*QtScript.*"
-
-FILES_libqtcore-dbg += "${libdir}/.debug/libQtCore*"
-FILES_libqtxml-dbg += "${libdir}/.debug/libQtXml*"
-FILES_libqtgui-dbg += "${libdir}/.debug/libQtGui*"
-FILES_libqtsql-dbg += "${libdir}/.debug/libQtSql*"
-FILES_libqtnetwork-dbg += "${libdir}/.debug/libQtNetwork*"
-FILES_libqtsvg-dbg += "${libdir}/.debug/libQtSvg*"
-FILES_libqt3support-dbg += "${libdir}/.debug/libQt3Support*"
-FILES_libqtscript-dbg += "${libdir}/.debug/libQtScript*"
-
-
-python populate_packages_prepend() {
- translationdir = bb.data.expand('${datadir}/qtopia/translations/', d)
- do_split_packages(d, translationdir, '^qt_(.*)\.qm$', 'qtopia-translation-%s', 'Qtopia translation for %s', extra_depends='' )
-}
-
STAGE_TEMP = "${WORKDIR}/temp-staging"
@@ -220,3 +148,8 @@ do_stage() {
rm -rf ${STAGE_TEMP}
}
+
+QT_BASE_NAME = "qtopiacore"
+QT_BASE_LIB = "libqtopiacore"
+QT_LIBRARY_NAME = "libQt"
+require qt_packaging.inc