aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qpe-gaim/qpe-gaim_20041030.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/qpe-gaim/qpe-gaim_20041030.bb
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/qpe-gaim/qpe-gaim_20041030.bb')
-rw-r--r--packages/qpe-gaim/qpe-gaim_20041030.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/qpe-gaim/qpe-gaim_20041030.bb b/packages/qpe-gaim/qpe-gaim_20041030.bb
index e69de29bb2..1af1fca802 100644
--- a/packages/qpe-gaim/qpe-gaim_20041030.bb
+++ b/packages/qpe-gaim/qpe-gaim_20041030.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "A multi protocol instant messager application, Qt/Embedded based Palmtop Environments Edition"
+SECTION = "opie/applications"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+DEPENDS = "qpe-libgaim glib-2.0"
+RDEPENDS = "libgaim-plugins glibc-gconv-iso8859-1"
+LICENSE = "GPL"
+HOMEPAGE = "http://qpe-gaim.sourceforge.net/"
+APPNAME = "gaim"
+APPTYPE = "binary"
+LICENSE = "GPL"
+APPDESKTOP = "${S}"
+PV = "0.4+cvs-20041030"
+PR = "r1"
+
+SRC_URI = "http://www.vanille.de/mirror/qpe-gaim_20041030.tar.bz2 \
+ file://libopie2.patch;patch=1"
+S = "${WORKDIR}/qpe-gaim"
+
+inherit opie
+
+EXTRA_QMAKEVARS_POST +="INCLUDEPATH-=${includedir}/glib-2.0 \
+ INCLUDEPATH-=${libdir}/glib-2.0/include \
+ INCLUDEPATH+=${STAGING_INCDIR}/glib-2.0 \
+ LIBS-=-lopie LIBS+=-lopiecore2 LIBS+=-lopieui2"
+
+do_configure_prepend() {
+ ln -s ../libgaim/src libgaim
+}
+
+do_install() {
+ for dir in 16x16 32x32 protocols status
+ do
+ install -d ${D}${palmtopdir}/pics/gaim/${dir}
+ install -m 0644 data/images/${dir}/*.png ${D}${palmtopdir}/pics/gaim/${dir}/
+ done
+ install -m 0644 gaim.png ${D}${palmtopdir}/pics/
+}