aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qi
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-02-26 18:30:34 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-02-26 18:30:34 +0100
commit9b4c27d16529467cf4a5329289e9fb1b7426ecc9 (patch)
treefe535c8200e6a4102c8b873ef4c7ee9d20bd4219 /packages/qi
parent4ca003cb0431acf26edb867d7b1adbf51aeac9a4 (diff)
downloadopenembedded-9b4c27d16529467cf4a5329289e9fb1b7426ecc9.tar.gz
qi: enable build debug output again and bump to latest version
Diffstat (limited to 'packages/qi')
-rw-r--r--packages/qi/qi.inc7
1 files changed, 5 insertions, 2 deletions
diff --git a/packages/qi/qi.inc b/packages/qi/qi.inc
index 3de44ded0b..6d6e0dc8f2 100644
--- a/packages/qi/qi.inc
+++ b/packages/qi/qi.inc
@@ -3,7 +3,7 @@ LICENSE = "GPL"
SECTION = "bootloader"
PROVIDES = "virtual/bootloader"
LOCALVERSION = "gitr${SRCREV}"
-PV = "1.0.0+${LOCALVERSION}"
+PV = "1.0.1+${LOCALVERSION}"
EXTRA_OEMAKE = ""
PARALLEL_MAKE = ""
@@ -11,13 +11,16 @@ PARALLEL_MAKE = ""
do_configure() {
echo >config.mk
# uncomment to debug
-# sed -i s,@,, Makefile
+ sed -i s,@,, Makefile
cat >config.mk <<EOF
BUILD_HOST=\$(shell hostname)
BUILD_VERSION=${PV}
BUILD_DATE=\$(shell date)
+# NOTE: The following depends on the fact that only one version of the cross-compiler
+# has been built. If it bails out with something like: "| arm-linux-ld: 4.3.3: No such file or directory"
+# then you need to remove all previously built toolchain directories out of the cross library path.
GCCV="`${CC} -dumpversion`"
COMPILER_LIB_PATH_PRE=${CROSS_DIR}/lib/gcc/${TARGET_SYS}/$(GCCV)
COMPILER_LIB_PATH=\$(COMPILER_LIB_PATH_PRE)/\$(shell ls \$(COMPILER_LIB_PATH_PRE))