aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python
diff options
context:
space:
mode:
authorFelix Domke <tmbinc@elitedvb.ne>2007-06-28 21:47:08 +0000
committerFelix Domke <tmbinc@elitedvb.ne>2007-06-28 21:47:08 +0000
commitc24e961f4e5263a23d68e40424b95c50c73db84d (patch)
tree3eb13215913dceaa64728bf7e911e0da0e4fa904 /packages/python
parenta82b4e7ca5d3512213208265b5e099c42efe3da5 (diff)
downloadopenembedded-c24e961f4e5263a23d68e40424b95c50c73db84d.tar.gz
python-2.5.1: fix cross compile
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-2.5.1/crosscompile.patch14
-rw-r--r--packages/python/python_2.5.1.bb7
2 files changed, 19 insertions, 2 deletions
diff --git a/packages/python/python-2.5.1/crosscompile.patch b/packages/python/python-2.5.1/crosscompile.patch
index 63ba12fec3..c4fa77227d 100644
--- a/packages/python/python-2.5.1/crosscompile.patch
+++ b/packages/python/python-2.5.1/crosscompile.patch
@@ -103,3 +103,17 @@ diff -Naur Python-2.5/setup.py Python-2.5-patched/setup.py
#
# The following modules are all pretty straightforward, and compile
# on pretty much any POSIXish platform.
+--- Python-2.5.1/setup.py 2007-06-27 18:22:04.000000000 +0200
++++ Python-2.5.1/setup.py 2007-06-27 20:29:23.000000000 +0200
+@@ -1138,6 +1139,11 @@
+
+ # Call the method for detecting whether _tkinter can be compiled
+ self.detect_tkinter(inc_dirs, lib_dirs)
++
++ additional_dir = os.getenv( "PYTHON_LIBDIR" )
++ for x in self.extensions:
++ x.library_dirs.append(additional_dir)
++ x.runtime_library_dirs.append(additional_dir)
+
+ def detect_tkinter_darwin(self, inc_dirs, lib_dirs):
+ # The _tkinter module, using frameworks. Since frameworks are quite
diff --git a/packages/python/python_2.5.1.bb b/packages/python/python_2.5.1.bb
index 70d94fde0d..53fb45e4b8 100644
--- a/packages/python/python_2.5.1.bb
+++ b/packages/python/python_2.5.1.bb
@@ -44,7 +44,9 @@ do_compile() {
HOSTPYTHON=${STAGING_BINDIR}/python \
STAGING_LIBDIR=${STAGING_LIBDIR} \
STAGING_INCDIR=${STAGING_INCDIR} \
- BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS}
+ PYTHON_LIBDIR=${S} \
+ BUILD_SYS=${BUILD_SYS} \
+ HOST_SYS=${HOST_SYS}
}
do_stage() {
@@ -57,7 +59,8 @@ do_install() {
oe_runmake HOSTPGEN=${STAGING_BINDIR}/pgen \
HOSTPYTHON=${STAGING_BINDIR}/python \
STAGING_LIBDIR=${STAGING_LIBDIR} \
- STAGING_INCDIR=${STAGING_INCDIR} \
+ STAGING_INCDIR=${STAGING_INCDIR} \
+ PYTHON_LIBDIR=${S} \
BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
DESTDIR=${D} install
}