aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python/python-pyqwt_3.10.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-02-08 18:05:47 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-02-08 18:05:47 +0000
commit6579e8daf68dd520b702412208bfeae85af6fadc (patch)
treeef2cfbfe3353bd39e28145995db1287bd2518b8d /packages/python/python-pyqwt_3.10.bb
parentc6c085bf81bd4997bdb216e958d366ddf46438ad (diff)
downloadopenembedded-6579e8daf68dd520b702412208bfeae85af6fadc.tar.gz
make python 2.4 as default, move python-sip into python/, make sip4 as default
BKrev: 4208ff7b-sgl7QbT_1xhYPmdi-Oy4g
Diffstat (limited to 'packages/python/python-pyqwt_3.10.bb')
-rw-r--r--packages/python/python-pyqwt_3.10.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/packages/python/python-pyqwt_3.10.bb b/packages/python/python-pyqwt_3.10.bb
index e69de29bb2..1f41ab0459 100644
--- a/packages/python/python-pyqwt_3.10.bb
+++ b/packages/python/python-pyqwt_3.10.bb
@@ -0,0 +1,64 @@
+DESCRIPTION = "Python QWT Bindings, QtE edition"
+HOMEPAGE = "http://www.vanille.de/projects/python.spy"
+SECTION = "devel/python"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "python-core python-sip python-pyqt (>=${PV}) python-numeric qwt"
+DEPENDS = "virtual/libqte2 python-numeric python-pyqt qwt"
+SRCNAME = "pyqwt"
+PR = "ml2"
+
+SRC_URI = "http://www.vanille.de/mirror/PyQwt-20040118.tar.gz \
+ file://qt2.x-compat.patch;patch=1 \
+ file://features"
+S = "${WORKDIR}/PyQwt-20040118"
+
+inherit qmake sip
+
+QMAKE_PROFILES = "pyqwt.pro"
+EXTRA_SIPTAGS = "-tWS_QWS -tQtPE_1_6_0 -tQt_2_3_1"
+SIP_MODULES = "qwt"
+SIP_FEATURES = "${WORKDIR}/features"
+EXTRA_OEMAKE = " MAKEFLAGS= "
+
+EXTRA_QMAKEVARS_POST += "CONFIG=qt CONFIG+=warn_on CONFIG+=release \
+ TARGET=qwt DESTDIR= VERSION=1.0.0 \
+ DEFINES=SIP_MAKE_DLL DEFINES+=SIP_QT_SUPPORT DEFINES+=HAS_NUMERIC DEFINES+=QWS \
+ INCLUDEPATH+=../numpy \
+ INCLUDEPATH+=${STAGING_INCDIR}/python2.3 \
+ INCLUDEPATH+=${STAGING_INCDIR} \
+ LIBS+=-L${STAGING_LIBDIR}/python2.3/site-packages \
+ LIBS+=-L${QTDIR}/lib LIBS+=-lqte LIBS+=-lqpe "
+
+do_generate_prepend() {
+ echo -e "TEMPLATE=subdirs\nSUBDIRS=qwt\n" >pyqwt.pro
+
+ echo "%Makefile qwt.pro.in" >>sip/qwtmod.sip
+ echo "TEMPLATE=lib" >>sip/qwtmod.sip
+ echo 'SOURCES = $B' >>sip/qwtmod.sip
+ echo 'HEADERS = $H' >>sip/qwtmod.sip
+ echo "%End" >>sip/qwtmod.sip
+
+ mkdir -p sip/qwt/
+ mv sip/*.* sip/qwt/
+}
+
+do_stage() {
+ install -d ${STAGING_SIPDIR}/qt/
+ for module in ${SIP_MODULES}
+ do
+ install -m 0644 ${S}/sip/${module}/*.sip ${STAGING_SIPDIR}/qt/
+ install -m 0755 ${module}/lib${module}.so ${STAGING_LIBDIR}/python2.3/site-packages/${module}.so
+ done
+}
+
+do_install() {
+ install -d ${D}/${libdir}/python2.3/site-packages/
+ for module in ${SIP_MODULES}
+ do
+ install -m 0755 ${module}/lib${module}.so ${D}/${libdir}/python2.3/site-packages/${module}.so
+ done
+}
+
+FILES_${PN} = "/usr/lib/python2.3/site-packages"