aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python/python-pygame-1.8.1
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-08-19 17:37:46 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-08-19 17:37:46 +0000
commitc4654869732909f4dc1c043ea0cce71537e89d3f (patch)
tree6c30f8f9b9d1aa72d8b9a9557c91772b84562e8a /packages/python/python-pygame-1.8.1
parent97f991702952f288dfbb34fee41b56799c654e31 (diff)
downloadopenembedded-c4654869732909f4dc1c043ea0cce71537e89d3f.tar.gz
python-pygame 1.7.1 update to 1.8.1 and stage headers
Diffstat (limited to 'packages/python/python-pygame-1.8.1')
-rw-r--r--packages/python/python-pygame-1.8.1/.mtn2git_empty0
-rw-r--r--packages/python/python-pygame-1.8.1/Setup64
2 files changed, 64 insertions, 0 deletions
diff --git a/packages/python/python-pygame-1.8.1/.mtn2git_empty b/packages/python/python-pygame-1.8.1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-pygame-1.8.1/.mtn2git_empty
diff --git a/packages/python/python-pygame-1.8.1/Setup b/packages/python/python-pygame-1.8.1/Setup
new file mode 100644
index 0000000000..cb8085530a
--- /dev/null
+++ b/packages/python/python-pygame-1.8.1/Setup
@@ -0,0 +1,64 @@
+#This Setup file is used by the setup.py script to configure the
+#python extensions. You will likely use the "config.py" which will
+#build a correct Setup file for you based on your system settings.
+#If not, the format is simple enough to edit by hand. First change
+#the needed commandline flags for each dependency, then comment out
+#any unavailable optional modules in the first optional section.
+
+
+SDL = -D_REENTRANT -Xlinker -lSDL -lpthread
+FONT = -lSDL_ttf
+IMAGE = -lSDL_image
+MIXER = -lSDL_mixer
+SMPEG = -lsmpeg
+PNG = -lpng
+JPEG = ljpeg
+SCRAP = -lX11
+
+#DEBUG = -C-W -C-Wall
+DEBUG =
+
+#the following modules are optional. you will want to compile
+#everything you can, but you can ignore ones you don't have
+#dependencies for, just comment them out
+
+imageext src/imageext.c $(SDL) $(IMAGE) $(PNG) $(JPEG) $(DEBUG)
+font src/font.c $(SDL) $(FONT) $(DEBUG)
+mixer src/mixer.c $(SDL) $(MIXER) $(DEBUG)
+mixer_music src/music.c $(SDL) $(MIXER) $(DEBUG)
+_numericsurfarray src/_numericsurfarray.c $(SDL) $(DEBUG)
+_numericsndarray src/_numericsndarray.c $(SDL) $(MIXER) $(DEBUG)
+movie src/movie.c $(SDL) $(SMPEG) $(DEBUG)
+scrap src/scrap.c $(SDL) $(SCRAP) $(DEBUG)
+
+#experimental new movie movie. requires libavcodec and libavformat.
+#add any necessary compile flags to this line and uncomment.
+#movieext src/movie.c src/ffmovie.c $(SDL) -lavcodec -lavformat
+
+
+#these modules are required for pygame to run. they only require
+#SDL as a dependency. these should not be altered
+
+base src/base.c $(SDL) $(DEBUG)
+cdrom src/cdrom.c $(SDL) $(DEBUG)
+color src/color.c $(SDL) $(DEBUG)
+constants src/constants.c $(SDL) $(DEBUG)
+display src/display.c $(SDL) $(DEBUG)
+event src/event.c $(SDL) $(DEBUG)
+fastevent src/fastevent.c src/fastevents.c $(SDL) $(DEBUG)
+key src/key.c $(SDL) $(DEBUG)
+mouse src/mouse.c $(SDL) $(DEBUG)
+rect src/rect.c $(SDL) $(DEBUG)
+rwobject src/rwobject.c $(SDL) $(DEBUG)
+surface src/surface.c src/alphablit.c src/surface_fill.c $(SDL) $(DEBUG)
+surflock src/surflock.c $(SDL) $(DEBUG)
+time src/time.c $(SDL) $(DEBUG)
+joystick src/joystick.c $(SDL) $(DEBUG)
+draw src/draw.c $(SDL) $(DEBUG)
+image src/image.c $(SDL) $(DEBUG)
+overlay src/overlay.c $(SDL) $(DEBUG)
+transform src/transform.c src/rotozoom.c src/scale2x.c $(SDL) $(DEBUG)
+mask src/mask.c src/bitmask.c $(SDL) $(DEBUG)
+bufferproxy src/bufferproxy.c $(SDL) $(DEBUG)
+pixelarray src/pixelarray.c $(SDL) $(DEBUG)
+