aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python/python-pydirectfb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-12-11 12:41:43 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-12-11 12:41:43 +0000
commit843ecca5c576542e407919aa719b23ffb89cfc15 (patch)
tree1b639ccf8419b1b21cf1ca42257f8282ae94aeb3 /packages/python/python-pydirectfb
parentc644668e3ff839df99c1a417c62c6444b87e6432 (diff)
downloadopenembedded-843ecca5c576542e407919aa719b23ffb89cfc15.tar.gz
python-pydirectfb: commit missing patch
Diffstat (limited to 'packages/python/python-pydirectfb')
-rw-r--r--packages/python/python-pydirectfb/.mtn2git_empty0
-rw-r--r--packages/python/python-pydirectfb/fix-directfb-detection.patch16
2 files changed, 16 insertions, 0 deletions
diff --git a/packages/python/python-pydirectfb/.mtn2git_empty b/packages/python/python-pydirectfb/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-pydirectfb/.mtn2git_empty
diff --git a/packages/python/python-pydirectfb/fix-directfb-detection.patch b/packages/python/python-pydirectfb/fix-directfb-detection.patch
new file mode 100644
index 0000000000..c8b7cc805a
--- /dev/null
+++ b/packages/python/python-pydirectfb/fix-directfb-detection.patch
@@ -0,0 +1,16 @@
+Index: pydirectfb/setup.py
+===================================================================
+--- pydirectfb.orig/setup.py
++++ pydirectfb/setup.py
+@@ -11,9 +11,10 @@
+ Check dependencies add add the flags to include_dirs, library_dirs and
+ libraries. The basic logic is taken from pygame.
+ """
+- command = name + '-config --version --cflags --libs 2>/dev/null'
++ command = 'pkg-config %s --modversion --cflags --libs 2>/dev/null' % name
+ try:
+ config = os.popen(command).readlines()
++ print config
+ if len(config) == 0:
+ raise ValueError, 'command not found'
+ flags = (' '.join(config[1:]) + ' ').split()