aboutsummaryrefslogtreecommitdiffstats
path: root/packages/python/python-imaging_1.1.6.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-16 13:09:27 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-16 13:09:27 +0000
commit966fc3fc63539a0cbedc0de1bc5284aea0bda2ad (patch)
treed696c8529479f323334a1bd1ad26869cca6cb362 /packages/python/python-imaging_1.1.6.bb
parent23135708dbd3684a6e4b65c8ad78b86efb7c41c4 (diff)
downloadopenembedded-966fc3fc63539a0cbedc0de1bc5284aea0bda2ad.tar.gz
python-imaging: update to 1.1.6
Diffstat (limited to 'packages/python/python-imaging_1.1.6.bb')
-rw-r--r--packages/python/python-imaging_1.1.6.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/python/python-imaging_1.1.6.bb b/packages/python/python-imaging_1.1.6.bb
new file mode 100644
index 0000000000..9f3b6323dd
--- /dev/null
+++ b/packages/python/python-imaging_1.1.6.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Python Imaging Library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "freetype jpeg tiff"
+RDEPENDS = "python-lang python-stringold"
+SRCNAME = "Imaging"
+PR = "ml0"
+
+SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
+ file://path.patch;patch=1"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_compile() {
+ export STAGING_LIBDIR=${STAGING_LIBDIR}
+ export STAGING_INCDIR=${STAGING_INCDIR}
+ distutils_do_compile
+}
+
+do_install() {
+ export STAGING_LIBDIR=${STAGING_LIBDIR}
+ export STAGING_INCDIR=${STAGING_INCDIR}
+ distutils_do_install
+ install -d ${D}${datadir}/doc/${PN}/html/
+ install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
+ install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
+
+}