aboutsummaryrefslogtreecommitdiffstats
path: root/packages/pyneo
diff options
context:
space:
mode:
authorM. Dietrich <mdt@emdete.de>2008-12-12 13:33:48 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-12-14 15:10:45 +0100
commitd8db315266254b897329ef14c10d87a07ecb84fe (patch)
tree5afaa41adbb320db33c3c813fa36459afe1297dd /packages/pyneo
parentbcdc4bd853c6d355b7d9675328dcc57524cb84a0 (diff)
downloadopenembedded-d8db315266254b897329ef14c10d87a07ecb84fe.tar.gz
gsm0710muxd: move to pyneo directory
Diffstat (limited to 'packages/pyneo')
-rw-r--r--packages/pyneo/gsm0710muxd_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/pyneo/gsm0710muxd_git.bb b/packages/pyneo/gsm0710muxd_git.bb
new file mode 100644
index 0000000000..7828500f2f
--- /dev/null
+++ b/packages/pyneo/gsm0710muxd_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "GSM 07.10 muxer userspace daemon"
+HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/gsm0710muxd"
+AUTHOR = "M. Dietrich"
+SECTION = "console/network"
+DEPENDS = "dbus dbus-glib"
+RDEPENDS = "dbus dbus-glib"
+LICENSE = "GPL"
+PV = "0.9.2+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/gsm0710muxd.git;protocol=git;branch=master"
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+# install init script for people who want to manually
+# start/stop it, but don't add runlevels.
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 data/gsm0710muxd ${D}${sysconfdir}/init.d/
+}
+
+FILES_${PN} += "${datadir} ${sysconfdir}"