aboutsummaryrefslogtreecommitdiffstats
path: root/packages/psplash/psplash_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-10-12 08:39:51 +0000
committerKoen Kooi <koen@openembedded.org>2006-10-12 08:39:51 +0000
commit90458249b3cabb3ff98d43fa724c62eae1acc0d6 (patch)
tree16bca889dd77dfe942ddd352dc2dff0afdbc8daa /packages/psplash/psplash_svn.bb
parentcebfab7d49bcdad36a871ddc7d56fcab190eca67 (diff)
downloadopenembedded-90458249b3cabb3ff98d43fa724c62eae1acc0d6.tar.gz
psplash: add a way to replace the bootup logo, currently an OE logo will be displayed
* The logo background has to be changed from white to grey to look good
Diffstat (limited to 'packages/psplash/psplash_svn.bb')
-rw-r--r--packages/psplash/psplash_svn.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/packages/psplash/psplash_svn.bb b/packages/psplash/psplash_svn.bb
index f5e2195e82..e2bdbce4b7 100644
--- a/packages/psplash/psplash_svn.bb
+++ b/packages/psplash/psplash_svn.bb
@@ -3,9 +3,15 @@ SECTION = "base"
LICENSE = "GPL"
PV = "0.0+svn${SRCDATE}"
+PR = "r1"
+
+# You can create your own pslash-hand-img.h by doing
+# ./make-image-header.sh <file>.png HAND
+# and rename the resulting .h to pslash-hand-img.h
SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
- file://psplash-init"
+ file://psplash-hand-img.h \
+ file://psplash-init"
S = "${WORKDIR}/psplash"
@@ -13,6 +19,10 @@ inherit autotools pkgconfig update-rc.d
FILES_${PN} += "/mnt/.psplash"
+do_configure_append() {
+ cp ${WORKDIR}/psplash-hand-img.h ${S}/
+}
+
do_install_prepend() {
install -d ${D}/mnt/.psplash/
install -d ${D}${sysconfdir}/init.d/