aboutsummaryrefslogtreecommitdiffstats
path: root/packages/procps/procps_3.2.7.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-10-13 12:57:13 +0000
committerKoen Kooi <koen@openembedded.org>2006-10-13 12:57:13 +0000
commit4fa2c89ec61664ea9842db12b1df01d879640ac1 (patch)
tree97f36a00f34f1ca365d4f14ae4aa7c0bae43aa50 /packages/procps/procps_3.2.7.bb
parent247469b81e9d210b2c219fc0f95d3b62249c2498 (diff)
downloadopenembedded-4fa2c89ec61664ea9842db12b1df01d879640ac1.tar.gz
procps: update to 3.2.7
Diffstat (limited to 'packages/procps/procps_3.2.7.bb')
-rw-r--r--packages/procps/procps_3.2.7.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/packages/procps/procps_3.2.7.bb b/packages/procps/procps_3.2.7.bb
new file mode 100644
index 0000000000..0aaf82a92a
--- /dev/null
+++ b/packages/procps/procps_3.2.7.bb
@@ -0,0 +1,56 @@
+LICENSE = "GPL"
+DESCRIPTION = "Procps is the package that has a bunch \
+of small useful utilities that give information \
+about processes using the /proc filesystem. The package \
+includes the programs ps, top, vmstat, w, kill, and skill."
+SECTION = "base"
+PRIORITY = "optional"
+DEPENDS = "ncurses"
+PR = "r5"
+
+SRC_URI = "http://procps.sourceforge.net/procps-${PV}.tar.gz \
+ file://install.patch;patch=1 \
+ file://procmodule.patch;patch=1 \
+ file://psmodule.patch;patch=1"
+
+
+
+inherit autotools
+FILES = "${bindir}/top.${PN} ${base_bindir}/ps.${PN} ${bindir}/uptime.${PN} ${base_bindir}/kill.${PN} \
+ ${bindir}/free.${PN} ${bindir}/w ${bindir}/watch ${bindir}/pgrep ${bindir}/pmap ${bindir}/pwdx \
+ ${bindir}/snice ${bindir}/vmstat ${bindir}/slabtop ${bindir}/pkill ${bindir}/skill ${bindir}/tload \
+ ${base_sbindir}/sysctl.${PN}"
+
+EXTRA_OEMAKE = "CFLAGS=-I${STAGING_INCDIR} \
+ CPPFLAGS=-I${STAGING_INCDIR} \
+ LDFLAGS=-L${STAGING_LIBDIR} -Wl,--rpath-link,${STAGING_LIBDIR} \
+ CURSES=-lncurses \
+ install='install -D' \
+ ldconfig=echo"
+
+do_install_append () {
+ mv ${D}${bindir}/uptime ${D}${bindir}/uptime.${PN}
+ mv ${D}${bindir}/top ${D}${bindir}/top.${PN}
+ mv ${D}${base_bindir}/kill ${D}${base_bindir}/kill.${PN}
+ mv ${D}${base_bindir}/ps ${D}${base_bindir}/ps.${PN}
+ mv ${D}${bindir}/free ${D}${bindir}/free.${PN}
+ mv ${D}${base_sbindir}/sysctl ${D}${base_sbindir}/sysctl.${PN}
+}
+
+pkg_postinst() {
+ update-alternatives --install ${bindir}/top top top.${PN} 90
+ update-alternatives --install ${bindir}/uptime uptime uptime.${PN} 90
+ update-alternatives --install ${base_bindir}/ps ps ps.${PN} 90
+ update-alternatives --install ${base_bindir}/kill kill kill.${PN} 90
+ update-alternatives --install ${bindir}/free free free.${PN} 90
+ update-alternatives --install ${base_sbindir}/sysctl sysctl sysctl.${PN} 90
+}
+
+pkg_postrm() {
+ update-alternatives --remove top top.${PN}
+ update-alternatives --remove ps ps.${PN}
+ update-alternatives --remove uptime uptime.${PN}
+ update-alternatives --remove kill kill.${PN}
+ update-alternatives --remove free free.${PN}
+ update-alternatives --remove sysctl sysctl.${PN}
+}