aboutsummaryrefslogtreecommitdiffstats
path: root/packages/procps/procps-3.2.1
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/procps/procps-3.2.1
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/procps/procps-3.2.1')
-rw-r--r--packages/procps/procps-3.2.1/.mtn2git_empty0
-rw-r--r--packages/procps/procps-3.2.1/install.patch16
-rw-r--r--packages/procps/procps-3.2.1/pagesz-not-constant.patch22
3 files changed, 38 insertions, 0 deletions
diff --git a/packages/procps/procps-3.2.1/.mtn2git_empty b/packages/procps/procps-3.2.1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/procps/procps-3.2.1/.mtn2git_empty
diff --git a/packages/procps/procps-3.2.1/install.patch b/packages/procps/procps-3.2.1/install.patch
index e69de29bb2..2d16c26f17 100644
--- a/packages/procps/procps-3.2.1/install.patch
+++ b/packages/procps/procps-3.2.1/install.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- procps-3.1.15/Makefile~install 2003-12-24 03:01:55.000000000 +0100
++++ procps-3.1.15/Makefile 2004-02-11 00:45:59.000000000 +0100
+@@ -147,7 +147,7 @@
+ ###### install
+
+ $(BINFILES) : all
+- $(install) --mode a=rx --strip $(notdir $@) $@
++ $(install) --mode a=rx $(notdir $@) $@
+
+ $(MANFILES) : all
+ $(install) --mode a=r $(notdir $@) $@
diff --git a/packages/procps/procps-3.2.1/pagesz-not-constant.patch b/packages/procps/procps-3.2.1/pagesz-not-constant.patch
index e69de29bb2..8e9e1ebfe1 100644
--- a/packages/procps/procps-3.2.1/pagesz-not-constant.patch
+++ b/packages/procps/procps-3.2.1/pagesz-not-constant.patch
@@ -0,0 +1,22 @@
+Index: procps-3.2.1/proc/devname.c
+===================================================================
+--- procps-3.2.1.orig/proc/devname.c 2004-03-18 05:43:50.000000000 +1100
++++ procps-3.2.1/proc/devname.c 2005-04-02 10:40:17.462138000 +1000
+@@ -227,7 +227,7 @@
+
+ /* number --> name */
+ unsigned dev_to_tty(char *restrict ret, unsigned chop, dev_t dev_t_dev, int pid, unsigned int flags) {
+- static char buf[PAGE_SIZE];
++ static char buf[4096];
+ char *restrict tmp = buf;
+ unsigned dev = dev_t_dev;
+ unsigned i = 0;
+@@ -249,7 +249,7 @@
+ if((flags&ABBREV_TTY) && !strncmp(tmp,"tty", 3) && tmp[3]) tmp += 3;
+ if((flags&ABBREV_PTS) && !strncmp(tmp,"pts/", 4) && tmp[4]) tmp += 4;
+ /* gotta check before we chop or we may chop someone else's memory */
+- if(chop + (unsigned long)(tmp-buf) <= sizeof buf)
++ if(chop + (unsigned long)(tmp-buf) < sizeof buf)
+ tmp[chop] = '\0';
+ /* replace non-ASCII characters with '?' and return the number of chars */
+ for(;;){