aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorJunqian Gordon Xu <xjqian@gmail.com>2008-08-04 17:38:50 +0000
committerJunqian Gordon Xu <xjqian@gmail.com>2008-08-04 17:38:50 +0000
commitff0991176a952b745d83166677939eadd0483476 (patch)
tree7b110249a180885787de45c3c011e650b1ace260 /packages/perl
parent3bdd303875cb479f311afdd6cead1ee79f7c7ea3 (diff)
downloadopenembedded-ff0991176a952b745d83166677939eadd0483476.tar.gz
liburi-perl: direct PERL_ARCHLIB to STAGING_LIBDIR_NATIVE, instead of the host env
* CAVEAT: perl/5.8.8 has to be hard coded, needs to be updated with each new perl version
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/liburi-perl_1.35.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/packages/perl/liburi-perl_1.35.bb b/packages/perl/liburi-perl_1.35.bb
index 23116aced9..5c1c427c24 100644
--- a/packages/perl/liburi-perl_1.35.bb
+++ b/packages/perl/liburi-perl_1.35.bb
@@ -2,10 +2,14 @@ DESCRIPTION = "Manipulates and accesses URI strings"
SECTION = "libs"
LICENSE = "Artistic|GPL"
#RDEPENDS += " libmime-base64-perl libnet-perl"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/URI-${PV}.tar.gz"
S = "${WORKDIR}/URI-${PV}"
inherit cpan
+
+do_configure_append() {
+ sed -i -e "s|PERL_ARCHLIB = /usr/lib/perl/5.8|PERL_ARCHLIB = ${STAGING_LIBDIR_NATIVE}/perl/5.8.8|" Makefile
+}