aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-09-26 23:17:07 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-09-26 23:17:07 +0000
commit5691a45dd69edd8cdad4b19c6ca5d50697f07f81 (patch)
tree702866f8484fb8db27a252f9dc981b665387a55b /packages/perl
parentdc5c0ee893b2b22acbcf0ede976fda4a747784a8 (diff)
downloadopenembedded-5691a45dd69edd8cdad4b19c6ca5d50697f07f81.tar.gz
perl: Add the libmodule-build perl module. This is required for anything
using the new Build.PL build system, *expect* for libmodule-build itself which can bootstrap itself.
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/libmodule-build-perl-native_0.2805.bb4
-rw-r--r--packages/perl/libmodule-build-perl_0.2805.bb16
2 files changed, 20 insertions, 0 deletions
diff --git a/packages/perl/libmodule-build-perl-native_0.2805.bb b/packages/perl/libmodule-build-perl-native_0.2805.bb
new file mode 100644
index 0000000000..65db79b150
--- /dev/null
+++ b/packages/perl/libmodule-build-perl-native_0.2805.bb
@@ -0,0 +1,4 @@
+SECTION = "libs"
+require libmodule-build-perl_${PV}.bb
+inherit native
+EXTRA_CPANFLAGS += " EXPATINCPATH='${STAGING_INCDIR}' EXPATLIBPATH='${STAGING_LIBDIR}'"
diff --git a/packages/perl/libmodule-build-perl_0.2805.bb b/packages/perl/libmodule-build-perl_0.2805.bb
new file mode 100644
index 0000000000..ef646a5c1c
--- /dev/null
+++ b/packages/perl/libmodule-build-perl_0.2805.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Module::Build - Build and install Perl modules"
+SECTION = "libs"
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/K/KW/KWILLIAMS/Module-Build-0.2805.tar.gz"
+LICENSE = "Artistic"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
+DEPENDS = "libyaml-perl-native libversion-perl-native \
+ libextutils-cbuilder-perl-native \
+ libextutils-parsexs-perl-native \
+ libarchive-tar-perl-native"
+RDEPENDS = "libyaml-perl libversion-perl libextutils-cbuilder-perl \
+ libextutils-parsexs-perl libarchive-tar-perl"
+PR = "r2"
+
+S = "${WORKDIR}/Module-Build-${PV}"
+
+inherit cpan_build