aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2007-10-29 20:31:21 +0000
committerRichard Purdie <rpurdie@rpsys.net>2007-10-29 20:31:21 +0000
commitc61d6845d6ceddacf4ddaed9ea4e46bc0b7c65c0 (patch)
tree12b0287dc9a1ea415621192a35ebad71c5b4cf31 /packages/perl
parent24587de38122fd93d807594d7aa88ae376313f2a (diff)
downloadopenembedded-c61d6845d6ceddacf4ddaed9ea4e46bc0b7c65c0.tar.gz
packages: Improve BUILD_SYS references to staging
Diffstat (limited to 'packages/perl')
-rw-r--r--packages/perl/perl_5.8.8.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/packages/perl/perl_5.8.8.bb b/packages/perl/perl_5.8.8.bb
index a3873d99fb..328b4fb5df 100644
--- a/packages/perl/perl_5.8.8.bb
+++ b/packages/perl/perl_5.8.8.bb
@@ -41,7 +41,7 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
HOSTPERL = "${STAGING_BINDIR_NATIVE}/perl${PV}"
# Where to find .so files - use the -native versions not those from the target build
-export PERLHOSTLIB = "${STAGING_DIR}/${BUILD_SYS}/lib/perl/${PV}/"
+export PERLHOSTLIB = "${STAGING_LIBDIR_NATIVE}/perl/${PV}/"
do_configure() {
# Make hostperl in build directory be the native perl
@@ -138,12 +138,12 @@ do_install() {
}
do_stage() {
install -d ${STAGING_DIR}/${HOST_SYS}/perl \
- ${STAGING_DIR}/${BUILD_SYS}/lib/perl/${PV} \
+ ${STAGING_LIBDIR_NATIVE}/perl/${PV} \
${STAGING_LIBDIR}/perl/${PV}/CORE
# target config, used by cpan.bbclass to extract version information
install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
# target configuration, used by native perl when cross-compiling
- install lib/Config_heavy.pl ${STAGING_DIR}/${BUILD_SYS}/lib/perl/${PV}/Config_heavy-target.pl
+ install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
# perl shared library headers
for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \
uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \