aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl/perl.inc
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-04-05 06:54:17 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-04-05 06:54:17 +0000
commit6589d01dfe208474892ff4fbb3cb01fb0da603c6 (patch)
treed8badf830fc4ec280cbf4bb5f96a3702556c1670 /packages/perl/perl.inc
parent4ff751b50feb7397a9909f1a684008fa17423223 (diff)
downloadopenembedded-6589d01dfe208474892ff4fbb3cb01fb0da603c6.tar.gz
perl: Move the do_configure from perl.inc into perl_5.8.4.bb since it is
only really useful for this version of perl the way it's written.
Diffstat (limited to 'packages/perl/perl.inc')
-rw-r--r--packages/perl/perl.inc22
1 files changed, 0 insertions, 22 deletions
diff --git a/packages/perl/perl.inc b/packages/perl/perl.inc
index 3e5ac504cd..cda260efcd 100644
--- a/packages/perl/perl.inc
+++ b/packages/perl/perl.inc
@@ -13,28 +13,6 @@ SRC_URI = "ftp://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
HOSTPERL="${STAGING_BINDIR_NATIVE}/perl${PV}"
-do_configure() {
- ln -sf ${HOSTPERL} ${STAGING_BINDIR_NATIVE}/hostperl
- cp ${HOSTPERL} hostperl
- cd Cross
- rm -f Makefile.SH.patch
- cp ${WORKDIR}/Makefile.SH.patch .
- cp ${WORKDIR}/config.sh-mipsel-linux .
- cp ${WORKDIR}/config.sh-i686-linux .
- cat config.sh-arm-linux | sed -e "s,arm-linux,armeb-linux,g" > config.sh-armeb-linux
- for i in config.sh-*-linux; do
- a="`echo $i|sed -e 's,^config.sh-,,; s,-linux$,,'`"
- newfile="`echo $i|sed -e 's,-linux$,-linux-uclibc,g'`"
- cat $i | sed -e "s,${a}-linux,${a}-linux-uclibc,g; \
- s,d_sockatmark='define',d_sockatmark='undef',g;" > $newfile
- done
- sed -i -e 's,./install_me_here,${D},g' config.sh-${TARGET_ARCH}-${TARGET_OS}
- rm -f config
- echo "ARCH = ${TARGET_ARCH}" > config
- echo "OS = ${TARGET_OS}" >> config
- oe_runmake patch
-}
-
do_compile() {
sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
cd Cross