aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl/perl-native_5.8.8.bb
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-04-21 02:52:14 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-04-21 02:52:14 +0000
commit9d7a595a810e75c945a6c5da1868c01fb091746a (patch)
tree95cd605515570965fddbc3987f1f87c816556bb6 /packages/perl/perl-native_5.8.8.bb
parentffb2d5eab2ae13cc66f107e6d4988b4075036144 (diff)
downloadopenembedded-9d7a595a810e75c945a6c5da1868c01fb091746a.tar.gz
perl: Add 5.8.8 and use DEFAULT_PREFERENCE to disable it until more
testing is done. Main differences from the 5.8.7 recipe are: * Always use gcc to link. Same arch's require this, while others can happily use ld. Use gcc for everything. * Fix threading issues by enabling threading in both perl-native and perl. In fact make the configurations almost identical. * No per ARCH configuration, just 32/64/le/be configs. This should stop configurations differing between arch's which made fixing things 5.8.7 difficult. Also means new ARCH's should work without any changes. * Fix up the way miniperl is handled so it shouldn't be the cause of problems for people anymore. * Stop perl-modules depending on perl-dbg, perl-pod, perl-dev etc. * In theory should work for MACHINE="native" now. Only tested for an sh4/glibc target built on an x86_64 host so far. A lot more testing and more cleanups are needed before this is ready to be enabled by default. NOTE: You must build the matching version of perl-native before attempting to build perl (that applies for any version).
Diffstat (limited to 'packages/perl/perl-native_5.8.8.bb')
-rw-r--r--packages/perl/perl-native_5.8.8.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/packages/perl/perl-native_5.8.8.bb b/packages/perl/perl-native_5.8.8.bb
new file mode 100644
index 0000000000..e14ced8691
--- /dev/null
+++ b/packages/perl/perl-native_5.8.8.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "Perl is a popular scripting language."
+HOMEPAGE = "http://www.perl.org/"
+SECTION = "libs"
+LICENSE = "Artistic|GPL"
+DEPENDS = "virtual/db-native gdbm-native"
+PR = "r0"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
+ file://Configure-multilib.patch;patch=1"
+
+S = "${WORKDIR}/perl-${PV}"
+
+inherit native
+
+do_configure () {
+ ./Configure \
+ -Dcc="${CC}" \
+ -Dcflags="${CFLAGS}" \
+ -Dldflags="${LDFLAGS}" \
+ -Dcf_by="Open Embedded" \
+ -Dprefix=${prefix} \
+ -Dvendorprefix=${prefix} \
+ -Dsiteprefix=${prefix}/local \
+ -Duseshrplib \
+ -Dusethreads \
+ -Duseithreads \
+ -Duselargefiles \
+ -Ud_dosuid \
+ -Ui_db \
+ -Ui_ndbm \
+ -Ui_gdbm \
+ -Di_shadow \
+ -Di_syslog \
+ -Duseperlio \
+ -Dman3ext=3pm \
+ -Uafs \
+ -Ud_csh \
+ -Uusesfio \
+ -Uusenm -des
+ sed 's!${STAGING_DIR}/bin!${STAGING_BINDIR}!;
+ s!${STAGING_DIR}/lib!${STAGING_LIBDIR}!' < config.sh > config.sh.new
+ mv config.sh.new config.sh
+}
+
+PARALLEL_MAKE = ""