aboutsummaryrefslogtreecommitdiffstats
path: root/packages/perl/perl-native_5.8.8.bb
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-05-04 01:34:31 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-05-04 01:34:31 +0000
commit325245976e2b28f7104994fdedeba95d1fc838ce (patch)
tree3e3a7a7902f54396ec0b62dc9151005da43e59b9 /packages/perl/perl-native_5.8.8.bb
parent55764a7c52979405d4d7c07fd92c3c5f64744494 (diff)
downloadopenembedded-325245976e2b28f7104994fdedeba95d1fc838ce.tar.gz
perl/perl-native 5.8.8: Move the creation of the hostperl link in staging
from the configure task in perl to the stage task in perl-native where it belongs - perl shouldn't be messing with the staged perl-native.
Diffstat (limited to 'packages/perl/perl-native_5.8.8.bb')
-rw-r--r--packages/perl/perl-native_5.8.8.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/packages/perl/perl-native_5.8.8.bb b/packages/perl/perl-native_5.8.8.bb
index a9333d79ee..7a3570906f 100644
--- a/packages/perl/perl-native_5.8.8.bb
+++ b/packages/perl/perl-native_5.8.8.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.perl.org/"
SECTION = "libs"
LICENSE = "Artistic|GPL"
DEPENDS = "virtual/db-native gdbm-native"
-PR = "r2"
+PR = "r3"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/perl-${PV}"
@@ -47,5 +47,9 @@ do_configure () {
s!${STAGING_DIR}/lib!${STAGING_LIBDIR}!' < config.sh > config.sh.new
mv config.sh.new config.sh
}
+do_stage_append() {
+ # We need a hostperl link for building perl
+ ln -sf ${STAGING_BINDIR_NATIVE}/perl${PV} ${STAGING_BINDIR_NATIVE}/hostperl
+}
PARALLEL_MAKE = ""