aboutsummaryrefslogtreecommitdiffstats
path: root/packages/opie-todo
diff options
context:
space:
mode:
authorMichael Krelin <hacker@klever.net>2007-10-26 12:23:56 +0000
committerMichael Krelin <hacker@klever.net>2007-10-26 12:23:56 +0000
commit36e79486430fe871d35fc062242831aa0f47126a (patch)
treeecd9bf3f61725e1b5dab2858007d22dfee0f663c /packages/opie-todo
parent98bb33889bb81a8ee23db06b5d4c75be927bf438 (diff)
downloadopenembedded-36e79486430fe871d35fc062242831aa0f47126a.tar.gz
opie-todo 1.2.3: another fix for stricter gcc.
Diffstat (limited to 'packages/opie-todo')
-rw-r--r--packages/opie-todo/files/gcc-syntax-fix.patch17
-rw-r--r--packages/opie-todo/opie-todo_1.2.3.bb3
2 files changed, 19 insertions, 1 deletions
diff --git a/packages/opie-todo/files/gcc-syntax-fix.patch b/packages/opie-todo/files/gcc-syntax-fix.patch
new file mode 100644
index 0000000000..c1b64f7a98
--- /dev/null
+++ b/packages/opie-todo/files/gcc-syntax-fix.patch
@@ -0,0 +1,17 @@
+diff --git a/quickedit.h b/quickedit.h
+index a479d9e..dc798b3 100644
+--- a/quickedit.h
++++ b/quickedit.h
+@@ -41,9 +41,9 @@ using Opie::OPimTodo;
+ namespace Todo{
+ class MainWindow;
+ struct QuickEditBase {
+- virtual OPimTodo todo()const = 0l;
+- virtual QSignal* signal() = 0l;
+- virtual QWidget* widget() = 0l;
++ virtual OPimTodo todo()const = 0;
++ virtual QSignal* signal() = 0;
++ virtual QWidget* widget() = 0;
+ };
+ /*
+ * this is my second try
diff --git a/packages/opie-todo/opie-todo_1.2.3.bb b/packages/opie-todo/opie-todo_1.2.3.bb
index f68a559f97..8f76d33bd7 100644
--- a/packages/opie-todo/opie-todo_1.2.3.bb
+++ b/packages/opie-todo/opie-todo_1.2.3.bb
@@ -4,4 +4,5 @@ PR = "r0"
SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/core/pim/todo \
${HANDHELDS_CVS};tag=${TAG};module=opie/apps \
- file://unbreak-logging.patch;patch=1"
+ file://unbreak-logging.patch;patch=1 \
+ file://gcc-syntax-fix.patch;patch=1"