aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openssh
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-04-18 01:42:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-18 01:42:32 +0000
commitf31534c088ac56d6e44e009134a170e2e786e24d (patch)
treed9f04c2854f950da8f4babd674d9bb49a51c4c46 /packages/openssh
parentfe2cdc3f39f63eda365229766238c1b031b1eb59 (diff)
downloadopenembedded-f31534c088ac56d6e44e009134a170e2e786e24d.tar.gz
openssh: Add ssh_config
Diffstat (limited to 'packages/openssh')
-rw-r--r--packages/openssh/openssh-3.8p1/ssh_config38
-rw-r--r--packages/openssh/openssh-4.0p1/ssh_config38
-rw-r--r--packages/openssh/openssh_3.8p1.bb4
-rw-r--r--packages/openssh/openssh_4.0p1.bb4
4 files changed, 82 insertions, 2 deletions
diff --git a/packages/openssh/openssh-3.8p1/ssh_config b/packages/openssh/openssh-3.8p1/ssh_config
new file mode 100644
index 0000000000..25ca7f56bd
--- /dev/null
+++ b/packages/openssh/openssh-3.8p1/ssh_config
@@ -0,0 +1,38 @@
+# $OpenBSD: ssh_config,v 1.16 2002/07/03 14:21:05 markus Exp $
+
+# This is the ssh client system-wide configuration file. See
+# ssh_config(5) for more information. This file provides defaults for
+# users, and the values can be changed in per-user configuration files
+# or on the command line.
+
+# Configuration data is parsed as follows:
+# 1. command line options
+# 2. user-specific file
+# 3. system-wide file
+# Any configuration value is only changed the first time it is set.
+# Thus, host-specific definitions should be at the beginning of the
+# configuration file, and defaults at the end.
+
+# Site-wide defaults for various options
+
+# Host *
+# ForwardAgent no
+# ForwardX11 no
+# RhostsAuthentication no
+# RhostsRSAAuthentication no
+# RSAAuthentication yes
+# PasswordAuthentication yes
+# HostbasedAuthentication no
+# BatchMode no
+# CheckHostIP yes
+# StrictHostKeyChecking ask
+# IdentityFile ~/.ssh/identity
+# IdentityFile ~/.ssh/id_rsa
+# IdentityFile ~/.ssh/id_dsa
+# Port 22
+# Protocol 2,1
+# Cipher 3des
+# Ciphers aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc
+# EscapeChar ~
+Host *
+ ForwardX11 yes
diff --git a/packages/openssh/openssh-4.0p1/ssh_config b/packages/openssh/openssh-4.0p1/ssh_config
new file mode 100644
index 0000000000..25ca7f56bd
--- /dev/null
+++ b/packages/openssh/openssh-4.0p1/ssh_config
@@ -0,0 +1,38 @@
+# $OpenBSD: ssh_config,v 1.16 2002/07/03 14:21:05 markus Exp $
+
+# This is the ssh client system-wide configuration file. See
+# ssh_config(5) for more information. This file provides defaults for
+# users, and the values can be changed in per-user configuration files
+# or on the command line.
+
+# Configuration data is parsed as follows:
+# 1. command line options
+# 2. user-specific file
+# 3. system-wide file
+# Any configuration value is only changed the first time it is set.
+# Thus, host-specific definitions should be at the beginning of the
+# configuration file, and defaults at the end.
+
+# Site-wide defaults for various options
+
+# Host *
+# ForwardAgent no
+# ForwardX11 no
+# RhostsAuthentication no
+# RhostsRSAAuthentication no
+# RSAAuthentication yes
+# PasswordAuthentication yes
+# HostbasedAuthentication no
+# BatchMode no
+# CheckHostIP yes
+# StrictHostKeyChecking ask
+# IdentityFile ~/.ssh/identity
+# IdentityFile ~/.ssh/id_rsa
+# IdentityFile ~/.ssh/id_dsa
+# Port 22
+# Protocol 2,1
+# Cipher 3des
+# Ciphers aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc
+# EscapeChar ~
+Host *
+ ForwardX11 yes
diff --git a/packages/openssh/openssh_3.8p1.bb b/packages/openssh/openssh_3.8p1.bb
index 47f6d0f88c..48fda6285f 100644
--- a/packages/openssh/openssh_3.8p1.bb
+++ b/packages/openssh/openssh_3.8p1.bb
@@ -11,11 +11,12 @@ used to provide applications with a secure communication channel."
HOMEPAGE = "http://www.openssh.org/"
LICENSE = "BSD"
MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
-PR = "r2"
+PR="r3"
SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
file://configure.patch;patch=1 \
file://scp-nossl.patch;patch=1 \
+ file://ssh_config \
file://sshd_config \
file://init"
@@ -42,6 +43,7 @@ do_configure_prepend () {
do_compile_append () {
install -m 0644 ${WORKDIR}/sshd_config ${S}/
+ install -m 0644 ${WORKDIR}/ssh_config ${S}/
}
do_install_append() {
diff --git a/packages/openssh/openssh_4.0p1.bb b/packages/openssh/openssh_4.0p1.bb
index bcfe2f370f..ee5df1421d 100644
--- a/packages/openssh/openssh_4.0p1.bb
+++ b/packages/openssh/openssh_4.0p1.bb
@@ -17,11 +17,12 @@ used to provide applications with a secure communication channel."
HOMEPAGE = "http://www.openssh.org/"
LICENSE = "BSD"
MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
-PR = "r7"
+PR = "r8"
SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
file://configure.patch;patch=1 \
file://sshd_config \
+ file://ssh_config \
file://init"
inherit autotools
@@ -48,6 +49,7 @@ do_configure_prepend () {
do_compile_append () {
install -m 0644 ${WORKDIR}/sshd_config ${S}/
+ install -m 0644 ${WORKDIR}/ssh_config ${S}/
}
do_install_append() {