aboutsummaryrefslogtreecommitdiffstats
path: root/packages/openslug-init
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-06-12 08:32:23 +0000
committerJohn Bowler <jbowler@nslu2-linux.org>2005-06-12 08:32:23 +0000
commit42fb5e07e908b84498f370eb194eee7559b0968a (patch)
treedaf7860ecfa1e80361a74d3647231f72698a2fcc /packages/openslug-init
parent16550a81257eaf81c733227f752cab5482267690 (diff)
downloadopenembedded-42fb5e07e908b84498f370eb194eee7559b0968a.tar.gz
Changes to fix population of the /dev directory in a
turnup system on first boot. BKrev: 42abf317-VPTABChzjck-YWWY6OEdA
Diffstat (limited to 'packages/openslug-init')
-rw-r--r--packages/openslug-init/openslug-init-0.10/turnup23
-rw-r--r--packages/openslug-init/openslug-init_0.10.bb2
2 files changed, 10 insertions, 15 deletions
diff --git a/packages/openslug-init/openslug-init-0.10/turnup b/packages/openslug-init/openslug-init-0.10/turnup
index a33a58ad02..c6d422a2c7 100644
--- a/packages/openslug-init/openslug-init-0.10/turnup
+++ b/packages/openslug-init/openslug-init-0.10/turnup
@@ -118,26 +118,21 @@ copy_rootfs() {
#
# setup_dev new device_table
-# Populates the /dev directory, removes the ramfs mount of /dev by
-# removing the links to the devices startup file.
+# In flash file systems /dev is in ramfs, in disk systems /dev
+# can be populated permanently. This is done by creating a
+# single entry '.noram' in /dev - the devices init script will
+# then populate the directory. The passed in device_table is
+# not currently used.
setup_dev() {
test -n "$1" -a -d "$1"/dev -a -r "$2" || {
echo "turnup: setup_dev($1,$2): expected a directory and a file" >&2
return 1
}
# at present the device_table is not used because it is incomplete,
- # /etc/init.d/devices adds extra stuff. So this script copies the
- # existing /dev. FIXME.
- echo "turnup: copying dev file system" >&2
- ( cd /
- find dev -print0 | cpio -p -0 -d -m -u "$1"
- ) || {
- echo "turnup: rootfs: cpio /dev $1 failed" >&2
- return 1
- }
- echo "done" >&2
- # now prevent this being done each time
- :>"$1"/dev/.permanent
+ # /etc/init.d/devices adds extra stuff, it seems fine to leave
+ # things this way
+ echo "turnup: initialising dev file system" >&2
+ :>"$1"/dev/.noram
return 0
}
diff --git a/packages/openslug-init/openslug-init_0.10.bb b/packages/openslug-init/openslug-init_0.10.bb
index 7b366b2173..ee619f0f31 100644
--- a/packages/openslug-init/openslug-init_0.10.bb
+++ b/packages/openslug-init/openslug-init_0.10.bb
@@ -3,7 +3,7 @@ SECTION = "console/network"
LICENSE = "GPL"
DEPENDS = "base-files devio"
RDEPENDS = "busybox devio"
-PR = "r29"
+PR = "r30"
SRC_URI = "file://linuxrc \
file://boot/flash \