aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ode
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-03-03 13:12:32 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-03-03 13:12:32 +0000
commitda9e9fc5a8680a831b5bbcb6370946e984cbbf4f (patch)
tree5fee43c157f04dbe9d3e0dfc2a9432ba3f08fa8e /packages/ode
parent478e3f6e5311c3526efd7164333605ac7d5d0c4a (diff)
downloadopenembedded-da9e9fc5a8680a831b5bbcb6370946e984cbbf4f.tar.gz
ode 0.9 fix install.patch
Diffstat (limited to 'packages/ode')
-rw-r--r--packages/ode/files/install.patch22
-rw-r--r--packages/ode/ode_0.9.bb40
2 files changed, 44 insertions, 18 deletions
diff --git a/packages/ode/files/install.patch b/packages/ode/files/install.patch
new file mode 100644
index 0000000000..d63229f8ec
--- /dev/null
+++ b/packages/ode/files/install.patch
@@ -0,0 +1,22 @@
+Index: ode-0.9/Makefile.am
+===================================================================
+--- ode-0.9.orig/Makefile.am
++++ ode-0.9/Makefile.am
+@@ -25,13 +25,13 @@ dist-zip: ${PACKAGE}-${VERSION}.tar.gz
+
+ if USE_SONAME
+ install-exec-hook:
+- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
++ ln -sf ./@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
+ $(libdir)/libode.so
+- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
++ ln -sf ./@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
+ $(libdir)/@ODE_SONAME@
+- ln -s $(libdir)/@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
++ ln -sf ./@ODE_SONAME@.@ODE_REVISION@.@ODE_AGE@ \
+ $(libdir)/@ODE_SONAME@.@ODE_REVISION@
+- /sbin/ldconfig
++ echo /sbin/ldconfig
+ else
+ install-exec-hook:
+ endif
diff --git a/packages/ode/ode_0.9.bb b/packages/ode/ode_0.9.bb
index 9055681a36..31eed3b884 100644
--- a/packages/ode/ode_0.9.bb
+++ b/packages/ode/ode_0.9.bb
@@ -5,26 +5,30 @@ LICENSE = "LGPL"
PR = "r0"
SRC_URI = "${SOURCEFORGE_MIRROR}/opende/ode-src-${PV}.zip \
- file://config.h"
+ file://install.patch;patch=1"
-inherit autotools
+inherit autotools binconfig
-#do_configure() {
-# touch configurator.exe
-# chmod a+rx configurator.exe
-# install -m 0644 ${WORKDIR}/config.h include/ode/
-#}
+EXTRA_OECONF = "--disable-demos --enable-soname"
-#do_compile() {
-# oe_runmake CC="${CC}" CFLAGS="${CFLAGS}" LD="${LD}" LDFLAGS="${LDFLAGS}" RANLIB="${RANLIB}" AR="${AR} qf " ode-lib
-#}
+do_configure_append() {
+ echo "#define dInfinity DBL_MAX" >>include/ode/config.h
+}
-#do_stage() {
-# install -d ${STAGING_INCDIR}/ode/
-# install -m 0644 include/ode/*.h ${STAGING_INCDIR}/ode/
-# oe_libinstall -C lib -a libode ${STAGING_LIBDIR}
-#}
+do_stage() {
+ oe_runmake install \
+ bindir=${STAGING_BINDIR_CROSS} \
+ libdir=${STAGING_LIBDIR} \
+ includedir=${STAGING_INCDIR} \
+ datadir=${STAGING_DATADIR}
+}
-#do_install() {
-# :
-#}
+do_install() {
+ oe_runmake install \
+ bindir=${D}${bindir} \
+ libdir=${D}${libdir} \
+ includedir=${D}${incdir} \
+ datadir=${D}${datadir}
+}
+
+FILES_${PN} = "${libdir}/lib*.so*"