aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ode
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/ode
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/ode')
-rw-r--r--packages/ode/.mtn2git_empty0
-rw-r--r--packages/ode/files/.mtn2git_empty0
-rw-r--r--packages/ode/files/config.h48
-rw-r--r--packages/ode/ode_0.5.bb28
4 files changed, 76 insertions, 0 deletions
diff --git a/packages/ode/.mtn2git_empty b/packages/ode/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ode/.mtn2git_empty
diff --git a/packages/ode/files/.mtn2git_empty b/packages/ode/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ode/files/.mtn2git_empty
diff --git a/packages/ode/files/config.h b/packages/ode/files/config.h
index e69de29bb2..8711bd91b2 100644
--- a/packages/ode/files/config.h
+++ b/packages/ode/files/config.h
@@ -0,0 +1,48 @@
+/* per-machine configuration. this file is automatically generated. */
+
+#ifndef _ODE_CONFIG_H_
+#define _ODE_CONFIG_H_
+
+/* standard system headers */
+#include <stdio.h>
+#include <stdlib.h>
+#include <math.h>
+#include <string.h>
+#include <stdarg.h>
+#include <malloc.h>
+#include <alloca.h>
+#include <values.h>
+#include <float.h>
+
+#ifdef __cplusplus
+extern "C" {
+#endif
+
+/* is this a pentium on a gcc-based platform? */
+#undef PENTIUM
+
+/* integer types (we assume int >= 32 bits) */
+typedef char int8;
+typedef unsigned char uint8;
+typedef short int16;
+typedef unsigned short uint16;
+typedef int int32;
+typedef unsigned int uint32;
+
+/* an integer type that we can safely cast a pointer to and
+ * from without loss of bits.
+ */
+typedef unsigned int intP;
+
+/* select the base floating point type */
+#define dDOUBLE 1
+
+/* the floating point infinity */
+#define dInfinity DBL_MAX
+
+/* available functions */
+
+#ifdef __cplusplus
+}
+#endif
+#endif
diff --git a/packages/ode/ode_0.5.bb b/packages/ode/ode_0.5.bb
index e69de29bb2..95fd2657cd 100644
--- a/packages/ode/ode_0.5.bb
+++ b/packages/ode/ode_0.5.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "ODE is an Open Source Physics Engine."
+SECTION = "libs"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+PR = "r0"
+LICENSE = "LGPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/opende/ode-${PV}.tgz \
+ file://config.h"
+
+do_configure() {
+ touch configurator.exe
+ chmod a+rx configurator.exe
+ install -m 0644 ${WORKDIR}/config.h include/ode/
+}
+
+do_compile() {
+ oe_runmake CC="${CC}" CFLAGS="${CFLAGS}" LD="${LD}" LDFLAGS="${LDFLAGS}" RANLIB="${RANLIB}" AR="${AR} qf " ode-lib
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/ode/
+ install -m 0644 include/ode/*.h ${STAGING_INCDIR}/ode/
+ oe_libinstall -C lib -a libode ${STAGING_LIBDIR}
+}
+
+do_install() {
+ :
+}